summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-12-30 03:20:16 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-12-30 03:20:16 +0000
commit1bdf546b3df68bfc1fddd837176558f23538a5d8 (patch)
treef83729388332e2606018dcad94ee6e7a030b43fc /sci-biology
parentAdded live qemu-kvm ebuild and sorted 0.12.1.1 deps. (diff)
downloadgentoo-2-1bdf546b3df68bfc1fddd837176558f23538a5d8.tar.gz
gentoo-2-1bdf546b3df68bfc1fddd837176558f23538a5d8.tar.bz2
gentoo-2-1bdf546b3df68bfc1fddd837176558f23538a5d8.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mothur/ChangeLog7
-rw-r--r--sci-biology/mothur/mothur-1.7.2.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/sci-biology/mothur/ChangeLog b/sci-biology/mothur/ChangeLog
index 6a9eb547b57f..4065e453f773 100644
--- a/sci-biology/mothur/ChangeLog
+++ b/sci-biology/mothur/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/mothur
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/ChangeLog,v 1.3 2009/12/29 21:14:45 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/ChangeLog,v 1.4 2009/12/30 03:20:16 weaver Exp $
+
+*mothur-1.7.2 (29 Dec 2009)
+
+ 29 Dec 2009; Andrey Kislyuk <weaver@gentoo.org> +mothur-1.7.2.ebuild:
+ Version bump
29 Dec 2009; Christian Faulhammer <fauli@gentoo.org> mothur-1.6.0.ebuild:
stable x86, bug 298777
diff --git a/sci-biology/mothur/mothur-1.7.2.ebuild b/sci-biology/mothur/mothur-1.7.2.ebuild
new file mode 100644
index 000000000000..e32acc04c3ae
--- /dev/null
+++ b/sci-biology/mothur/mothur-1.7.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.7.2.ebuild,v 1.1 2009/12/30 03:20:16 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A suite of algorithms for ecological bioinformatics"
+HOMEPAGE="http://schloss.micro.umass.edu/wiki/Main_Page"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/Mothur.source"
+
+src_prepare() {
+ sed -i -e 's/CC_OPTIONS =/CC_OPTIONS = ${CXXFLAGS} /' \
+ -e 's|CC = g++|CC = '$(tc-getCXX)'|' "${S}/makefile" || die
+}
+
+src_install() {
+ dobin mothur || die
+}