summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-20 18:20:40 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-20 18:20:40 +0000
commit9de535d44a643c817cdedb568b389f68ce22980e (patch)
tree8fbba83088c7b6d6559c040924b7cee386d7ed60 /sci-biology/fasttree/fasttree-2.0.1.ebuild
parentConvert to ruby-ng. (diff)
downloadgentoo-2-9de535d44a643c817cdedb568b389f68ce22980e.tar.gz
gentoo-2-9de535d44a643c817cdedb568b389f68ce22980e.tar.bz2
gentoo-2-9de535d44a643c817cdedb568b389f68ce22980e.zip
Respect FLAGS and fix as-needed issues wrt bug 295199. Thanks Diego for reporting.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/fasttree/fasttree-2.0.1.ebuild')
-rw-r--r--sci-biology/fasttree/fasttree-2.0.1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sci-biology/fasttree/fasttree-2.0.1.ebuild b/sci-biology/fasttree/fasttree-2.0.1.ebuild
index 532fe31e824f..7a2691703290 100644
--- a/sci-biology/fasttree/fasttree-2.0.1.ebuild
+++ b/sci-biology/fasttree/fasttree-2.0.1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/fasttree/fasttree-2.0.1.ebuild,v 1.1 2009/09/10 23:14:22 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/fasttree/fasttree-2.0.1.ebuild,v 1.2 2010/06/20 18:20:40 xarthisius Exp $
EAPI="2"
+inherit eutils toolchain-funcs
+
DESCRIPTION="Fast inference of approximately-maximum-likelihood phylogenetic trees"
HOMEPAGE="http://www.microbesonline.org/fasttree/"
#SRC_URI="http://www.microbesonline.org/fasttree/FastTree.c"
@@ -14,12 +16,17 @@ SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~x86"
-DEPEND=""
-RDEPEND=""
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
src_install() {
dobin FastTree FastTreeUPGMA || die
insinto /usr/share/${PN}
doins *.pl *.pm || die
- dodoc README*
+ dodoc README* || die
}