summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-08-09 02:28:40 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-08-09 02:28:40 +0000
commit52449b790135d0e842855c2b90b0b1c3c1ba8275 (patch)
treecc9ca2dec88c719bef2fa1d09532f2d001bf8b44 /sci-astronomy/xephem
parentFixed #229949. (diff)
downloadgentoo-2-52449b790135d0e842855c2b90b0b1c3c1ba8275.tar.gz
gentoo-2-52449b790135d0e842855c2b90b0b1c3c1ba8275.tar.bz2
gentoo-2-52449b790135d0e842855c2b90b0b1c3c1ba8275.zip
Removed installation of example INDI code. This resolves the file collisions with media-graphics/feh (see bug #224705).
(Portage version: 2.2_rc5/cvs/Linux 2.6.26-SENTINEL-1 i686)
Diffstat (limited to 'sci-astronomy/xephem')
-rw-r--r--sci-astronomy/xephem/ChangeLog6
-rw-r--r--sci-astronomy/xephem/xephem-3.7.3.ebuild14
2 files changed, 11 insertions, 9 deletions
diff --git a/sci-astronomy/xephem/ChangeLog b/sci-astronomy/xephem/ChangeLog
index cf2e2039a4c3..97e5f530f86b 100644
--- a/sci-astronomy/xephem/ChangeLog
+++ b/sci-astronomy/xephem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/xephem
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.30 2008/07/05 15:57:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.31 2008/08/09 02:28:40 markusle Exp $
+
+ 09 Aug 2008; Markus Dittrich <markusle@gentoo.org> xephem-3.7.3.ebuild:
+ Removed installation of example INDI code. This resolves the file
+ collisions with media-graphics/feh (see bug #224705).
05 Jul 2008; Markus Meier <maekke@gentoo.org> xephem-3.7.3.ebuild:
amd64 stable, bug #229885
diff --git a/sci-astronomy/xephem/xephem-3.7.3.ebuild b/sci-astronomy/xephem/xephem-3.7.3.ebuild
index 44850c1b87c9..559897f2a0f7 100644
--- a/sci-astronomy/xephem/xephem-3.7.3.ebuild
+++ b/sci-astronomy/xephem/xephem-3.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.3.ebuild,v 1.8 2008/07/05 15:57:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.3.ebuild,v 1.9 2008/08/09 02:28:40 markusle Exp $
inherit eutils
@@ -11,8 +11,7 @@ KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
IUSE=""
SLOT="0"
LICENSE="as-is"
-DEPEND="!media-gfx/feh
- x11-libs/openmotif
+DEPEND="x11-libs/openmotif
media-libs/jpeg
media-libs/libpng"
@@ -22,8 +21,8 @@ src_unpack() {
# make sure we use system libs not the ones that
# ship with the xephem tarball
- rm -fr libjpegd/ libpng/ libz/ libXm/ \
- || die "Failed to remove unneeded libs"
+ rm -fr libjpegd/ libpng/ libz/ libXm/ GUI/xephem/tools/indi \
+ || die "Failed to remove unneeded libs and tools"
epatch "${FILESDIR}"/${P}-use-system-lib.patch
for i in libastro/Makefile libip/Makefile liblilxml/Makefile \
@@ -63,11 +62,10 @@ src_install() {
into /usr
cd "${S}"/GUI/xephem
dobin xephem || die "dobin xephem failed"
- for file in tools/indi/{evalINDI,getINDI,setINDI,tmount,ota,wx,cam,security,indiserver} \
- tools/{lx200xed/lx200xed,xedb/xedb,xephemdbd/xephemdbd}; do
+ for file in tools/{lx200xed/lx200xed,xedb/xedb,xephemdbd/xephemdbd}; do
dobin ${file} || die "dobin ${file} failed"
done
- doman xephem.1 tools/*/*.1
+ doman xephem.1
mv tools .. # do not install tool sources into share directory
for i in $(find . -mindepth 1 -type d); do
insinto /usr/share/${PN}/${i}