summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-06-28 13:30:31 +0000
committerUlrich Müller <ulm@gentoo.org>2008-06-28 13:30:31 +0000
commit4587462610b65ba9a322293b6456ae54ff558f84 (patch)
tree13568aff8e097a6ec6ce4c7ff2947f128c6efcc7 /sci-astronomy/xephem
parentstable amd64, bug 229871 (diff)
downloadgentoo-2-4587462610b65ba9a322293b6456ae54ff558f84.tar.gz
gentoo-2-4587462610b65ba9a322293b6456ae54ff558f84.tar.bz2
gentoo-2-4587462610b65ba9a322293b6456ae54ff558f84.zip
Fix Motif linking problem again, bug 229761.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686)
Diffstat (limited to 'sci-astronomy/xephem')
-rw-r--r--sci-astronomy/xephem/ChangeLog6
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.3-link-motif.patch20
-rw-r--r--sci-astronomy/xephem/xephem-3.7.3.ebuild6
3 files changed, 30 insertions, 2 deletions
diff --git a/sci-astronomy/xephem/ChangeLog b/sci-astronomy/xephem/ChangeLog
index bb5cc1d09c99..ae7e94820aa5 100644
--- a/sci-astronomy/xephem/ChangeLog
+++ b/sci-astronomy/xephem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/xephem
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.24 2008/06/27 10:18:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.25 2008/06/28 13:30:30 ulm Exp $
+
+ 28 Jun 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/xephem-3.7.3-link-motif.patch, xephem-3.7.3.ebuild:
+ Fix Motif linking problem again, bug 229761.
27 Jun 2008; Ulrich Mueller <ulm@gentoo.org> xephem-3.7.2.ebuild,
xephem-3.7.3.ebuild:
diff --git a/sci-astronomy/xephem/files/xephem-3.7.3-link-motif.patch b/sci-astronomy/xephem/files/xephem-3.7.3-link-motif.patch
new file mode 100644
index 000000000000..4828d2eac39a
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.3-link-motif.patch
@@ -0,0 +1,20 @@
+--- xephem-3.7.3-orig/GUI/xephem/Makefile 2006-05-14 01:06:06.000000000 +0200
++++ xephem-3.7.3/GUI/xephem/Makefile 2008-06-28 11:23:32.000000000 +0200
+@@ -15,7 +15,7 @@
+ LIBLIB = -lastro -lip -llilxml -ljpegd -lpng -lz
+
+ # MOTIFI is the directory containing the Xm directory of include files.
+-# MOTIFL is the directory containing the libXm.a library.
++# MOTIFL is the directory containing libXm
+ # MOTIF can be used to set one common directory if desired.
+ # Defaults work ok for Linux and Mac OS X.
+ ifdef MOTIF
+@@ -34,7 +34,7 @@
+ CLDFLAGS = -g
+ CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
+ LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
+-XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11
++XLIBS = -lXm -lXp -lXt -lXext -lXmu -lX11
+ LIBS = $(XLIBS) $(LIBLIB) -lm
+
+ # for ppc Apple OS X to make universal (i386 and ppc binary), requires
diff --git a/sci-astronomy/xephem/xephem-3.7.3.ebuild b/sci-astronomy/xephem/xephem-3.7.3.ebuild
index 748e1c711124..737ea3f430b6 100644
--- a/sci-astronomy/xephem/xephem-3.7.3.ebuild
+++ b/sci-astronomy/xephem/xephem-3.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.3.ebuild,v 1.2 2008/06/27 10:18:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.3.ebuild,v 1.3 2008/06/28 13:30:30 ulm Exp $
inherit eutils
@@ -17,6 +17,10 @@ DEPEND="!media-gfx/feh
src_unpack() {
unpack ${A}
cd "${S}"
+
+ # Link against Motif shared lib, bug 229761
+ epatch "${FILESDIR}/${P}-link-motif.patch"
+
for i in libastro/Makefile libip/Makefile libjpegd/Makefile \
liblilxml/Makefile GUI/xephem/Makefile GUI/xephem/tools/*/Makefile ; do
einfo "Fixing CFLAGS in ${i}"