summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-26 21:09:54 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-26 21:09:54 +0000
commit5be9cf0b5f59f5ac697c42756fb95a6f82b2c34c (patch)
tree18a8de1059ad6bf8063df99e3b106b3f97b6a0ff /sci-astronomy/wcslib
parentRemove lldpd because it is redundant with ISC, bug 403973. (diff)
downloadgentoo-2-5be9cf0b5f59f5ac697c42756fb95a6f82b2c34c.tar.gz
gentoo-2-5be9cf0b5f59f5ac697c42756fb95a6f82b2c34c.tar.bz2
gentoo-2-5be9cf0b5f59f5ac697c42756fb95a6f82b2c34c.zip
Version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/ChangeLog7
-rw-r--r--sci-astronomy/wcslib/wcslib-4.11.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index 0e238c3188c7..894a55bde10b 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.24 2012/02/09 18:51:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.25 2012/02/26 21:09:54 xarthisius Exp $
+
+*wcslib-4.11 (26 Feb 2012)
+
+ 26 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +wcslib-4.11.ebuild:
+ Version bump
*wcslib-4.10 (09 Feb 2012)
diff --git a/sci-astronomy/wcslib/wcslib-4.11.ebuild b/sci-astronomy/wcslib/wcslib-4.11.ebuild
new file mode 100644
index 000000000000..ea9b44c83fda
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.11.ebuild,v 1.1 2012/02/26 21:09:54 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="fortran fits pgplot static-libs"
+
+RDEPEND="fortran? ( virtual/fortran )
+ fits? ( sci-libs/cfitsio )
+ pgplot? ( sci-libs/pgplot )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ $(use_enable fortran) \
+ $(use_with fits cfitsio) \
+ $(use_with pgplot)
+}
+
+src_compile() {
+ # nasty makefile, debugging means full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/lib*.a
+}