summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-05-02 12:10:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-05-02 12:10:58 +0000
commitd0a281c431e83d91d12361574e5b43bc0d4f902f (patch)
treedb10bc1f47831335a1b75b075892cbcedb66193b /sci-astronomy/stellarium
parentUpdate to last test version. (diff)
downloadgentoo-2-d0a281c431e83d91d12361574e5b43bc0d4f902f.tar.gz
gentoo-2-d0a281c431e83d91d12361574e5b43bc0d4f902f.tar.bz2
gentoo-2-d0a281c431e83d91d12361574e5b43bc0d4f902f.zip
add gcc41 patch from nyhm (bug #132005)
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'sci-astronomy/stellarium')
-rw-r--r--sci-astronomy/stellarium/ChangeLog6
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch20
-rw-r--r--sci-astronomy/stellarium/stellarium-0.8.0.ebuild8
3 files changed, 32 insertions, 2 deletions
diff --git a/sci-astronomy/stellarium/ChangeLog b/sci-astronomy/stellarium/ChangeLog
index b7229ecceb57..1a5af7c42f8f 100644
--- a/sci-astronomy/stellarium/ChangeLog
+++ b/sci-astronomy/stellarium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/stellarium
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.14 2006/05/01 23:44:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.15 2006/05/02 12:10:58 mr_bones_ Exp $
+
+ 02 May 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/stellarium-0.8.0-gcc41.patch, stellarium-0.8.0.ebuild:
+ add gcc41 patch from nyhm (bug #132005)
*stellarium-0.8.0 (01 May 2006)
diff --git a/sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch b/sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch
new file mode 100644
index 000000000000..a9a1bc379e85
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch
@@ -0,0 +1,20 @@
+--- src/s_gui.h
++++ src/s_gui.h
+@@ -510,7 +510,7 @@
+
+ private:
+ callback<void> onChangeCallback;
+- void ScrollBar::adjustSize(void);
++ void adjustSize(void);
+ Button scrollBt;
+ bool vertical;
+ unsigned int scrollOffset, scrollSize;
+@@ -837,7 +837,7 @@
+ class City
+ {
+ public:
+- City::City(const string& _name = "", const string& _state = "", const string& _country = "",
++ City(const string& _name = "", const string& _state = "", const string& _country = "",
+ double _longitude = 0.f, double _latitude = 0.f, float zone = 0, int _showatzoom = 0, int _altitude = 0);
+ void addCity(const string& _name = "", const string& _state = "", const string& _country = "",
+ double _longitude = 0.f, double _latitude = 0.f, float zone = 0, int _showatzoom = 0, int _altitude = 0);
diff --git a/sci-astronomy/stellarium/stellarium-0.8.0.ebuild b/sci-astronomy/stellarium/stellarium-0.8.0.ebuild
index aed8cac467d6..009f0e44b3a4 100644
--- a/sci-astronomy/stellarium/stellarium-0.8.0.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.8.0.ebuild,v 1.1 2006/05/01 23:44:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.8.0.ebuild,v 1.2 2006/05/02 12:10:58 mr_bones_ Exp $
inherit eutils flag-o-matic
@@ -24,6 +24,12 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
|| ( x11-libs/libXt virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+}
+
src_compile() {
append-flags -fno-strict-aliasing
econf \