summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-05 21:53:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-05 21:53:39 +0000
commit782a645ef3af58a4ace2aac05cf3784f5b638cb9 (patch)
treea176c71d7794ed2e31ae56bdc8c28fac778fb771 /sci-astronomy/skycat
parentFix further missing headers, added soname in libcgplot, and as-needed fixes (diff)
downloadgentoo-2-782a645ef3af58a4ace2aac05cf3784f5b638cb9.tar.gz
gentoo-2-782a645ef3af58a4ace2aac05cf3784f5b638cb9.tar.bz2
gentoo-2-782a645ef3af58a4ace2aac05cf3784f5b638cb9.zip
Added some missing headers, more gcc-4.3 fixes not caught during compilation
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-astronomy/skycat')
-rw-r--r--sci-astronomy/skycat/ChangeLog10
-rw-r--r--sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch32
-rw-r--r--sci-astronomy/skycat/skycat-3.0.2-r1.ebuild (renamed from sci-astronomy/skycat/skycat-3.0.1.ebuild)12
3 files changed, 45 insertions, 9 deletions
diff --git a/sci-astronomy/skycat/ChangeLog b/sci-astronomy/skycat/ChangeLog
index fc36f84a0b75..6c95d80277a2 100644
--- a/sci-astronomy/skycat/ChangeLog
+++ b/sci-astronomy/skycat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-astronomy/skycat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.3 2008/06/26 11:34:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.4 2008/11/05 21:53:39 bicatali Exp $
+
+*skycat-3.0.2-r1 (05 Nov 2008)
+
+ 05 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/skycat-3.0.1-gcc43.patch, -skycat-3.0.1.ebuild,
+ +skycat-3.0.2-r1.ebuild:
+ Added some missing headers, more gcc-4.3 fixes not caught during
+ compilation
*skycat-3.0.2 (26 Jun 2008)
diff --git a/sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch b/sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch
index c245a0d81fce..06ba0413dbf5 100644
--- a/sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch
+++ b/sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch
@@ -1,3 +1,14 @@
+--- astrotcl/generic/ImageIO.h.orig 2008-11-05 17:57:14.000000000 +0000
++++ astrotcl/generic/ImageIO.h 2008-11-05 17:57:29.000000000 +0000
+@@ -116,7 +116,7 @@
+ double unScaleValue(double d) const {return (d-bzero_)/bscale_;}
+
+ // return the size in bytes of a raw image pixel
+- int pixelSize() const {return abs(bitpix_)/8;}
++ int pixelSize() const {return fabs(bitpix_)/8;}
+
+ // member access
+ int width() const {return width_;}
--- astrotcl/generic/Fits_IO.h.orig 2006-01-12 16:43:52.000000000 +0000
+++ astrotcl/generic/Fits_IO.h 2006-09-14 11:34:20.000000000 +0100
@@ -49,7 +49,7 @@
@@ -255,6 +266,27 @@
protected:
char name_[100]; // name of application
+--- rtd/generic/histmap.c.orig 2008-11-05 18:02:25.000000000 +0000
++++ rtd/generic/histmap.c 2008-11-05 18:02:53.000000000 +0000
+@@ -17,6 +17,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "histeq.h" /* define SubrangeLink, List */
+
+
+--- rtd/generic/histzero.c.orig 2008-11-05 18:02:31.000000000 +0000
++++ rtd/generic/histzero.c 2008-11-05 18:03:08.000000000 +0000
+@@ -15,6 +15,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "histeq.h" /* define SubrangeLink */
+
+ static void merge_links();
+
--- rtd/rtdevt/rtdCLNT.h.orig 2006-01-12 16:40:00.000000000 +0000
+++ rtd/rtdevt/rtdCLNT.h 2006-09-14 11:51:56.000000000 +0100
@@ -40,52 +40,52 @@
diff --git a/sci-astronomy/skycat/skycat-3.0.1.ebuild b/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild
index 472bff1a6aa1..cf512ab56457 100644
--- a/sci-astronomy/skycat/skycat-3.0.1.ebuild
+++ b/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.1.ebuild,v 1.2 2008/06/17 08:57:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild,v 1.1 2008/11/05 21:53:39 bicatali Exp $
inherit eutils autotools
@@ -24,18 +24,15 @@ src_unpack() {
unpack ${A}
cd "${S}"
# fix buggy tcl.m4 for bash3
- epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-m4.patch
# fix old style headers, set as error by new g++
- epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-gcc43.patch
eautoconf
}
src_compile() {
- econf \
- $(use_enable threads) \
- || die "econf failed"
+ econf $(use_enable threads)
emake
- # a second time to make sure every dir passed
emake || die "emake failed"
}
@@ -43,7 +40,6 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README CHANGES VERSION
for d in tclutil astrotcl rtd cat skycat; do
- docinto ${d}
for f in README CHANGES VERSION; do
newdoc ${f} ${f}.${d}
done