summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-06-20 08:53:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-06-20 08:53:45 +0000
commitd589cecfbaab100b76fae97bb56378c3647be710 (patch)
tree282c19451ae322012561518646679e5a3d36a0d3 /net-www
parentversion dump for security reasons (diff)
downloadgentoo-2-d589cecfbaab100b76fae97bb56378c3647be710.tar.gz
gentoo-2-d589cecfbaab100b76fae97bb56378c3647be710.tar.bz2
gentoo-2-d589cecfbaab100b76fae97bb56378c3647be710.zip
version dump for security reasons
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phpBB/ChangeLog8
-rw-r--r--net-www/phpBB/Manifest5
-rw-r--r--net-www/phpBB/files/digest-phpBB-2.0.51
-rw-r--r--net-www/phpBB/phpBB-2.0.5.ebuild47
4 files changed, 57 insertions, 4 deletions
diff --git a/net-www/phpBB/ChangeLog b/net-www/phpBB/ChangeLog
index ce8cc9cc045c..99e13fcd41ee 100644
--- a/net-www/phpBB/ChangeLog
+++ b/net-www/phpBB/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/phpBB
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.2 2003/02/12 08:52:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.3 2003/06/20 08:53:37 robbat2 Exp $
+
+*phpBB-2.0.5 (20 Jun 2003)
+
+ 20 Jun 2003; Robin Johnson <robbat2@gentoo.org> phpBB-2.0.5.ebuild:
+ Version bump. Removing old ebuilds shortly as per security issue in bug
+ #23147.
*phpBB-2.0.4 (07 Feb 2003)
diff --git a/net-www/phpBB/Manifest b/net-www/phpBB/Manifest
index f6616c307cee..2edde19d54bf 100644
--- a/net-www/phpBB/Manifest
+++ b/net-www/phpBB/Manifest
@@ -1,6 +1,5 @@
-MD5 1b46bf51c102f554272de5ed35b92bb3 phpBB-2.0.5.ebuild 1498
-MD5 1b46bf51c102f554272de5ed35b92bb3 phpBB-2.0.5.ebuild~ 1498
+MD5 4a19fcfcfcffdc9ae043a36e093cb222 phpBB-2.0.5.ebuild 1498
MD5 1b46bf51c102f554272de5ed35b92bb3 phpBB-2.0.4.ebuild 1498
-MD5 b1e580706cc6c4502d2bd74549b193bd ChangeLog 344
+MD5 e3ffd195d56f5b33813705d1b0a2a438 ChangeLog 528
MD5 1c9cf1de5be80b37285838551452ebf4 files/digest-phpBB-2.0.4 63
MD5 b0e9ee3a18db6416eedbe05a7c409b36 files/digest-phpBB-2.0.5 63
diff --git a/net-www/phpBB/files/digest-phpBB-2.0.5 b/net-www/phpBB/files/digest-phpBB-2.0.5
new file mode 100644
index 000000000000..b605c09306ad
--- /dev/null
+++ b/net-www/phpBB/files/digest-phpBB-2.0.5
@@ -0,0 +1 @@
+MD5 602cf40b6ea57c042a83e394f0722fef phpBB-2.0.5.tar.gz 550182
diff --git a/net-www/phpBB/phpBB-2.0.5.ebuild b/net-www/phpBB/phpBB-2.0.5.ebuild
new file mode 100644
index 000000000000..528d18153403
--- /dev/null
+++ b/net-www/phpBB/phpBB-2.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tim Raedisch <tim.raedisch@udo.edu>
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.5.ebuild,v 1.1 2003/06/20 08:53:38 robbat2 Exp $
+
+S=${WORKDIR}/${PN}2
+DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://belnet.dl.sourceforge.net/sourceforge/phpbb/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/php"
+
+HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache2/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/phpbb ] ; then
+ ewarn "You need to unmerge your old phpBB version first."
+ ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #we need to have this empty function ... default compile hangs
+ echo "Nothing to compile"
+}
+
+src_install() {
+ cd ${S}
+ dodir ${HTTPD_ROOT}/phpbb
+ cp -r * ${D}/${HTTPD_ROOT}/phpbb
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/phpbb
+ dodoc ${S}/docs/*
+}
+
+