summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-05 14:16:44 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-05 14:16:44 +0000
commitd1371083579c273c861f53dae239c853f33116fd (patch)
treebbda3ab799e676d629f130a72e5b57e6f91ab97e /net-www
parentInitial ebuild + ChangeLog + digest (diff)
downloadgentoo-2-d1371083579c273c861f53dae239c853f33116fd.tar.gz
gentoo-2-d1371083579c273c861f53dae239c853f33116fd.tar.bz2
gentoo-2-d1371083579c273c861f53dae239c853f33116fd.zip
fix digest; tweak xft2 detection code
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/ChangeLog7
-rw-r--r--net-www/mozilla/files/digest-mozilla-1.2.12
-rw-r--r--net-www/mozilla/mozilla-1.2.1.ebuild28
3 files changed, 17 insertions, 20 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index c8b1fc2e349c..dcdc31141df5 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.60 2002/12/05 04:14:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.61 2002/12/05 14:16:44 azarah Exp $
+
+ 05 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1.ebuild :
+
+ Fix digest again. Hope mozilla devs dont make changing the tarball a
+ habit ..
*mozilla-1.2.1 (05 Dec 2002)
diff --git a/net-www/mozilla/files/digest-mozilla-1.2.1 b/net-www/mozilla/files/digest-mozilla-1.2.1
index 3b874707d4bb..2a452b7df951 100644
--- a/net-www/mozilla/files/digest-mozilla-1.2.1
+++ b/net-www/mozilla/files/digest-mozilla-1.2.1
@@ -1,4 +1,4 @@
-MD5 aa7c46d5d855367c15feda1a2dad60e7 mozilla-source-1.2.1.tar.bz2 30923315
+MD5 58c37a29ef2fae2939f5be116abec32a mozilla-source-1.2.1.tar.bz2 30919648
MD5 365b640d9ba605fdf478e2e96ce8ce89 enigmail-0.71.0.tar.gz 179703
MD5 e00bb4cdc9abb69e875f6717c110dfa7 ipc-1.0.1.tar.gz 128677
MD5 5ef5c58e501b0cb873ee2b2a04ed74e3 fcpackage.2_0.tar.gz 538159
diff --git a/net-www/mozilla/mozilla-1.2.1.ebuild b/net-www/mozilla/mozilla-1.2.1.ebuild
index 83057775f322..161dc571389a 100644
--- a/net-www/mozilla/mozilla-1.2.1.ebuild
+++ b/net-www/mozilla/mozilla-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.2.1.ebuild,v 1.1 2002/12/05 04:14:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.2.1.ebuild,v 1.2 2002/12/05 14:16:44 azarah Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome"
# Internal USE flags that I do not really want to advertise ...
@@ -113,12 +113,6 @@ moz_setup() {
export MOZILLA_OFFICIAL=1
export BUILD_OFFICIAL=1
- # enable XFT
- if [ "${DISABLE_XFT}" != "1" ]
- then
- export MOZ_ENABLE_XFT="1"
- fi
-
# make sure the nss module gets build (for NSS support)
if [ -n "`use ssl`" ]
then
@@ -240,22 +234,20 @@ src_compile() {
fi
fi
- if [ -n "${MOZ_ENABLE_XFT}" ]
+ if [ -n "`use gtk2`" ]
then
- if [ -n "`use gtk2`" ]
+ # Only enable Xft if we have Xft2.0 installed ...
+ if (test -x /usr/bin/pkg-config) && (pkg-config xft)
then
- # Only enable Xft if we have Xft2.0 installed ...
- if pkg-config xft 2> /dev/null
- then
- einfo "Building with Xft2.0 support!"
- myconf="${myconf} --enable-xft"
- else
- myconf="${myconf} --disable-xft"
- fi
- else
einfo "Building with Xft2.0 support!"
myconf="${myconf} --enable-xft"
+ else
+ ewarn "Building without Xft2.0 support!"
+ myconf="${myconf} --disable-xft"
fi
+ else
+ einfo "Building with Xft2.0 support!"
+ myconf="${myconf} --enable-xft"
fi
if [ -n "`use ipv6`" ]