summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-06-11 19:57:23 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-06-11 19:57:23 +0000
commitc2c2cf96d77116ded2a14f9317adb2144381a3a8 (patch)
tree71bb0a043420e3858b8118a862262c72531a671c /net-www
parentalpha stable (diff)
downloadgentoo-2-c2c2cf96d77116ded2a14f9317adb2144381a3a8.tar.gz
gentoo-2-c2c2cf96d77116ded2a14f9317adb2144381a3a8.tar.bz2
gentoo-2-c2c2cf96d77116ded2a14f9317adb2144381a3a8.zip
version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gnash/ChangeLog7
-rw-r--r--net-www/gnash/files/digest-gnash-0.8.03
-rw-r--r--net-www/gnash/gnash-0.8.0.ebuild125
3 files changed, 134 insertions, 1 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index 139ba5083065..1d940b58665d 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.43 2007/05/14 06:24:19 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.44 2007/06/11 19:57:23 genstef Exp $
+
+*gnash-0.8.0 (11 Jun 2007)
+
+ 11 Jun 2007; Stefan Schweizer <genstef@gentoo.org> +gnash-0.8.0.ebuild:
+ version bump
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/net-www/gnash/files/digest-gnash-0.8.0 b/net-www/gnash/files/digest-gnash-0.8.0
new file mode 100644
index 000000000000..c58c1de56149
--- /dev/null
+++ b/net-www/gnash/files/digest-gnash-0.8.0
@@ -0,0 +1,3 @@
+MD5 b3a3b22d608b5050b1b2743bc348c536 gnash-0.8.0.tar.bz2 2053076
+RMD160 6c885c283345973d27206f6e3f90635264a724ae gnash-0.8.0.tar.bz2 2053076
+SHA256 ff8c3ca6f297ad4fa7cc8fecea45119dbaf8fef7f95901c04eccbf0d6424ef84 gnash-0.8.0.tar.bz2 2053076
diff --git a/net-www/gnash/gnash-0.8.0.ebuild b/net-www/gnash/gnash-0.8.0.ebuild
new file mode 100644
index 000000000000..bd4af9fd48aa
--- /dev/null
+++ b/net-www/gnash/gnash-0.8.0.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.0.ebuild,v 1.1 2007/06/11 19:57:23 genstef Exp $
+
+inherit nsplugins kde-functions qt3 multilib
+set-kdedir
+
+DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
+HOMEPAGE="http://www.gnu.org/software/gnash"
+SRC_URI="mirror://gnu/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="agg gstreamer ffmpeg kde nsplugin xml video_cards_i810"
+#dmalloc, broken see bug 142939
+#dmalloc? ( dev-libs/dmalloc )
+# $(use_enable dmalloc) \
+
+RDEPEND="
+ xml? ( dev-libs/libxml2 )
+ sys-libs/zlib
+ media-libs/jpeg
+ media-libs/libogg
+ media-libs/libpng
+ net-misc/curl
+ !ffmpeg? ( media-libs/libmad )
+ ffmpeg? ( media-video/ffmpeg )
+ gstreamer? ( media-libs/gstreamer
+ || (
+ media-plugins/gst-plugins-ffmpeg
+ media-plugins/gst-plugins-mad
+ media-plugins/gst-plugins-lame
+ )
+ )
+ !gstreamer? ( media-libs/libsdl )
+ dev-libs/boost
+ || (
+ ( x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-proto/xproto )
+ virtual/x11
+ )
+ dev-libs/atk
+ dev-libs/glib
+ >x11-libs/gtk+-2
+ x11-libs/pango
+ !agg? ( virtual/opengl x11-libs/gtkglext )
+ kde? ( kde-base/kdelibs )
+ agg? ( x11-libs/agg )"
+ #cairo? ( x11-libs/cairo )
+
+pkg_setup() {
+ if use agg && use kde; then
+ eerror "Building klash with the agg based renderer is not supportet"
+ eerror "Please USE -kde or -agg"
+ die "kde and agg not supported at the same time"
+ fi
+
+ if has_version '<dev-libs/boost-1.34' && ! built_with_use dev-libs/boost threads; then
+ eerror "dev-libst/boost has to be built with the 'threads' USE flag"
+ die "dev-libs/boost not built with threads"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ use nsplugin && myconf="${myconf} --with-plugindir=/opt/netscape/plugins"
+
+ #--enable-renderer=engine Specify rendering engine:
+ # OpenGL (default)
+ # Cairo (experimental)
+ #cairo: does not work for plugins yet, offers flash for non-accelerated gfx?
+ #if use cairo; then
+ # myconf="${myconf} --enable-renderer=cairo"
+ #fi
+ if use agg; then
+ myconf="${myconf} --enable-renderer=agg"
+ fi
+ #--enable-gui=flavor Specify gui flavor:
+ # GTK
+ # SDL -> has no controls, we do not USE it
+ #$(use_enable gtk glext) with USE=-gtk, fails to detect gtkglext, bug 135010
+ #--enable-sound=gst,sdl
+ if use gstreamer; then
+ myconf="${myconf} --enable-sound=gst"
+ else
+ myconf="${myconf} --enable-sound=sdl"
+ fi
+
+ if use ffmpeg; then
+ myconf="${myconf} --with-mp3-decoder=ffmpeg"
+ fi
+
+ if use kde; then
+ myconf="${myconf} --enable-klash --with-qt-incl=${QTDIR}/include
+ --with-qt-lib=${QTDIR}/$(get_libdir)"
+ else
+ myconf="${myconf} --disable-klash"
+ fi
+
+ econf \
+ $(use_enable nsplugin plugin) \
+ $(use_enable xml) \
+ $(use_enable video_cards_i810 i810-lod-bias) \
+ --without-gcc-arch \
+ ${myconf} || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \
+ || rm -rf ${D}/opt
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "ALPHA"
+ ewarn "gnash is still in heavy development"
+ ewarn "please report gnash bugs upstream to the gnash devs"
+}