summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-17 00:13:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-17 00:13:25 +0000
commitb580b6ab1eb0098dfa38b292656d77f073430acf (patch)
tree6680c954e77798dee53e5864b1178cdf900b5bc0 /net-www
parentAdd patch to build fine with latest ffmpeg also when failing because of toolc... (diff)
downloadgentoo-2-b580b6ab1eb0098dfa38b292656d77f073430acf.tar.gz
gentoo-2-b580b6ab1eb0098dfa38b292656d77f073430acf.tar.bz2
gentoo-2-b580b6ab1eb0098dfa38b292656d77f073430acf.zip
Fix RUNPATH bugs by cleaning up the autotools #114418.
(Portage version: 2.0.53)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gplflash/ChangeLog10
-rw-r--r--net-www/gplflash/files/digest-gplflash-0.4.13-r11
-rw-r--r--net-www/gplflash/files/gplflash-0.4.13-build.patch37
-rw-r--r--net-www/gplflash/gplflash-0.4.13-r1.ebuild49
4 files changed, 95 insertions, 2 deletions
diff --git a/net-www/gplflash/ChangeLog b/net-www/gplflash/ChangeLog
index 1f7737605b05..bc90fab587a1 100644
--- a/net-www/gplflash/ChangeLog
+++ b/net-www/gplflash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/gplflash
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.19 2005/09/17 00:21:57 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.20 2005/12/17 00:13:25 vapier Exp $
+
+*gplflash-0.4.13-r1 (17 Dec 2005)
+
+ 17 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gplflash-0.4.13-build.patch, +gplflash-0.4.13-r1.ebuild:
+ Fix RUNPATH bugs by cleaning up the autotools #114418.
17 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/net-www/gplflash/files/digest-gplflash-0.4.13-r1 b/net-www/gplflash/files/digest-gplflash-0.4.13-r1
new file mode 100644
index 000000000000..7fd42a74bd2d
--- /dev/null
+++ b/net-www/gplflash/files/digest-gplflash-0.4.13-r1
@@ -0,0 +1 @@
+MD5 1b14c21094eb07416842ac0f5298b3f1 gplflash-0.4.13.tar.bz2 323128
diff --git a/net-www/gplflash/files/gplflash-0.4.13-build.patch b/net-www/gplflash/files/gplflash-0.4.13-build.patch
new file mode 100644
index 000000000000..b0b4f399603f
--- /dev/null
+++ b/net-www/gplflash/files/gplflash-0.4.13-build.patch
@@ -0,0 +1,37 @@
+--- lib/Makefile.am
++++ lib/Makefile.am
+@@ -1,7 +1,7 @@
+
+ INCLUDES = -I$(top_srcdir)/lib
+
+-AM_CXXFLAGS =-O3 -Wall -fno-rtti -fno-exceptions -g3
++AM_CXXFLAGS = -Wall -fno-rtti -fno-exceptions
+
+ flash_LTLIBRARIES = \
+ libflash.la
+--- plugin/Makefile.am
++++ plugin/Makefile.am
+@@ -10,21 +10,11 @@
+ # api gets control.
+ #
+
+-
+ PLUGIN_DEFINES= -DXP_UNIX -DPLUGIN_TRACE
+-OPTIMIZER=$(OPTFLAGS)
+-SHARED=-shared
+
+ libnpflash_la_SOURCES = plugin.c npunix.c
+-libnpflash_la_CFLAGS = -fpic -fPIC -DPIC $(OPTIMIZER) $(PLUGIN_DEFINES) -I../lib $(X_CFLAGS)
+-libnpflash_la_LDFLAGS = -L../lib/.libs -lflash
+-
+-install-pluginLTLIBRARIES: $(plugin_LIBRARIES)
+- mkdir -p "$(DESTDIR)$(PLUGIN_DIR)"
+- cp $(srcdir)/.libs/libnpflash.so.0.0.0 "$(DESTDIR)$(PLUGIN_DIR)/libnpflash.so"
+-
+-uninstall-pluginLTLIBRARIES: $(plugin_LIBRARIES)
+- rm -f "$(DESTDIR)$(PLUGIN_DIR)/libnpflash.so"
++libnpflash_la_CFLAGS = $(PLUGIN_DEFINES) -I$(top_builddir)/lib $(X_CFLAGS)
++libnpflash_la_LIBADD = $(top_builddir)/lib/libflash.la
+
+ # $(LIBTOOL) --mode=install -c .libs/libnpflash.so $(PLUGIN_DIR)
+
diff --git a/net-www/gplflash/gplflash-0.4.13-r1.ebuild b/net-www/gplflash/gplflash-0.4.13-r1.ebuild
new file mode 100644
index 000000000000..9ede30bfa9ae
--- /dev/null
+++ b/net-www/gplflash/gplflash-0.4.13-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/gplflash-0.4.13-r1.ebuild,v 1.1 2005/12/17 00:13:25 vapier Exp $
+
+inherit nsplugins eutils flag-o-matic autotools
+
+DESCRIPTION="free, portable, and useable alternative to the flash-decoder by Macromedia"
+HOMEPAGE="http://gplflash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -ppc64 ~sparc ~x86"
+IUSE="nosound"
+
+DEPEND="media-libs/libmad
+ media-libs/jpeg
+ sys-libs/zlib
+ virtual/x11
+ !net-www/netscape-flash
+ !media-libs/libflash"
+
+PLUGDIR="/opt/netscape/plugins"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_compile() {
+ use nosound && append-flags -DNOSOUND
+
+ # configure -- includes and libraries won't be found correctly.
+ # temporal solution is pointing configure to the exaclt location
+ # until a better solution is found. bug #79270
+ econf \
+ --with-plugin-dir=${PLUGDIR} \
+ --x-includes=/usr/include/X11/ --x-libraries=/usr/lib/ \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+ inst_plugin ${PLUGDIR}/libnpflash.so
+}