summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-02-23 23:14:49 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-02-23 23:14:49 +0000
commit48ca2f134aa78c4e6238aa0bae294c2ec9772a81 (patch)
treed74705d08722cee04c61dc9a5eb4ba0000a1c616 /net-www
parentfix non-gtk install (diff)
downloadgentoo-2-48ca2f134aa78c4e6238aa0bae294c2ec9772a81.tar.gz
gentoo-2-48ca2f134aa78c4e6238aa0bae294c2ec9772a81.tar.bz2
gentoo-2-48ca2f134aa78c4e6238aa0bae294c2ec9772a81.zip
Revision bumped cause of openssl
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.12-r11
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.12-r1.ebuild75
3 files changed, 81 insertions, 2 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index afb10fff99bc..cd9f6dd24ef2 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.11 2003/02/12 08:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.12 2003/02/23 23:14:49 mholzer Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*mod_ssl-2.8.12-r1 (21 Feb 2003)
+
+ 21 Feb 2003; Martin Holzer <mholzer@gentoo.org> mod_ssl-2.8.12-r1.ebuild :
+ Bumped Revision cause of openssl
*mod_ssl-2.8.12 (26 Oct 2002)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.12-r1 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.12-r1
new file mode 100644
index 000000000000..dfab8708a5e4
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.12-r1
@@ -0,0 +1 @@
+MD5 6d52df71a602ae150898fb8483fa22a4 mod_ssl-2.8.12-1.3.27.tar.gz 753529
diff --git a/net-www/mod_ssl/mod_ssl-2.8.12-r1.ebuild b/net-www/mod_ssl/mod_ssl-2.8.12-r1.ebuild
new file mode 100644
index 000000000000..2b7339985772
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.12-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.12-r1.ebuild,v 1.1 2003/02/23 23:14:49 mholzer Exp $
+
+MY_P=${P}-1.3.27
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="x86 ppc sparc"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="=net-www/apache-1*
+ >=dev-libs/openssl-0.9.6i"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}