summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-12-21 15:55:31 +0000
committerJim Ramsay <lack@gentoo.org>2008-12-21 15:55:31 +0000
commit2cf6ce9a2bdf1283f83c91f9dab39b291e989824 (patch)
tree0ecce4edab4256827797d8fa692f732111d961ef /net-www
parentBump to 2.24.3. Bug fixes. (diff)
downloadgentoo-2-2cf6ce9a2bdf1283f83c91f9dab39b291e989824.tar.gz
gentoo-2-2cf6ce9a2bdf1283f83c91f9dab39b291e989824.tar.bz2
gentoo-2-2cf6ce9a2bdf1283f83c91f9dab39b291e989824.zip
Version bumps to both stable 32-bit and alpha 64-bit releases. Bug #251454 Bug #239543
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r3 i686)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/netscape-flash/ChangeLog11
-rw-r--r--net-www/netscape-flash/netscape-flash-10.0.15.3.ebuild92
-rw-r--r--net-www/netscape-flash/netscape-flash-10.0.21.1_alpha.ebuild (renamed from net-www/netscape-flash/netscape-flash-10.0.20.7_alpha.ebuild)4
3 files changed, 104 insertions, 3 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 8fc91b1f933b..c3eb7fbf589b 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.84 2008/12/01 16:57:00 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.85 2008/12/21 15:55:31 lack Exp $
+
+*netscape-flash-10.0.21.1_alpha (21 Dec 2008)
+*netscape-flash-10.0.15.3 (21 Dec 2008)
+
+ 21 Dec 2008; Jim Ramsay <lack@gentoo.org>
+ +netscape-flash-10.0.15.3.ebuild, +netscape-flash-10.0.21.1_alpha.ebuild,
+ -netscape-flash-10.0.20.7_alpha.ebuild:
+ Version bumps to both stable 32-bit and alpha 64-bit releases
+ Bug #251454 Bug #239543
01 Dec 2008; Jim Ramsay <lack@gentoo.org>
netscape-flash-10.0.20.7_alpha.ebuild:
diff --git a/net-www/netscape-flash/netscape-flash-10.0.15.3.ebuild b/net-www/netscape-flash/netscape-flash-10.0.15.3.ebuild
new file mode 100644
index 000000000000..b872e7c081a4
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-10.0.15.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10.0.15.3.ebuild,v 1.1 2008/12/21 15:55:31 lack Exp $
+
+inherit nsplugins rpm
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm
+amd64? ( mirror://gentoo/flash-libcompat-0.2.tar.bz2 )"
+HOMEPAGE="http://www.adobe.com/"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-10"
+RESTRICT="strip mirror"
+
+S="${WORKDIR}"
+
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig
+ dev-libs/nss
+ net-misc/curl
+ >=sys-libs/glibc-2.4 )
+ media-fonts/corefonts"
+
+# Our new flash-libcompat suffers from the same EXESTACK problem as libcrypto
+# from app-text/acroread, so tell QA to ignore it.
+# Apparently the flash library itself also suffers from this issue
+QA_EXECSTACK="opt/flash-libcompat/libcrypto.so.0.9.7
+ opt/netscape/plugins/libflashplayer.so"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ pushd "${S}/usr/lib/flash-plugin"
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+ popd
+
+ pushd "${S}/usr/share/doc/flash-plugin-${PV}/"
+ dodoc readme.txt
+ popd
+
+ # libcurl and libnss are not currently available in any emul-linux-x86
+ # packages, so for amd64 we provide these snarfed out of other binary
+ # packages. libcurl and its ssl dependencies come from app-text/acroread;
+ # libnss and its friends come from net-libs/xulrunner-bin
+ if use amd64; then
+ exeinto /opt/flash-libcompat
+ pushd "${WORKDIR}/flash-libcompat-0.2/"
+ doexe *
+ popd
+ echo 'LDPATH="/opt/flash-libcompat"' > 99flash-libcompat
+ doenvd 99flash-libcompat
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+}
+
+pkg_postinst() {
+ ewarn "Flash player is closed-source, with a long history of security"
+ ewarn "issues. Please consider only running flash applets you know to"
+ ewarn "be safe."
+
+ if has_version 'www-client/mozilla-firefox'; then
+ elog "The firefox 'flashblock' extension may help:"
+ elog " https://addons.mozilla.org/en-US/firefox/addon/433"
+ fi
+
+ if has_version 'kde-base/konqueror'; then
+ elog "Konqueror users: You may need to follow the instructions here:"
+ elog " http://dev.gentoo.org/~lack/konqueror-flash.xml"
+ elog "For flash to work with your browser."
+ fi
+}
diff --git a/net-www/netscape-flash/netscape-flash-10.0.20.7_alpha.ebuild b/net-www/netscape-flash/netscape-flash-10.0.21.1_alpha.ebuild
index 05672525243b..5c814b386256 100644
--- a/net-www/netscape-flash/netscape-flash-10.0.20.7_alpha.ebuild
+++ b/net-www/netscape-flash/netscape-flash-10.0.21.1_alpha.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10.0.20.7_alpha.ebuild,v 1.4 2008/12/01 16:57:00 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10.0.21.1_alpha.ebuild,v 1.1 2008/12/21 15:55:31 lack Exp $
EAPI=1
inherit nsplugins
DESCRIPTION="Adobe Flash Player"
-SRC_URI="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d20.7.linux-x86_64.so.tar.gz"
+SRC_URI="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d21.1.linux-x86_64.so.tar.gz"
HOMEPAGE="http://www.adobe.com/"
IUSE=""
SLOT="0"