summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-05-09 10:27:40 +0000
committerThilo Bangert <bangert@gentoo.org>2002-05-09 10:27:40 +0000
commit511f00305d4bc0b258ab5b8c2a7ab66d95547bcd (patch)
treee0cb90afe10642c3cc67d8c060a27fea8d64f52e /net-www/publicfile
parentpublicfile - http and ftp services by djb. contrib by jakd (diff)
downloadgentoo-2-511f00305d4bc0b258ab5b8c2a7ab66d95547bcd.tar.gz
gentoo-2-511f00305d4bc0b258ab5b8c2a7ab66d95547bcd.tar.bz2
gentoo-2-511f00305d4bc0b258ab5b8c2a7ab66d95547bcd.zip
d'oh!
Diffstat (limited to 'net-www/publicfile')
-rw-r--r--net-www/publicfile/ChangeLog9
-rw-r--r--net-www/publicfile/publicfile-0.52.ebuild47
2 files changed, 56 insertions, 0 deletions
diff --git a/net-www/publicfile/ChangeLog b/net-www/publicfile/ChangeLog
new file mode 100644
index 000000000000..0128eadb8725
--- /dev/null
+++ b/net-www/publicfile/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/publicfile
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/publicfile/ChangeLog,v 1.1 2002/05/09 10:27:40 bangert Exp $
+
+*publicfile-0.52 (09 May 2002)
+
+ 09 May 2002; Thilo Bangert <bangert@gentoo.org> :
+
+ initial release - contribution by jakd@gu.st
diff --git a/net-www/publicfile/publicfile-0.52.ebuild b/net-www/publicfile/publicfile-0.52.ebuild
new file mode 100644
index 000000000000..fad69330ddc6
--- /dev/null
+++ b/net-www/publicfile/publicfile-0.52.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author jakd <jakd@gu.st>
+# $Header: /var/cvsroot/gentoo-x86/net-www/publicfile/publicfile-0.52.ebuild,v 1.1 2002/05/09 10:27:40 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="publish files through FTP and HTTP"
+SRC_URI="http://cr.yp.to/publicfile/${P}.tar.gz"
+HOMEPAGE="http://cr.yp.to/publicfile.html"
+
+LICENSE="as-is"
+
+RDEPEND=">=sys-apps/daemontools-0.70
+ >=sys-apps/ucspi-tcp-0.83"
+
+src_compile() {
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ echo "/usr" > conf-home
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ftpd httpd
+ newexe configure publicfile-conf
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+}
+
+pkg_setup() {
+ groupadd nofiles
+ id ftp || useradd -g nofiles -d /home/public ftp
+ id ftplog || useradd -g nofiles -d /home/public ftplog
+}
+
+pkg_postinst() {
+ /usr/bin/publicfile-conf ftp ftplog /home/public `hostname`
+ echo
+ echo -e "\e[32;01m httpd and ftpd are serving out of /public.\033[0m"
+ echo -e "\e[32;01m remember to start the servers with:\033[0m"
+ echo -e "\e[32;01m ln -s /public/httpd /public/ftpd /service\033[0m"
+ echo
+}
+
+pkg_postrm() {
+ userdel ftplog
+}