summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-15 16:20:54 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-15 16:20:54 +0000
commitc1fb0bcc2037b0504e560209454eac00d645aeb4 (patch)
treec4aa4810411b2773c6f2c6b5772a1984e8ae974a /net-www/netscape
parentChanged permissions of /usr/bin/crontab from 4750 to 4755. (diff)
downloadgentoo-2-c1fb0bcc2037b0504e560209454eac00d645aeb4.tar.gz
gentoo-2-c1fb0bcc2037b0504e560209454eac00d645aeb4.tar.bz2
gentoo-2-c1fb0bcc2037b0504e560209454eac00d645aeb4.zip
Added RDEPEND and PROVIDE
Diffstat (limited to 'net-www/netscape')
-rw-r--r--net-www/netscape/files/digest-navigator-4.76-r11
-rw-r--r--net-www/netscape/files/digest-netscape-4.76-r11
-rw-r--r--net-www/netscape/navigator-4.76-r1.ebuild31
-rw-r--r--net-www/netscape/netscape-4.76-r1.ebuild34
4 files changed, 67 insertions, 0 deletions
diff --git a/net-www/netscape/files/digest-navigator-4.76-r1 b/net-www/netscape/files/digest-navigator-4.76-r1
new file mode 100644
index 000000000000..bdcf7d2f2f61
--- /dev/null
+++ b/net-www/netscape/files/digest-navigator-4.76-r1
@@ -0,0 +1 @@
+MD5 dc0c4c4cfad4d7c2fc81a2d98f021090 navigator-v476-us.x86-unknown-linux2.2.tar.gz
diff --git a/net-www/netscape/files/digest-netscape-4.76-r1 b/net-www/netscape/files/digest-netscape-4.76-r1
new file mode 100644
index 000000000000..df1848676858
--- /dev/null
+++ b/net-www/netscape/files/digest-netscape-4.76-r1
@@ -0,0 +1 @@
+MD5 720de067072ff74d1e0c4aaa47eeae5c communicator-v476-us.x86-unknown-linux2.2.tar.gz
diff --git a/net-www/netscape/navigator-4.76-r1.ebuild b/net-www/netscape/navigator-4.76-r1.ebuild
new file mode 100644
index 000000000000..fdc335ac2762
--- /dev/null
+++ b/net-www/netscape/navigator-4.76-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape/navigator-4.76-r1.ebuild,v 1.1 2001/01/15 16:20:54 achim Exp $
+
+A=navigator-v476-us.x86-unknown-linux2.2.tar.gz
+S=${WORKDIR}/navigator-v476.x86-unknown-linux2.2
+DESCRIPTION="Netscape Navigator Standalone 4.76"
+SRC_URI="ftp://ftp.netscape.com/pub/communicator/english/4.76/unix/supported/linux22/navigator_standalone/"${A}
+HOMEPAGE="http://developer.netscape.com/support/index.html"
+RDEPEND=">=sys-libs/lib-compat-1.0"
+PROVIDE="virtual/x11-web-browser"
+
+src_install() {
+ cd ${S}
+ dodir /opt/netscape
+ dodir /opt/netscape/java/classes
+ dodir /usr/X11R6/bin
+ dodoc README.install
+ cd ${D}/opt/netscape
+ gzip -dc ${S}/netscape-v476.nif | tar xf -
+ gzip -dc ${S}/nethelp-v476.nif | tar xf -
+ cp ${S}/*.jar ${D}/opt/netscape/java/classes
+ cp ${O}/files/netscape ${D}/usr/X11R6/bin/netscape
+ rm ${D}/opt/netscape/netscape-dynMotif
+ rm ${D}/opt/netscape/libnullplugin-dynMotif.so
+ insinto /usr/X11R6/bin
+ doins ${FILES}/netscape
+ chmod +x ${D}/usr/X11R6/bin/netscape
+}
+
diff --git a/net-www/netscape/netscape-4.76-r1.ebuild b/net-www/netscape/netscape-4.76-r1.ebuild
new file mode 100644
index 000000000000..e30adbe447a3
--- /dev/null
+++ b/net-www/netscape/netscape-4.76-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape/netscape-4.76-r1.ebuild,v 1.1 2001/01/15 16:20:54 achim Exp $
+
+P=netscape-4.76
+A=communicator-v476-us.x86-unknown-linux2.2.tar.gz
+S=${WORKDIR}/communicator-v476.x86-unknown-linux2.2
+DESCRIPTION="Netscape Communicator 4.76"
+SRC_URI="ftp://ftp.netscape.com/pub/communicator/english/4.76/unix/supported/linux22/complete_install/"${A}
+HOMEPAGE="http://developer.netscape.com/support/index.html"
+
+RDEPEND=">=sys-libs/lib-compat-1.0"
+PROVIDE="virtual/x11-web-browser"
+
+src_install() {
+ cd ${S}
+ dodir /opt/netscape
+ dodir /opt/netscape/java/classes
+ dodir /usr/X11R6/bin
+ dodoc README.install
+ cd ${D}/opt/netscape
+ gzip -dc ${S}/netscape-v476.nif | tar xf -
+ gzip -dc ${S}/nethelp-v476.nif | tar xf -
+ gzip -dc ${S}/spellchk-v476.nif | tar xf -
+ cp ${S}/*.jar ${D}/opt/netscape/java/classes
+ cp ${O}/files/netscape ${D}/usr/X11R6/bin/netscape
+ rm ${D}/opt/netscape/netscape-dynMotif
+ rm ${D}/opt/netscape/libnullplugin-dynMotif.so
+ insinto /usr/X11R6/bin
+ doins ${FILESDIR}/netscape
+ chmod +x ${D}/usr/X11R6/bin/netscape
+}
+