summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-10-29 20:37:01 +0000
committerAchim Gottinger <achim@gentoo.org>2000-10-29 20:37:01 +0000
commit1b5ea6763da5b9159d10ad39b9546d33b1516d94 (patch)
tree53a0339c392d391a906ec8195b5c18f079d296ed /net-www/mozilla
parentNow a threaded version of perl is build. The tests pass all now. (diff)
downloadgentoo-2-1b5ea6763da5b9159d10ad39b9546d33b1516d94.tar.gz
gentoo-2-1b5ea6763da5b9159d10ad39b9546d33b1516d94.tar.bz2
gentoo-2-1b5ea6763da5b9159d10ad39b9546d33b1516d94.zip
*** empty log message ***
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/mozilla-milestone-18.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/net-www/mozilla/mozilla-milestone-18.ebuild b/net-www/mozilla/mozilla-milestone-18.ebuild
index 578fff48b8e7..6cedadbdab7e 100644
--- a/net-www/mozilla/mozilla-milestone-18.ebuild
+++ b/net-www/mozilla/mozilla-milestone-18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-milestone-18.ebuild,v 1.1 2000/10/14 12:30:18 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-milestone-18.ebuild,v 1.2 2000/10/29 20:37:00 achim Exp $
A=mozilla-source-M${PV}.tar.gz
S=${WORKDIR}/mozilla
@@ -13,7 +13,8 @@ HOMEPAGE="http://www.mozilla.org"
src_compile() {
cd ${S}
- try ./configure --prefix=/opt/mozilla --host=${CHOST}
+ try CFLAGS=\"$CFLAGS -I/usr/lib/qt/include\" ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk -enable-mathml --enable-svg
try make
}
@@ -21,7 +22,15 @@ src_compile() {
src_install () {
cd ${S}
- try make DESTDIR=${D} install
+ export MOZILLA_OFFICIAL=1
+ export BUILD_OFFICIAL=1
+ cd ${S}/xpinstall/packager
+ try make
+ dodir /opt
+ tar xzf ${S}/dist/mozilla-i686-pc-linux-gnu.tar.gz -C ${D}/opt
+ mv ${D}/opt/package ${D}/opt/mozilla
+ dodoc LEGAL LICENSE README/mozilla/README*
+
}