summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-01-05 05:03:08 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-01-05 05:03:08 +0000
commite0d19c1d4edb200dcafa40ed35757c99729d016c (patch)
treeadebf42bd2bdfe722700ebe5068ef9ba14c1e649 /net-wireless
parentadd missing doc to IUSE (diff)
downloadgentoo-2-e0d19c1d4edb200dcafa40ed35757c99729d016c.tar.gz
gentoo-2-e0d19c1d4edb200dcafa40ed35757c99729d016c.tar.bz2
gentoo-2-e0d19c1d4edb200dcafa40ed35757c99729d016c.zip
Initial version of iw for aircrack-ng, ebuild contributions by Roel Aaij and
Pierre Guinoiseau, bug 233285. (Portage version: 2.1.6.4/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/iw/ChangeLog12
-rw-r--r--net-wireless/iw/files/iw-0_p20080605-ldflags.patch45
-rw-r--r--net-wireless/iw/iw-0_p20080605.ebuild29
-rw-r--r--net-wireless/iw/metadata.xml9
4 files changed, 95 insertions, 0 deletions
diff --git a/net-wireless/iw/ChangeLog b/net-wireless/iw/ChangeLog
new file mode 100644
index 000000000000..3003b04e2601
--- /dev/null
+++ b/net-wireless/iw/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-wireless/iw
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/iw/ChangeLog,v 1.1 2009/01/05 05:03:08 rbu Exp $
+
+*iw-0_p20080605 (05 Jan 2009)
+
+ 05 Jan 2009; Robert Buchholz <rbu@gentoo.org>
+ +files/iw-0_p20080605-ldflags.patch, +metadata.xml,
+ +iw-0_p20080605.ebuild:
+ Initial version of iw for aircrack-ng, ebuild contributions by Roel Aaij and
+ Pierre Guinoiseau, bug 233285.
+
diff --git a/net-wireless/iw/files/iw-0_p20080605-ldflags.patch b/net-wireless/iw/files/iw-0_p20080605-ldflags.patch
new file mode 100644
index 000000000000..80f2aa012b69
--- /dev/null
+++ b/net-wireless/iw/files/iw-0_p20080605-ldflags.patch
@@ -0,0 +1,45 @@
+From 28da3ed85b4f876b91d9412f83cefb0318185c8e Mon Sep 17 00:00:00 2001
+From: Robert Buchholz <rbu@goodpoint.de>
+Date: Mon, 5 Jan 2009 05:53:56 +0100
+Subject: [PATCH] Make iw use LIBS instead of LDFLAGS
+
+When linking with LDFLAGS such as -Wl,--as-needed, gcc behaves
+strictly with respect to the order of object and libraries.
+LDFLAGS need to be specified before objects whereas libraries
+need to be specified after objects using their symbols.
+
+Furthermore, do not impose -O2 -g CFLAGS on anyone who
+has global CFLAGS defined.
+---
+ Makefile | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index f8f07ed..1f1ce44 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+ MAKEFLAGS += --no-print-directory
+
+ CC ?= "gcc"
++CFLAGS ?= -O2 -g
+ CFLAGS += -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration
+ CFLAGS += -I/lib/modules/`uname -r`/build/include
+-CFLAGS += -O2 -g
+-LDFLAGS += -lnl
++LIBS += -lnl
+
+ OBJS = iw.o interface.o info.o station.o util.o mpath.o
+ ALL = iw
+@@ -25,7 +25,7 @@ all: $(ALL)
+
+ iw: $(OBJS)
+ @$(NQ) ' LD ' iw
+- $(Q)$(CC) $(LDFLAGS) $(OBJS) -o iw
++ $(Q)$(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o iw
+
+ check:
+ $(Q)$(MAKE) all CC="REAL_CC=$(CC) CHECK=\"sparse -Wall\" cgcc"
+--
+1.6.0.4
+
diff --git a/net-wireless/iw/iw-0_p20080605.ebuild b/net-wireless/iw/iw-0_p20080605.ebuild
new file mode 100644
index 000000000000..28ebcc0d8c93
--- /dev/null
+++ b/net-wireless/iw/iw-0_p20080605.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/iw/iw-0_p20080605.ebuild,v 1.1 2009/01/05 05:03:08 rbu Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="nl80211 userspace tool for use with aircrack-ng"
+HOMEPAGE="http://www.aircrack-ng.org"
+SRC_URI="http://dl.aircrack-ng.org/${PN}.tar.bz2 -> ${P}.tar.bz2"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/libnl-1.1"
+RDEPEND="${DEPEND}"
+
+CC=$(tc-getCC)
+LD=$(tc-getLD)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+}
diff --git a/net-wireless/iw/metadata.xml b/net-wireless/iw/metadata.xml
new file mode 100644
index 000000000000..ad08de8df302
--- /dev/null
+++ b/net-wireless/iw/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>rbu@gentoo.org</email>
+ <name>Robert Buchholz</name>
+</maintainer>
+<herd>netmon</herd>
+</pkgmetadata>