summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2007-04-24 03:47:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2007-04-24 03:47:33 +0000
commit943126b1f5b0f6c92bb46e602ee05979df063e13 (patch)
tree57cad44714fd10371d91c3f9a7fe9094ad18c505 /net-wireless
parentVersion bump to 22.0.99. (diff)
downloadgentoo-2-943126b1f5b0f6c92bb46e602ee05979df063e13.tar.gz
gentoo-2-943126b1f5b0f6c92bb46e602ee05979df063e13.tar.bz2
gentoo-2-943126b1f5b0f6c92bb46e602ee05979df063e13.zip
Version bump to fix bug 157600 which affected a lot of people, and is a trivial bump. Blame Seemant if your toes have been stepped on
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/libbtctl/ChangeLog10
-rw-r--r--net-wireless/libbtctl/files/digest-libbtctl-0.8.23
-rw-r--r--net-wireless/libbtctl/libbtctl-0.8.2.ebuild54
3 files changed, 65 insertions, 2 deletions
diff --git a/net-wireless/libbtctl/ChangeLog b/net-wireless/libbtctl/ChangeLog
index 87ad4d1c00a8..a7801c218d91 100644
--- a/net-wireless/libbtctl/ChangeLog
+++ b/net-wireless/libbtctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/libbtctl
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/ChangeLog,v 1.32 2006/11/05 21:30:38 peper Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/ChangeLog,v 1.33 2007/04/24 03:47:33 seemant Exp $
+
+*libbtctl-0.8.2 (24 Apr 2007)
+
+ 24 Apr 2007; Seemant Kulleen <seemant@gentoo.org> +libbtctl-0.8.2.ebuild:
+ Version bump to fix bug 157600 which affected a lot of people, and is a
+ trivial bump. Blame Seemant if your toes have been stepped on
05 Nov 2006; Piotr Jaroszyński <peper@gentoo.org> libbtctl-0.8.1.ebuild:
Add auto* deps. Thanks to Matthias Schwarzott <zzam@gentoo.org> in bug #154138.
diff --git a/net-wireless/libbtctl/files/digest-libbtctl-0.8.2 b/net-wireless/libbtctl/files/digest-libbtctl-0.8.2
new file mode 100644
index 000000000000..b730112da2b9
--- /dev/null
+++ b/net-wireless/libbtctl/files/digest-libbtctl-0.8.2
@@ -0,0 +1,3 @@
+MD5 00966e109db14f14589739a85fe00941 libbtctl-0.8.2.tar.bz2 324778
+RMD160 fbf50df97c7a23c29037c0f1b22383eb01588e04 libbtctl-0.8.2.tar.bz2 324778
+SHA256 568b13d5f35b5ea994e5f23e56b7685ec171dae9e5da2d3e8ea9196ea77ece1f libbtctl-0.8.2.tar.bz2 324778
diff --git a/net-wireless/libbtctl/libbtctl-0.8.2.ebuild b/net-wireless/libbtctl/libbtctl-0.8.2.ebuild
new file mode 100644
index 000000000000..e6305f182a26
--- /dev/null
+++ b/net-wireless/libbtctl/libbtctl-0.8.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.8.2.ebuild,v 1.1 2007/04/24 03:47:33 seemant Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit gnome2 multilib mono autotools
+
+DESCRIPTION="A GObject wrapper for Bluetooth functionality"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="mono doc"
+
+RDEPEND=">=dev-libs/glib-2
+ >=net-wireless/bluez-utils-2.25
+ >=net-wireless/bluez-libs-2.25
+ >=dev-libs/openobex-1.2
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.0
+ !sparc? (
+ mono? (
+ >=dev-lang/mono-0.96
+ =dev-dotnet/gtk-sharp-1.0*
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="README NEWS ChangeLog AUTHORS COPYING"
+USE_DESTDIR="yes"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix multilib
+ sed -e "s:\/lib\/:\/$(get_libdir)\/:" -i src/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ use sparc || G2CONF=$(use_enable mono)
+ gnome2_src_configure
+ sed -i -e 's/libext="a/& la/' libtool
+ emake || die "make failed"
+}