summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-12-18 22:09:53 +0000
committerPeter Johanson <latexer@gentoo.org>2003-12-18 22:09:53 +0000
commit524f419f428602105aec43e8652a6b3fee94711d (patch)
treeb0feb74871c4a13eb602d1b7886ff5c8b5e3ca73 /net-wireless
parentInitial import. Ebuild by yours truly (diff)
downloadgentoo-2-524f419f428602105aec43e8652a6b3fee94711d.tar.gz
gentoo-2-524f419f428602105aec43e8652a6b3fee94711d.tar.bz2
gentoo-2-524f419f428602105aec43e8652a6b3fee94711d.zip
Initial import. Ebuild by yours truly
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/waproamd/ChangeLog11
-rw-r--r--net-wireless/waproamd/Manifest8
-rw-r--r--net-wireless/waproamd/files/digest-waproamd-0.41
-rw-r--r--net-wireless/waproamd/files/waproamd.confd14
-rw-r--r--net-wireless/waproamd/files/waproamd.initd38
-rw-r--r--net-wireless/waproamd/metadata.xml11
-rw-r--r--net-wireless/waproamd/waproamd-0.4.ebuild34
7 files changed, 113 insertions, 4 deletions
diff --git a/net-wireless/waproamd/ChangeLog b/net-wireless/waproamd/ChangeLog
new file mode 100644
index 000000000000..c7d6d76a1e83
--- /dev/null
+++ b/net-wireless/waproamd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-wireless/waproamd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/waproamd/ChangeLog,v 1.1 2003/12/18 22:09:45 latexer Exp $
+
+*waproamd-0.4 (18 Dec 2003)
+
+ 18 Dec 2003; Peter Johanson <latexer@gentoo.org> metadata.xml,
+ waproamd-0.4.ebuild, files/waproamd.confd, files/waproamd.initd:
+ Initial import. Ebuild and initscript by yours truly. In combination with
+ ifplugd, this is a *handy* little daemon
+
diff --git a/net-wireless/waproamd/Manifest b/net-wireless/waproamd/Manifest
index 105ad1de500f..06c3c3dd686f 100644
--- a/net-wireless/waproamd/Manifest
+++ b/net-wireless/waproamd/Manifest
@@ -1,6 +1,6 @@
-MD5 d9fc28512dbe5fa26a670ba084bb5f38 waproamd-0.4.ebuild 680
-MD5 fee6011c0b364adf8f64b7965187ca9e ChangeLog 411
+MD5 53c6c2c3f9df61450245c536599fbb86 waproamd-0.4.ebuild 799
+MD5 bd97d62e9cee95183b3e3ead4b4c236a ChangeLog 506
MD5 a2aa67a22dd7eea0ab0662fa8a65c615 metadata.xml 568
-MD5 cae89a9770a0f445e496320a4db5cd92 files/waproamd.confd 357
-MD5 5a1cb37b64fe151eedfd5ced023e9f73 files/waproamd.initd 883
+MD5 c0c45e06231aceeb6970b76c7dfb4d88 files/waproamd.confd 434
+MD5 2e24d5f3470d705a971d9e2c5f510e61 files/waproamd.initd 905
MD5 4f49f6ad335f1b7cf6b9595e3afbc9d3 files/digest-waproamd-0.4 64
diff --git a/net-wireless/waproamd/files/digest-waproamd-0.4 b/net-wireless/waproamd/files/digest-waproamd-0.4
new file mode 100644
index 000000000000..7e971c73bb7a
--- /dev/null
+++ b/net-wireless/waproamd/files/digest-waproamd-0.4
@@ -0,0 +1 @@
+MD5 70bf747834e02738dec5c88c1df22495 waproamd-0.4.tar.gz 121175
diff --git a/net-wireless/waproamd/files/waproamd.confd b/net-wireless/waproamd/files/waproamd.confd
new file mode 100644
index 000000000000..a937b8bee5e4
--- /dev/null
+++ b/net-wireless/waproamd/files/waproamd.confd
@@ -0,0 +1,14 @@
+# Configuration file for waproamd
+# Peter Johanson <latexer@gentoo.org>
+
+# INTERFACES="auto" if you'd like the devices to be determined automagically
+INTERFACES="wlan0"
+
+# Additional parameters for waproamd.
+# (Run "waproamd -h" for further information.)
+ARGS="-wM"
+
+# Additional parameters for waproamd for the specified interface. Note
+# that $ARGS is ignored, when a variable like this is set for an
+# interface
+#ARGS_wlan0="-wM"
diff --git a/net-wireless/waproamd/files/waproamd.initd b/net-wireless/waproamd/files/waproamd.initd
new file mode 100644
index 000000000000..7c352ea74096
--- /dev/null
+++ b/net-wireless/waproamd/files/waproamd.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+
+# waproamd initscript adapted by Peter Johanson <latexer@gentoo.org>
+#
+# Configuration resides in /etc/conf.d/waproamd.conf instead of
+# /etc/waproamd/waproamd.conf
+
+get_config() {
+ if [ -z "${INTERFACES}" -o "x${INTERFACES}" = "xauto" ]
+ then
+ INTERFACES="`cat /proc/net/wireless | awk '{ print $1 }' | egrep '^[wlan|eth]' | cut -d: -f1`"
+ fi
+}
+
+start() {
+ get_config
+ ebegin "Starting Wireless Access Point Roaming Daemon:"
+ for IF in $INTERFACES ; do
+ ebegin " ${IF}"
+ A="`eval echo \$\{ARGS_${IF}\}`"
+ [ -z "$A" ] && A="$ARGS"
+ /usr/sbin/waproamd -i $IF $A
+ eend $?
+ done
+ save_options "ifaces" "${INTERFACES}"
+ eend $?
+}
+
+stop() {
+ INTERFACES="$(get_options 'ifaces')"
+ ebegin "Stopping Wireless Access Point Roaming Daemon:"
+ for IF in $INTERFACES ; do
+ ebegin " ${IF}"
+ /usr/sbin/waproamd -k -i $IF
+ eend $?
+ done
+ eend $?
+}
diff --git a/net-wireless/waproamd/metadata.xml b/net-wireless/waproamd/metadata.xml
new file mode 100644
index 000000000000..23fff6ad2086
--- /dev/null
+++ b/net-wireless/waproamd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile</herd>
+<maintainer>
+ <email>latexer@gentoo.org</email>
+ <name>Peter Johanson</name>
+ <description>This is about the most useful wireless config daemon out there. I'm here to make sure it jives in gentoo.</description>
+</maintainer>
+<longdescription>waproamd provides an easy way to handle roaming with wireless cards, in particular with setting WEP keys based on either ESSID or AP MAC address.</longdescription>
+</pkgmetadata>
diff --git a/net-wireless/waproamd/waproamd-0.4.ebuild b/net-wireless/waproamd/waproamd-0.4.ebuild
new file mode 100644
index 000000000000..98b4847ef697
--- /dev/null
+++ b/net-wireless/waproamd/waproamd-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/waproamd/waproamd-0.4.ebuild,v 1.1 2003/12/18 22:09:45 latexer Exp $
+
+DESCRIPTION="Wireless roaming daemon for configuring wireless settings"
+
+HOMEPAGE="http://www.stud.uni-hamburg.de/~lennart/projects/waproamd/"
+SRC_URI="http://0pointer.de/lennart/projects/waproamd/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/libdaemon"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp ${FILESDIR}/waproamd.initd ${S}/conf/waproamd.init.in
+}
+
+src_compile() {
+ econf --disable-lynx || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc README
+ insinto /etc/conf.d
+ newins ${FILESDIR}/waproamd.confd waproamd
+}