summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-03-22 13:36:54 +0000
committerPacho Ramos <pacho@gentoo.org>2015-03-22 13:36:54 +0000
commit21c30f39ddf6f768ce8ef17cb990c93b7da7d6f6 (patch)
tree694ba7cadddd71ba728cf52a4de57e24a221ce26 /net-wireless
parentAdd missing DEPEND on dev-libs/qjson, bug #543786. (diff)
downloadgentoo-2-21c30f39ddf6f768ce8ef17cb990c93b7da7d6f6.tar.gz
gentoo-2-21c30f39ddf6f768ce8ef17cb990c93b7da7d6f6.tar.bz2
gentoo-2-21c30f39ddf6f768ce8ef17cb990c93b7da7d6f6.zip
Version bump, try both udevadm paths (#539844 by Rick Harris), drop old.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/ChangeLog8
-rw-r--r--net-wireless/bluez/bluez-5.29.ebuild (renamed from net-wireless/bluez/bluez-5.27.ebuild)28
-rw-r--r--net-wireless/bluez/files/bluez-udevadm-path.patch10
3 files changed, 32 insertions, 14 deletions
diff --git a/net-wireless/bluez/ChangeLog b/net-wireless/bluez/ChangeLog
index f625d152bea3..e7ca744e79da 100644
--- a/net-wireless/bluez/ChangeLog
+++ b/net-wireless/bluez/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/bluez
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.236 2015/03/03 08:34:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.237 2015/03/22 13:36:53 pacho Exp $
+
+*bluez-5.29 (22 Mar 2015)
+
+ 22 Mar 2015; Pacho Ramos <pacho@gentoo.org> +bluez-5.29.ebuild,
+ +files/bluez-udevadm-path.patch, -bluez-5.27.ebuild:
+ Version bump, try both udevadm paths (#539844 by Rick Harris), drop old.
03 Mar 2015; Michał Górny <mgorny@gentoo.org> bluez-5.28.ebuild:
Remove broken REQUIRED_USE and correct deps for python-any-r1.
diff --git a/net-wireless/bluez/bluez-5.27.ebuild b/net-wireless/bluez/bluez-5.29.ebuild
index 36727093b946..bc427a457ae1 100644
--- a/net-wireless/bluez/bluez-5.27.ebuild
+++ b/net-wireless/bluez/bluez-5.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-5.27.ebuild,v 1.2 2015/02/11 16:10:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-5.29.ebuild,v 1.1 2015/03/22 13:36:53 pacho Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
@@ -15,7 +15,6 @@ LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0/3"
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
IUSE="cups debug +obex +readline selinux systemd test +udev"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
CDEPEND="
>=dev-libs/glib-2.28:2
@@ -32,12 +31,16 @@ CDEPEND="
)
"
DEPEND="${CDEPEND}
+ app-arch/xz-utils
virtual/pkgconfig
test? (
- ${PYTHON_DEPS}
- >=dev-python/dbus-python-1
- dev-python/pygobject:2
- dev-python/pygobject:3
+ $(python_gen_any_dep '
+ >=dev-python/dbus-python-1[${PYTHON_USEDEP}]
+ || (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ )
+ ')
)
"
RDEPEND="${CDEPEND}
@@ -65,6 +68,10 @@ src_prepare() {
# Use static group "plugdev" if there is no ConsoleKit (or systemd logind)
epatch "${FILESDIR}"/bluez-plugdev.patch
+ # Try both udevadm paths to cover udev/systemd vs. eudev locations (#539844)
+ # http://www.spinics.net/lists/linux-bluetooth/msg58739.html
+ epatch "${FILESDIR}"/bluez-udevadm-path.patch
+
# Fedora patches
# http://www.spinics.net/lists/linux-bluetooth/msg38490.html
epatch "${FILESDIR}"/0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
@@ -146,7 +153,7 @@ multilib_src_install() {
if multilib_is_native_abi; then
emake DESTDIR="${D}" install
- # Upstream don't install this, bug #524640
+ # Upstream doesn't install this, bug #524640
# http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
# http://comments.gmane.org/gmane.linux.bluez.kernel/54564
# gatttool is only built with readline, bug #530776
@@ -171,7 +178,7 @@ multilib_src_install_all() {
keepdir /var/lib/bluetooth
# Upstream don't want people to play with them
- # But we keep installing them due 'historical' reasons
+ # But we keep installing them due to 'historical' reasons
insinto /etc/bluetooth
local d
for d in input network proximity; do
@@ -180,11 +187,6 @@ multilib_src_install_all() {
doins src/main.conf
doins src/bluetooth.conf
-# FIXME:
-# Looks like upstream installs it only for systemd, probably not needed
-# insinto /usr/share/dbus-1/system-services
-# doins src/org.bluez.service
-
newinitd "${FILESDIR}"/bluetooth-init.d-r3 bluetooth
newinitd "${FILESDIR}"/rfcomm-init.d-r2 rfcomm
diff --git a/net-wireless/bluez/files/bluez-udevadm-path.patch b/net-wireless/bluez/files/bluez-udevadm-path.patch
new file mode 100644
index 000000000000..76cd8788b7e6
--- /dev/null
+++ b/net-wireless/bluez/files/bluez-udevadm-path.patch
@@ -0,0 +1,10 @@
+--- tools/hid2hci.rules~ 2012-12-24 18:46:55.000000000 +0100
++++ tools/hid2hci.rules 2015-03-22 14:29:22.753074765 +0100
+@@ -20,6 +20,7 @@
+ # Unfortunately the only event seen is the BT device disappearing, so the mouse
+ # device needs to be chased down on the USB bus.
+ ATTR{bDeviceClass}=="e0", ATTR{bDeviceSubClass}=="01", ATTR{bDeviceProtocol}=="01", ATTR{idVendor}=="413c", \
++ ENV{REMOVE_CMD}="/usr/bin/udevadm trigger --action=change --subsystem-match=usb --property-match=HID2HCI_SWITCH=1 \
+ ENV{REMOVE_CMD}="/sbin/udevadm trigger --action=change --subsystem-match=usb --property-match=HID2HCI_SWITCH=1"
+
+ # CSR devices