summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 19:57:02 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 19:57:02 +0000
commitf6eb92870f38bfde57325bb099d2498bb0ff45ff (patch)
treed36370ffacba97746eaed8ed950b8fd5e5095d14 /net-print/pykota
parentx86 stable, bug #314899 (diff)
downloadgentoo-2-f6eb92870f38bfde57325bb099d2498bb0ff45ff.tar.gz
gentoo-2-f6eb92870f38bfde57325bb099d2498bb0ff45ff.tar.bz2
gentoo-2-f6eb92870f38bfde57325bb099d2498bb0ff45ff.zip
Use Python 2 (bug #315873). Delete call to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-print/pykota')
-rw-r--r--net-print/pykota/ChangeLog8
-rw-r--r--net-print/pykota/pykota-1.25_p2437-r1.ebuild28
2 files changed, 22 insertions, 14 deletions
diff --git a/net-print/pykota/ChangeLog b/net-print/pykota/ChangeLog
index 1cf0036a55d9..370e3a643da3 100644
--- a/net-print/pykota/ChangeLog
+++ b/net-print/pykota/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/pykota
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.24 2008/05/21 19:00:41 dev-zero Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.25 2010/06/04 19:57:02 arfrever Exp $
+
+ 04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pykota-1.25_p2437-r1.ebuild:
+ Use Python 2 (bug #315873). Delete call to deprecated python_version().
21 May 2008; Tiziano Müller <dev-zero@gentoo.org>
pykota-1.25_p2437-r1.ebuild:
diff --git a/net-print/pykota/pykota-1.25_p2437-r1.ebuild b/net-print/pykota/pykota-1.25_p2437-r1.ebuild
index fb60e4a6915e..8ca86c92d66e 100644
--- a/net-print/pykota/pykota-1.25_p2437-r1.ebuild
+++ b/net-print/pykota/pykota-1.25_p2437-r1.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437-r1.ebuild,v 1.3 2009/11/29 13:51:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437-r1.ebuild,v 1.4 2010/06/04 19:57:02 arfrever Exp $
-S=${WORKDIR}/${PN}
+EAPI="3"
+PYTHON_DEPEND="2"
-inherit python eutils distutils
+inherit distutils
-DESCRIPTION="Flexible print quota and accounting package for use with CUPS and
-lpd."
-SRC_URI="http://scriptkitty.com/files/${P}.tar.bz2"
+DESCRIPTION="Flexible print quota and accounting package for use with CUPS and lpd."
HOMEPAGE="http://www.pykota.com"
-LICENSE="GPL-2"
+SRC_URI="http://scriptkitty.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="ldap mysql postgres snmp sqlite snmp xml"
DEPEND="dev-lang/python
@@ -25,17 +27,19 @@ DEPEND="dev-lang/python
sqlite? ( =dev-python/pysqlite-2* )
snmp? ( net-analyzer/net-snmp =dev-python/pysnmp-3.4* )
xml? ( dev-python/jaxml )"
-
RDEPEND="${DEPEND}"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
+S="${WORKDIR}/${PN}"
DOCS="README MANIFEST.in TODO SECURITY NEWS CREDITS FAQ"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
mkdir -p "${D}"/etc/${PN}
- python_version
distutils_src_install
#cups backend ----------------------------------------------
mkdir -p "${D}"$(cups-config --serverbin)/backend