summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-15 13:18:41 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-15 13:18:41 +0000
commitbfa13e00579b0fb5de2daff9022097e862626805 (patch)
tree7a4226c8975dd6f02c47f866858b625a92a16a8e /net-print/cups-pdf
parentinitial release (diff)
downloadgentoo-2-bfa13e00579b0fb5de2daff9022097e862626805.tar.gz
gentoo-2-bfa13e00579b0fb5de2daff9022097e862626805.tar.bz2
gentoo-2-bfa13e00579b0fb5de2daff9022097e862626805.zip
initial release
Diffstat (limited to 'net-print/cups-pdf')
-rw-r--r--net-print/cups-pdf/ChangeLog10
-rw-r--r--net-print/cups-pdf/Manifest4
-rw-r--r--net-print/cups-pdf/cups-pdf-1.0.ebuild38
-rw-r--r--net-print/cups-pdf/files/README.gentoo20
-rw-r--r--net-print/cups-pdf/files/digest-cups-pdf-1.01
5 files changed, 71 insertions, 2 deletions
diff --git a/net-print/cups-pdf/ChangeLog b/net-print/cups-pdf/ChangeLog
new file mode 100644
index 000000000000..57ef906411e0
--- /dev/null
+++ b/net-print/cups-pdf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-print/cups-pdf
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.1 2003/07/15 13:18:33 lanius Exp $
+
+*cups-pdf-1.0 (15 Jul 2003)
+
+ 15 Jul 2003; Heinrich Wendel <lanius@gentoo.org> cups-pdf-1.0.ebuild,
+ files/README.gentoo:
+ initial release, thx to Nick Palmer <nicholas@slackers.net> (bug #17652)
+
diff --git a/net-print/cups-pdf/Manifest b/net-print/cups-pdf/Manifest
index 7222c188ae47..8c90a303b670 100644
--- a/net-print/cups-pdf/Manifest
+++ b/net-print/cups-pdf/Manifest
@@ -1,4 +1,4 @@
-MD5 5d99dcf7ad45eed231bc9334be7635b9 cups-pdf-1.0.ebuild 908
-MD5 36cbfd88827099bc9b03b89130a1f691 ChangeLog 327
+MD5 7f589148b15eececd99a9509639444e7 cups-pdf-1.0.ebuild 1009
+MD5 f66e650c8e1bb85cbc137467a8162168 ChangeLog 418
MD5 63d30955280af99d1bc5c3c73d00c038 files/README.gentoo 1141
MD5 538c06d645a95a87338ea30b2d9b35ac files/digest-cups-pdf-1.0 62
diff --git a/net-print/cups-pdf/cups-pdf-1.0.ebuild b/net-print/cups-pdf/cups-pdf-1.0.ebuild
new file mode 100644
index 000000000000..ebe62966d5eb
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/cups-pdf-1.0.ebuild,v 1.1 2003/07/15 13:18:33 lanius Exp $
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files."
+HOMEPAGE="http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/"
+MY_P="${PN}_${PV/_/}"
+SRC_URI="http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-print/cups"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ gcc ${CFLAGS} -o cups-pdf cups-pdf.c || die "Compilation failed."
+}
+
+src_install () {
+ dodir /usr/lib/cups/backend
+ exeinto /usr/lib/cups/backend
+ doexe cups-pdf
+
+ dodir /usr/share/cups/model
+ insinto /usr/share/cups/model
+ doins PostscriptColor.ppd.gz
+
+ dodoc ${FILESDIR}/README.gentoo
+}
+
+pkg_postinst () {
+ einfo "You will find some informations about cups-pdf in this file:"
+ einfo "/usr/share/doc/${PF}/README.gentoo.gz"
+}
diff --git a/net-print/cups-pdf/files/README.gentoo b/net-print/cups-pdf/files/README.gentoo
new file mode 100644
index 000000000000..a450bd62146e
--- /dev/null
+++ b/net-print/cups-pdf/files/README.gentoo
@@ -0,0 +1,20 @@
+After restarting CUPS (/etc/init.d/cupsd restart), you will be able to choose
+"Virtual Printer (PDF Printer)" when setting up a new printer in CUPS.
+
+To set up a queue for other UNIX clients you should select Postscript as vendor
+and the Color Printer as model for your new printer; queues that get their
+input from samba or netatalk (i.e. Windows, OS/2 or MacOS) can be set up as raw
+queues. On the Windows, OS/2 or MacOS system choose a color postscript driver
+for that network printer (the drivers for Minolta Page Works or HP DesignJet
+printers do a good job).
+
+Once you print to the new device the output directory (/var/spool/cups-pdf)
+will be created and all converted PDF files will be placed in subdirectories
+named after the owner of the print job. In case the owner cannot be identified
+(i.e. does not exist on the server) the output is placed in the subdirectory
+for anonymous operation (ANONYMOUS/). Furthermore, a logfile will be placed in
+/var/log/cups.
+
+The file /usr/share/cups/model/PostscriptColor.ppd.gz is a modified version of
+the Postscript.ppd.gz that comes with CUPS 1.1.15 that is able to handle color
+output.
diff --git a/net-print/cups-pdf/files/digest-cups-pdf-1.0 b/net-print/cups-pdf/files/digest-cups-pdf-1.0
new file mode 100644
index 000000000000..a0e8ea8079ee
--- /dev/null
+++ b/net-print/cups-pdf/files/digest-cups-pdf-1.0
@@ -0,0 +1 @@
+MD5 1d9942f1c4ebedf588666a147096f938 cups-pdf_1.0.tar.gz 5738