summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-08-23 03:59:00 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-08-23 03:59:00 +0000
commitcb2b9c2c64f82bda044b650b9cd98698d61c6082 (patch)
tree69febda6e7e460c44c9348a43906f619d58e183b /net-print/c2esp
parentVersion bump for stable channel release. (diff)
downloadgentoo-2-cb2b9c2c64f82bda044b650b9cd98698d61c6082.tar.gz
gentoo-2-cb2b9c2c64f82bda044b650b9cd98698d61c6082.tar.bz2
gentoo-2-cb2b9c2c64f82bda044b650b9cd98698d61c6082.zip
Add c2esp-18, a driver for certain Canon ESP series printers.
(Portage version: 2.2.0_alpha50-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-print/c2esp')
-rw-r--r--net-print/c2esp/ChangeLog10
-rw-r--r--net-print/c2esp/c2esp-18.ebuild48
-rw-r--r--net-print/c2esp/files/c2esp-18-ldflags.patch36
-rw-r--r--net-print/c2esp/metadata.xml9
4 files changed, 103 insertions, 0 deletions
diff --git a/net-print/c2esp/ChangeLog b/net-print/c2esp/ChangeLog
new file mode 100644
index 000000000000..d2c3cd9760e2
--- /dev/null
+++ b/net-print/c2esp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-print/c2esp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/c2esp/ChangeLog,v 1.1 2011/08/23 03:59:00 binki Exp $
+
+*c2esp-18 (23 Aug 2011)
+
+ 23 Aug 2011; Nathan Phillip Brink <binki@gentoo.org> +c2esp-18.ebuild,
+ +files/c2esp-18-ldflags.patch, +metadata.xml:
+ Add c2esp-18, a driver for certain Canon ESP series printers.
+
diff --git a/net-print/c2esp/c2esp-18.ebuild b/net-print/c2esp/c2esp-18.ebuild
new file mode 100644
index 000000000000..53b24fca075e
--- /dev/null
+++ b/net-print/c2esp/c2esp-18.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/c2esp/c2esp-18.ebuild,v 1.1 2011/08/23 03:59:00 binki Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}${PV}
+
+DESCRIPTION="A cups filter for Kodak ESP printers"
+HOMEPAGE="http://cupsdriverkodak.sf.net/"
+SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=media-libs/jbigkit-2.0-r1
+ >=net-print/cups-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Remove embedded media-libs/jbigkit
+ rm -f *jbig* || die
+
+ # Remove the embedded jbig files from the Makefile's dependencies:
+ sed -i \
+ -e '/^[a-z0-9.]*:/s/\$(LIBJBG)//g' \
+ -e '/^[a-z0-9.]*:/s/jbig[^ ]*\.h//g' \
+ Makefile || die
+
+ # Use Gentoo-style cups paths
+ sed -i -e s,/usr/lib/cups/filter,/usr/libexec/cups/filter,g ppd/*.ppd || die
+
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBJBG='-ljbig85 -ljbig'
+}
+
+src_install() {
+ emake DESTDIR="${D}" FILTERBIN="${D}"/usr/libexec/cups/filter install
+}
diff --git a/net-print/c2esp/files/c2esp-18-ldflags.patch b/net-print/c2esp/files/c2esp-18-ldflags.patch
new file mode 100644
index 000000000000..2a1e94740f39
--- /dev/null
+++ b/net-print/c2esp/files/c2esp-18-ldflags.patch
@@ -0,0 +1,36 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Do not ignore LDFLAGS when linking.
+
+--- a/Makefile
++++ b/Makefile
+@@ -214,7 +214,7 @@
+ #CUPSLIBS_ST = /usr/lib/libcups.a -lgssapi_krb5 -lgnutls -lz -lpthread -lm -lcrypt
+
+ c2esptst: c2esptst.o
+- $(CC) $(CFLAGS) -o $@ c2esptst.o -lcupsimage -lcups -lcupsdriver $(LIBJBG)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ c2esptst.o -lcupsimage -lcups -lcupsdriver $(LIBJBG)
+ #last $(CC) $(CFLAGS) -o $@ c2esptst.o -lcupsimage -lcups -lgssapi_krb5 -lgnutls -lz -lpthread -lm -lcrypt $(LIBJBG) libcupsdriver.a
+ #was $(CC) $(CFLAGS) -o $@ c2esptst.o -lcupsimage $(LIBJBG) libcupsdriver.a
+
+@@ -222,16 +222,16 @@
+ c2esp: c2esp.o
+ # /usr/lib/libcupsimage.so.2 replaced by -lcupsimage
+ # libcupsdriver.a removed
+- $(CC) $(CFLAGS) -o $@ c2esp.o -lcupsimage -lcups -lcupsdriver $(LIBJBG)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ c2esp.o -lcupsimage -lcups -lcupsdriver $(LIBJBG)
+ # previous version below, simplified version above
+ # $(CC) $(CFLAGS) -o $@ c2esp.o -lcups -lgssapi_krb5 -lgnutls -lz -lpthread -lm -lcrypt /usr/lib/libcupsimage.so.2 $(LIBJBG)
+
+ command2esp: command2esp.o
+ # $(CC) $(CFLAGS) -o $@ command2esp.o -lcups -lcupsdriver
+- $(CC) $(CFLAGS) -o $@ command2esp.o -lcups -lcupsdriver
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ command2esp.o -lcups -lcupsdriver
+
+ myopldecode: myopldecode.o
+- $(CC) $(CFLAGS) -g myopldecode.o $(LIBJBG) -o $@
++ $(CC) $(CFLAGS) -g $(LDFLAGS) myopldecode.o $(LIBJBG) -o $@
+
+
+ #
+
+Diff finished. Sat Aug 20 18:40:17 2011
diff --git a/net-print/c2esp/metadata.xml b/net-print/c2esp/metadata.xml
new file mode 100644
index 000000000000..7c12f3b82e46
--- /dev/null
+++ b/net-print/c2esp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+</pkgmetadata>