summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-21 12:14:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-21 12:14:47 +0000
commitfffb6dd93846e94b3da9da66a697612e4be7a2cd (patch)
tree751d6ab1ab630659f2777cd579beee547258bbf0 /net-p2p
parentStable on alpha, bug 520864 (diff)
downloadgentoo-2-fffb6dd93846e94b3da9da66a697612e4be7a2cd.tar.gz
gentoo-2-fffb6dd93846e94b3da9da66a697612e4be7a2cd.tar.bz2
gentoo-2-fffb6dd93846e94b3da9da66a697612e4be7a2cd.zip
Add libsecp256k1 to 9999
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog6
-rw-r--r--net-p2p/bitcoind/bitcoind-9999.ebuild9
-rw-r--r--net-p2p/bitcoind/files/9999-sys_libsecp256k1.patch80
3 files changed, 92 insertions, 3 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 9940cae11058..f684ca1bcc18 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.92 2014/11/13 18:41:27 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.93 2014/11/21 12:14:47 blueness Exp $
+
+ 21 Nov 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/9999-sys_libsecp256k1.patch, bitcoind-9999.ebuild:
+ Add libsecp256k1 to 9999
*bitcoind-9999 (13 Nov 2014)
diff --git a/net-p2p/bitcoind/bitcoind-9999.ebuild b/net-p2p/bitcoind/bitcoind-9999.ebuild
index 53b1ae32ead7..5ce082d82bdb 100644
--- a/net-p2p/bitcoind/bitcoind-9999.ebuild
+++ b/net-p2p/bitcoind/bitcoind-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 2010-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-9999.ebuild,v 1.1 2014/11/13 18:41:27 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-9999.ebuild,v 1.2 2014/11/21 12:14:47 blueness Exp $
EAPI=4
@@ -37,6 +37,7 @@ RDEPEND="
sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
)
virtual/bitcoin-leveldb
+ dev-libs/libsecp256k1
"
DEPEND="${RDEPEND}
>=app-shells/bash-4.1
@@ -51,7 +52,8 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
- rm -r src/leveldb
+ epatch "${FILESDIR}/${PV}-sys_libsecp256k1.patch"
+ rm -r src/leveldb src/secp256k1
eautoreconf
}
@@ -62,6 +64,7 @@ src_configure() {
$(use_enable test tests) \
$(use_enable wallet) \
--with-system-leveldb \
+ --without-libs \
--without-utils \
--without-gui
}
@@ -73,6 +76,8 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/test_bitcoin"
+
insinto /etc/bitcoin
newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
diff --git a/net-p2p/bitcoind/files/9999-sys_libsecp256k1.patch b/net-p2p/bitcoind/files/9999-sys_libsecp256k1.patch
new file mode 100644
index 000000000000..77ed10675e30
--- /dev/null
+++ b/net-p2p/bitcoind/files/9999-sys_libsecp256k1.patch
@@ -0,0 +1,80 @@
+diff --git a/configure.ac b/configure.ac
+index 6784521..3598bab 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -634,6 +634,12 @@ AC_ARG_WITH([daemon],
+
+ BITCOIN_QT_INIT
+
++PKG_CHECK_MODULES([libsecp256k1],[libsecp256k1],,[true])
++AC_ARG_WITH([libsecp256k1-verify],[],[use_libsecp256k1=$withval],[use_libsecp256k1=yes])
++if test "x$use_libsecp256k1" = "xyes"; then
++ AC_DEFINE(USE_SECP256K1,1,[USE_SECP256K1])
++fi
++
+ if test x$use_pkgconfig = xyes; then
+
+ if test x"$PKG_CONFIG" = "x"; then
+@@ -869,9 +875,6 @@ PKGCONFIG_LIBDIR_TEMP="$PKG_CONFIG_LIBDIR"
+ unset PKG_CONFIG_LIBDIR
+ PKG_CONFIG_LIBDIR="$PKGCONFIG_LIBDIR_TEMP"
+
+-ac_configure_args="${ac_configure_args} --disable-shared --with-pic"
+-AC_CONFIG_SUBDIRS([src/secp256k1])
+-
+ AC_OUTPUT
+
+ dnl Taken from https://wiki.debian.org/RpathIssue
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 0d45203..3a44a16 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,4 +1,3 @@
+-DIST_SUBDIRS = secp256k1
+ AM_LDFLAGS = $(PTHREAD_CFLAGS) $(LIBTOOL_LDFLAGS)
+
+
+@@ -20,7 +19,7 @@ endif
+ BITCOIN_CONFIG_INCLUDES=-I$(builddir)/config
+ BITCOIN_INCLUDES=-I$(builddir) -I$(builddir)/obj $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS) $(CRYPTO_CFLAGS) $(SSL_CFLAGS)
+
+-BITCOIN_INCLUDES += -I$(srcdir)/secp256k1/include
++BITCOIN_INCLUDES += $(libsecp256k1_CFLAGS)
+
+ LIBBITCOIN_SERVER=libbitcoin_server.a
+ LIBBITCOIN_WALLET=libbitcoin_wallet.a
+@@ -30,10 +29,7 @@ LIBBITCOIN_UTIL=libbitcoin_util.a
+ LIBBITCOIN_CRYPTO=crypto/libbitcoin_crypto.a
+ LIBBITCOIN_UNIVALUE=univalue/libbitcoin_univalue.a
+ LIBBITCOINQT=qt/libbitcoinqt.a
+-LIBSECP256K1=secp256k1/libsecp256k1.la
+-
+-$(LIBSECP256K1): $(wildcard secp256k1/src/*) $(wildcard secp256k1/include/*)
+- $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
++LIBSECP256K1=$(libsecp256k1_LIBS)
+
+ # Make is not made aware of per-object dependencies to avoid limiting building parallelization
+ # But to build the less dependent modules first, we manually select their order here:
+@@ -364,7 +360,7 @@ libbitcoinconsensus_la_LDFLAGS = -no-undefined $(RELDFLAGS)
+ libbitcoinconsensus_la_LIBADD = $(CRYPTO_LIBS)
+ libbitcoinconsensus_la_CPPFLAGS = $(CRYPTO_CFLAGS) -I$(builddir)/obj -DBUILD_BITCOIN_INTERNAL
+ if USE_LIBSECP256K1
+-libbitcoinconsensus_la_LIBADD += secp256k1/libsecp256k1.la
++libbitcoinconsensus_la_LIBADD += $(LIBSECP256K1)
+ endif
+ endif
+
+diff --git a/src/Makefile.test.include b/src/Makefile.test.include
+index 5fd2afe..014092a 100644
+--- a/src/Makefile.test.include
++++ b/src/Makefile.test.include
+@@ -104,9 +104,6 @@ bitcoin_test_check: $(TEST_BINARY) FORCE
+ bitcoin_test_clean : FORCE
+ rm -f $(CLEAN_BITCOIN_TEST) $(test_test_bitcoin_OBJECTS) $(TEST_BINARY)
+
+-check-local:
+- $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C secp256k1 check
+-
+ %.json.h: %.json
+ @$(MKDIR_P) $(@D)
+ @echo "namespace json_tests{" > $@