summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-06 16:11:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-06 16:11:13 +0000
commitf8d07df4b4e5c0f93b4c2fe5cc764b7d11308ec5 (patch)
tree1b4502d9037af3bf3245becfdff561f9b2d2146e /net-p2p
parentMarking squirrelmail-1.4.17 ppc64 for bug 249774 (diff)
downloadgentoo-2-f8d07df4b4e5c0f93b4c2fe5cc764b7d11308ec5.tar.gz
gentoo-2-f8d07df4b4e5c0f93b4c2fe5cc764b7d11308ec5.tar.bz2
gentoo-2-f8d07df4b4e5c0f93b4c2fe5cc764b7d11308ec5.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog9
-rw-r--r--net-p2p/deluge/deluge-1.1.0_rc3.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index a133753a9e4c..8649dfb03fbe 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.106 2008/12/30 12:31:04 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.107 2009/01/06 16:11:13 armin76 Exp $
+
+*deluge-1.1.0_rc3 (06 Jan 2009)
+
+ 06 Jan 2009; Raúl Porcel <armin76@gentoo.org> +deluge-1.1.0_rc3.ebuild:
+ Version bump
*deluge-1.1.0_rc2 (30 Dec 2008)
diff --git a/net-p2p/deluge/deluge-1.1.0_rc3.ebuild b/net-p2p/deluge/deluge-1.1.0_rc3.ebuild
new file mode 100644
index 000000000000..d5dda957770b
--- /dev/null
+++ b/net-p2p/deluge/deluge-1.1.0_rc3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.1.0_rc3.ebuild,v 1.1 2009/01/06 16:11:13 armin76 Exp $
+
+inherit eutils distutils flag-o-matic
+
+MY_PV="${PV/rc/RC}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BitTorrent client with a client/server model."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+DEPEND=">=dev-lang/python-2.4
+ dev-libs/boost
+ dev-python/setuptools"
+RDEPEND="${DEPEND}
+ dev-python/pyxdg
+ dev-python/pygobject
+ gtk? (
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ gnome-base/librsvg
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+
+ filter-ldflags -Wl,--as-needed
+}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}"/deluged.init deluged
+ newconfd "${FILESDIR}"/deluged.conf deluged
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ einfo "Please note that Deluge is still in it's early stages"
+ einfo "of development. Use it carefully and feel free to submit bugs"
+ einfo "in upstream page."
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}