summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-14 23:23:44 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-14 23:23:44 +0000
commite495a71f9f82c160bab370a9050871213248bcb8 (patch)
tree5ddb180aff924cf71fa0851a55c4c6d60c35355e /net-p2p
parentAdd alternative dependency >=freebsd-ubin-9.0_rc providing fuser. #415785 (diff)
downloadgentoo-2-e495a71f9f82c160bab370a9050871213248bcb8.tar.gz
gentoo-2-e495a71f9f82c160bab370a9050871213248bcb8.tar.bz2
gentoo-2-e495a71f9f82c160bab370a9050871213248bcb8.zip
Add new versions that fix CVE-2012-2459, bug #415973
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog17
-rw-r--r--net-p2p/bitcoind/bitcoind-0.4.6.ebuild108
-rw-r--r--net-p2p/bitcoind/bitcoind-0.4.7_rc1.ebuild108
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.5.ebuild122
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.6_rc1.ebuild122
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.0.7.ebuild114
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.0.8_rc1.ebuild114
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.2.ebuild113
-rw-r--r--net-p2p/bitcoind/files/0.6.1-reopen_log_file.patch91
9 files changed, 908 insertions, 1 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 9607c5f1604d..4a99ca6930c0 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.26 2012/04/27 09:27:12 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.27 2012/05/14 23:23:44 blueness Exp $
+
+*bitcoind-0.6.2 (14 May 2012)
+*bitcoind-0.6.0.8_rc1 (14 May 2012)
+*bitcoind-0.6.0.7 (14 May 2012)
+*bitcoind-0.5.6_rc1 (14 May 2012)
+*bitcoind-0.5.5 (14 May 2012)
+*bitcoind-0.4.7_rc1 (14 May 2012)
+*bitcoind-0.4.6 (14 May 2012)
+
+ 14 May 2012; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.6.1-reopen_log_file.patch, +bitcoind-0.4.6.ebuild,
+ +bitcoind-0.4.7_rc1.ebuild, +bitcoind-0.5.5.ebuild,
+ +bitcoind-0.5.6_rc1.ebuild, +bitcoind-0.6.0.7.ebuild,
+ +bitcoind-0.6.0.8_rc1.ebuild, +bitcoind-0.6.2.ebuild:
+ Add new versions that fix CVE-2012-2459, bug #415973
27 Apr 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.6.0.ebuild:
Add logrotation to 0.6.0 as well
diff --git a/net-p2p/bitcoind/bitcoind-0.4.6.ebuild b/net-p2p/bitcoind/bitcoind-0.4.6.ebuild
new file mode 100644
index 000000000000..13fb1be806b4
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.4.6.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.4.6.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.4.4-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.4.5rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bip16 +eligius logrotate ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/crypto++
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-${PN}-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ cp "${FILESDIR}/0.4.2-Makefile.gentoo" "Makefile" || die
+ if use bip16; then
+ epatch "${WORKDIR}/0.4.4-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.4.4+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.4.5rc1-eligius_sendfee.patch"
+ fi
+ use logrotate && epatch "${FILESDIR}/0.4.5-reopen_log_file.patch"
+}
+
+src_compile() {
+ local OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=( "LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("DB_CXXFLAGS=-I$(db_includedir "${DB_VER}")")
+ OPTS+=("DB_LDFLAGS=-ldb_cxx-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_CXXFLAGS=-I${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ use upnp && OPTS+=(USE_UPNP=1)
+
+ cd src || die
+ emake "${OPTS[@]}" ${PN}
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.4.7_rc1.ebuild b/net-p2p/bitcoind/bitcoind-0.4.7_rc1.ebuild
new file mode 100644
index 000000000000..4425db4208d5
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.4.7_rc1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.4.7_rc1.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.4.4-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.4.5rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bip16 +eligius logrotate ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/crypto++
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-${PN}-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ cp "${FILESDIR}/0.4.2-Makefile.gentoo" "Makefile" || die
+ if use bip16; then
+ epatch "${WORKDIR}/0.4.4-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.4.4+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.4.5rc1-eligius_sendfee.patch"
+ fi
+ use logrotate && epatch "${FILESDIR}/0.4.5-reopen_log_file.patch"
+}
+
+src_compile() {
+ local OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=( "LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("DB_CXXFLAGS=-I$(db_includedir "${DB_VER}")")
+ OPTS+=("DB_LDFLAGS=-ldb_cxx-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_CXXFLAGS=-I${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ use upnp && OPTS+=(USE_UPNP=1)
+
+ cd src || die
+ emake "${OPTS[@]}" ${PN}
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.5.ebuild b/net-p2p/bitcoind/bitcoind-0.5.5.ebuild
new file mode 100644
index 000000000000..d8e7c95342bc
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.5.5.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.5.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+bip16 +eligius examples logrotate ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
+ use logrotate && epatch "${FILESDIR}/0.4.5-reopen_log_file.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.6_rc1.ebuild b/net-p2p/bitcoind/bitcoind-0.5.6_rc1.ebuild
new file mode 100644
index 000000000000..07b720c49bef
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.5.6_rc1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.6_rc1.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+bip16 +eligius examples logrotate ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
+ use logrotate && epatch "${FILESDIR}/0.4.5-reopen_log_file.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.0.7.ebuild b/net-p2p/bitcoind/bitcoind-0.6.0.7.ebuild
new file mode 100644
index 000000000000..773d8ab3196c
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.6.0.7.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.0.7.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.6.0-eligius_sendfee.patch.xz
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples logrotate ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.6.0-eligius_sendfee.patch"
+ use logrotate && epatch "${FILESDIR}/0.6.0-reopen_log_file.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.0.8_rc1.ebuild b/net-p2p/bitcoind/bitcoind-0.6.0.8_rc1.ebuild
new file mode 100644
index 000000000000..5c83d08e0e39
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.6.0.8_rc1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.0.8_rc1.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.6.0-eligius_sendfee.patch.xz
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples logrotate ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.6.0-eligius_sendfee.patch"
+ use logrotate && epatch "${FILESDIR}/0.6.0-reopen_log_file.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.2.ebuild b/net-p2p/bitcoind/bitcoind-0.6.2.ebuild
new file mode 100644
index 000000000000..bebdbede9756
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.6.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.2.ebuild,v 1.1 2012/05/14 23:23:44 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="https://nodeload.github.com/bitcoin/bitcoin/tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/bitcoind/eligius/sendfee/0.6.1-eligius_sendfee.patch.xz
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples logrotate upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoin-06d764e"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.6.1-eligius_sendfee.patch"
+ use logrotate && epatch "${FILESDIR}/0.6.1-reopen_log_file.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/files/0.6.1-reopen_log_file.patch b/net-p2p/bitcoind/files/0.6.1-reopen_log_file.patch
new file mode 100644
index 000000000000..d4a43f907f5f
--- /dev/null
+++ b/net-p2p/bitcoind/files/0.6.1-reopen_log_file.patch
@@ -0,0 +1,91 @@
+diff --git a/src/init.cpp b/src/init.cpp
+index 3fe6d1b..71379c1 100644
+--- a/src/init.cpp
++++ b/src/init.cpp
+@@ -80,6 +80,10 @@ void HandleSIGTERM(int)
+ fRequestShutdown = true;
+ }
+
++void HandleSIGHUP(int)
++{
++ fReopenDebugLog = true;
++}
+
+
+
+@@ -141,7 +145,13 @@ bool AppInit2(int argc, char* argv[])
+ sa.sa_flags = 0;
+ sigaction(SIGTERM, &sa, NULL);
+ sigaction(SIGINT, &sa, NULL);
+- sigaction(SIGHUP, &sa, NULL);
++
++ // Reopen debug.log on SIGHUP
++ struct sigaction sa_hup;
++ sa_hup.sa_handler = HandleSIGHUP;
++ sigemptyset(&sa_hup.sa_mask);
++ sa_hup.sa_flags = 0;
++ sigaction(SIGHUP, &sa_hup, NULL);
+ #endif
+
+ //
+diff --git a/src/util.cpp b/src/util.cpp
+index 3569f22..3b2e330 100644
+--- a/src/util.cpp
++++ b/src/util.cpp
+@@ -70,6 +70,8 @@ bool fTestNet = false;
+ bool fNoListen = false;
+ bool fLogTimestamps = false;
+ CMedianFilter<int64> vTimeOffsets(200,0);
++FILE* fileout = NULL;
++bool fReopenDebugLog = false;
+
+ // Init openssl library multithreading support
+ static boost::interprocess::interprocess_mutex** ppmutexOpenSSL;
+@@ -198,7 +200,6 @@ inline int OutputDebugStringF(const char* pszFormat, ...)
+ else
+ {
+ // print to debug.log
+- static FILE* fileout = NULL;
+
+ if (!fileout)
+ {
+@@ -209,6 +210,17 @@ inline int OutputDebugStringF(const char* pszFormat, ...)
+ if (fileout)
+ {
+ static bool fStartedNewLine = true;
++#ifndef WIN32
++ flockfile(fileout);
++
++ // reopen the log file, if requested
++ if (fReopenDebugLog) {
++ fReopenDebugLog = false;
++ boost::filesystem::path pathDebug = GetDataDir() / "debug.log";
++ if (freopen(pathDebug.string().c_str(),"a",fileout) != NULL)
++ setbuf(fileout, NULL); // unbuffered
++ }
++#endif
+
+ // Debug print useful for profiling
+ if (fLogTimestamps && fStartedNewLine)
+@@ -222,6 +234,9 @@ inline int OutputDebugStringF(const char* pszFormat, ...)
+ va_start(arg_ptr, pszFormat);
+ ret = vfprintf(fileout, pszFormat, arg_ptr);
+ va_end(arg_ptr);
++#ifndef WIN32
++ funlockfile(fileout);
++#endif
+ }
+ }
+
+diff --git a/src/util.h b/src/util.h
+index 5f8d037..796b74a 100644
+--- a/src/util.h
++++ b/src/util.h
+@@ -125,6 +125,7 @@ extern std::string strMiscWarning;
+ extern bool fTestNet;
+ extern bool fNoListen;
+ extern bool fLogTimestamps;
++extern bool fReopenDebugLog;
+
+ void RandAddSeed();
+ void RandAddSeedPerfmon();