summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-17 12:00:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-17 12:00:24 +0000
commitcfe959da3ab75fc01d9d47bed6e48ab602cbaacc (patch)
tree912652ae7b5ab7802b22b3cc53bb792cfb05703e /net-p2p
parentfix an 'implicit declaration warning' fixing bug 269778 (diff)
downloadgentoo-2-cfe959da3ab75fc01d9d47bed6e48ab602cbaacc.tar.gz
gentoo-2-cfe959da3ab75fc01d9d47bed6e48ab602cbaacc.tar.bz2
gentoo-2-cfe959da3ab75fc01d9d47bed6e48ab602cbaacc.zip
Fix collision with kdelibs:3.5 per bug #270070. Remove blocker, not needed anymore
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog11
-rw-r--r--net-p2p/ktorrent/ktorrent-2.2.8-r1.ebuild71
-rw-r--r--net-p2p/ktorrent/ktorrent-3.2.1-r1.ebuild (renamed from net-p2p/ktorrent/ktorrent-3.2.1.ebuild)3
3 files changed, 82 insertions, 3 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index b924c688f6b4..fe591a89f6bc 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.114 2009/05/14 13:31:49 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.115 2009/05/17 12:00:24 scarabeus Exp $
+
+*ktorrent-3.2.1-r1 (17 May 2009)
+*ktorrent-2.2.8-r1 (17 May 2009)
+
+ 17 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +ktorrent-2.2.8-r1.ebuild, -ktorrent-3.2.1.ebuild,
+ +ktorrent-3.2.1-r1.ebuild:
+ Fix collision with kdelibs:3.5 per bug #270070. Remove blocker, not needed
+ anymore.
14 May 2009; Tomas Chvatal <scarabeus@gentoo.org> ktorrent-2.2.8.ebuild:
Fix build issue when we bumped new eclass. Per bug #269701.
diff --git a/net-p2p/ktorrent/ktorrent-2.2.8-r1.ebuild b/net-p2p/ktorrent/ktorrent-2.2.8-r1.ebuild
new file mode 100644
index 000000000000..a6fb5b1b463c
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.2.8-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.2.8-r1.ebuild,v 1.1 2009/05/17 12:00:24 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi kdeenablefinal"
+
+DEPEND="dev-libs/gmp
+ >=dev-libs/geoip-1.4.0-r1
+ avahi? ( >=net-dns/avahi-0.6.16-r1[qt3] )"
+RDEPEND="${DEPEND}
+ || ( =kde-base/kdebase-kioslaves-3.5* =kde-base/kdebase-3.5* )"
+
+S="${WORKDIR}/${MY_P}"
+
+need-kde 3.5
+
+LANGS="ar bg br ca cs cy da de el en_GB es et fa fr gl hu it ja ka lt
+ms nb nds nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+
+ cd "${S}"
+ # Fix automagic dependencies on avahi
+ epatch "${FILESDIR}/${PN}-2.2.5-avahi-check.patch"
+ epatch "${FILESDIR}/${P}-lograce.patch"
+
+ rm -f "${S}/configure"
+}
+
+src_configure(){
+ local myconf="${myconf}
+ $(use_with avahi)
+ --enable-builtin-country-flags
+ --enable-knetwork
+ --enable-system-geoip
+ --enable-torrent-mimetype
+ --disable-geoip"
+
+ kde_src_configure
+}
+
+src_install() {
+ kde_src_install
+ # remove colliding desktop file
+ rm -rf "${D}/${KDEDIR}"/share/mimelnk/application/x-bittorrent.desktop
+}
diff --git a/net-p2p/ktorrent/ktorrent-3.2.1.ebuild b/net-p2p/ktorrent/ktorrent-3.2.1-r1.ebuild
index c0d58b201e91..fed06739c26c 100644
--- a/net-p2p/ktorrent/ktorrent-3.2.1.ebuild
+++ b/net-p2p/ktorrent/ktorrent-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.2.1.ebuild,v 1.4 2009/04/18 01:01:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.2.1-r1.ebuild,v 1.1 2009/05/17 12:00:24 scarabeus Exp $
EAPI="2"
@@ -30,7 +30,6 @@ DEPEND="${COMMONDEPEND}
sys-devel/gettext
"
RDEPEND="${COMMONDEPEND}
- !net-p2p/ktorrent:0
infowidget? ( >=dev-libs/geoip-1.4.4 )
ipfilter? ( >=kde-base/kdebase-kioslaves-${KDE_MINIMAL} )"