summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-02-18 09:41:03 +0000
committerHans de Graaff <graaff@gentoo.org>2012-02-18 09:41:03 +0000
commitcf3402cda4713b6294d97d877a1d6d3d6f8a5fdc (patch)
treee378a7bef40da9f48df76719a84469a48bc8195b /net-p2p
parentFixed for and marked ~x86-solaris (diff)
downloadgentoo-2-cf3402cda4713b6294d97d877a1d6d3d6f8a5fdc.tar.gz
gentoo-2-cf3402cda4713b6294d97d877a1d6d3d6f8a5fdc.tar.bz2
gentoo-2-cf3402cda4713b6294d97d877a1d6d3d6f8a5fdc.zip
Move to EAPI=4. Only install requested LINGUAS per bug 403645.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog8
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.98.2-r1.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index 79665c25efad..43b51034bed5 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.130 2012/02/16 18:49:10 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.131 2012/02/18 09:41:03 graaff Exp $
+
+*gtk-gnutella-0.98.2-r1 (18 Feb 2012)
+
+ 18 Feb 2012; Hans de Graaff <graaff@gentoo.org>
+ +gtk-gnutella-0.98.2-r1.ebuild:
+ Move to EAPI=4. Only install requested LINGUAS per bug 403645.
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
gtk-gnutella-0.98.2.ebuild:
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.98.2-r1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.98.2-r1.ebuild
new file mode 100644
index 000000000000..e3b38adbc09a
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.98.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.98.2-r1.ebuild,v 1.1 2012/02/18 09:41:03 graaff Exp $
+
+EAPI=4
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ strip-linguas -i po
+
+ rm po/LINGUAS
+ for ling in ${LINGUAS}; do
+ echo $ling >> po/LINGUAS
+ done
+}
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}