summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-05 09:24:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-05 09:24:37 +0000
commit89b1bf4999747e6e1c2e8e3fe0168d3bba5ca7a3 (patch)
tree69f6016e032ade9a86f5be4f37f5821cb0aabf79 /net-p2p
parentversion bump (diff)
downloadgentoo-2-89b1bf4999747e6e1c2e8e3fe0168d3bba5ca7a3.tar.gz
gentoo-2-89b1bf4999747e6e1c2e8e3fe0168d3bba5ca7a3.tar.bz2
gentoo-2-89b1bf4999747e6e1c2e8e3fe0168d3bba5ca7a3.zip
Version bump.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.5.13
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.5.1-build.patch33
-rw-r--r--net-p2p/rtorrent/rtorrent-0.5.1.ebuild50
4 files changed, 93 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 5c0df02e715f..df0511b230ee 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.42 2006/04/23 09:29:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.43 2006/05/05 09:24:37 flameeyes Exp $
+
+*rtorrent-0.5.1 (05 May 2006)
+
+ 05 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/rtorrent-0.5.1-build.patch, +rtorrent-0.5.1.ebuild:
+ Version bump.
23 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> rtorrent-0.5.0.ebuild:
Add ~x86-fbsd keyword.
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.5.1 b/net-p2p/rtorrent/files/digest-rtorrent-0.5.1
new file mode 100644
index 000000000000..7ffa7ef1a6e3
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.5.1
@@ -0,0 +1,3 @@
+MD5 e33e1478bbe1a8836f318f0d904782c4 rtorrent-0.5.1.tar.gz 411269
+RMD160 ab588a3bc1e07bafb420c2c85383243684915a1c rtorrent-0.5.1.tar.gz 411269
+SHA256 d6c94ce0236f455bebb79a5851525ceecde160fc94b3bd1b4ea55406f85be561 rtorrent-0.5.1.tar.gz 411269
diff --git a/net-p2p/rtorrent/files/rtorrent-0.5.1-build.patch b/net-p2p/rtorrent/files/rtorrent-0.5.1-build.patch
new file mode 100644
index 000000000000..43908682479e
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.5.1-build.patch
@@ -0,0 +1,33 @@
+Index: rtorrent-0.5.1/rak/functional_fun.h
+===================================================================
+--- rtorrent-0.5.1.orig/rak/functional_fun.h
++++ rtorrent-0.5.1/rak/functional_fun.h
+@@ -349,28 +349,12 @@ convert_fn(function_base0<SrcResult>* sr
+ return new convert_fn0_t<Result, SrcResult>(src);
+ }
+
+-// This overload ensures that if we try to convert to the same type,
+-// it will optimize away the unneeded layer.
+-template <typename Result>
+-inline function_base0<Result>*
+-convert_fn(function_base0<Result>* src) {
+- return src;
+-}
+-
+ template <typename Result, typename Arg1, typename SrcResult, typename SrcArg1>
+ inline function_base1<Result, Arg1>*
+ convert_fn(function_base1<SrcResult, SrcArg1>* src) {
+ return new convert_fn1_t<Result, Arg1, SrcResult, SrcArg1>(src);
+ }
+
+-// This overload ensures that if we try to convert to the same type,
+-// it will optimize away the unneeded layer.
+-template <typename Result, typename Arg1>
+-inline function_base1<Result, Arg1>*
+-convert_fn(function_base1<Result, Arg1>* src) {
+- return src;
+-}
+-
+ }
+
+ #endif
diff --git a/net-p2p/rtorrent/rtorrent-0.5.1.ebuild b/net-p2p/rtorrent/rtorrent-0.5.1.ebuild
new file mode 100644
index 000000000000..f4ca684133d0
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.5.1.ebuild,v 1.1 2006/05/05 09:24:37 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=net-libs/libtorrent-0.9.0
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [[ $(gcc-major-version)$(gcc-minor-version) -ge "41" ]] && \
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}