summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-28 19:10:13 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-28 19:10:13 +0000
commit0a8010fe1c7977b54e1cbaf299838c40f224e054 (patch)
treee0179bc908fac83873c1cada9e9a7cd002106e6e /net-p2p
parentunmask xvid on ffmpeg (diff)
downloadgentoo-2-0a8010fe1c7977b54e1cbaf299838c40f224e054.tar.gz
gentoo-2-0a8010fe1c7977b54e1cbaf299838c40f224e054.tar.bz2
gentoo-2-0a8010fe1c7977b54e1cbaf299838c40f224e054.zip
Version bump by lorem_ipsum.
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-remote-cli/ChangeLog8
-rw-r--r--net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/net-p2p/transmission-remote-cli/ChangeLog b/net-p2p/transmission-remote-cli/ChangeLog
index eaca3dbff8b0..f1a0f5a40424 100644
--- a/net-p2p/transmission-remote-cli/ChangeLog
+++ b/net-p2p/transmission-remote-cli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission-remote-cli
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/ChangeLog,v 1.5 2013/07/02 10:06:54 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/ChangeLog,v 1.6 2013/07/28 19:10:13 xmw Exp $
+
+*transmission-remote-cli-1.6.1 (28 Jul 2013)
+
+ 28 Jul 2013; Michael Weber <xmw@gentoo.org>
+ +transmission-remote-cli-1.6.1.ebuild:
+ Version bump by lorem_ipsum.
*transmission-remote-cli-1.6.0 (02 Jul 2013)
diff --git a/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.1.ebuild b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.1.ebuild
new file mode 100644
index 000000000000..7c435b400063
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.1.ebuild,v 1.1 2013/07/28 19:10:13 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/fagga/transmission-remote-cli/"
+SRC_URI="https://github.com/fagga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip rdns"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep dev-python/simplejson[$(python_gen_usedep python2_5)] python2_5)
+ geoip? ( dev-python/geoip-python )
+ rdns? ( dev-python/adns-python[$PYTHON_USEDEP] )"
+
+src_install() {
+ python_foreach_impl python_doscript transmission-remote-cli
+ newbashcomp completion/bash/transmission-remote-cli-bash-completion.sh \
+ transmission-remote-cli
+ doman transmission-remote-cli.1
+ dodoc NEWS README.md
+}