summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-06-18 21:10:52 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-06-18 21:10:52 +0000
commitfd203cb7527275659a1d5361bf97d896cd1e4fe9 (patch)
tree9ff170b7ee4e5fefe5a33e6859e27e506bc8a6d1 /net-p2p/phex
parentNow X is forced (does not build without), itcl/itk paths removed from ebuild.... (diff)
downloadgentoo-2-fd203cb7527275659a1d5361bf97d896cd1e4fe9.tar.gz
gentoo-2-fd203cb7527275659a1d5361bf97d896cd1e4fe9.tar.bz2
gentoo-2-fd203cb7527275659a1d5361bf97d896cd1e4fe9.zip
Remove MacOS GUI related calls (#298698)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-p2p/phex')
-rw-r--r--net-p2p/phex/ChangeLog10
-rw-r--r--net-p2p/phex/files/0001-Remove-MacOS-GUI-references.patch261
-rw-r--r--net-p2p/phex/phex-3.2.0.102-r1.ebuild63
3 files changed, 332 insertions, 2 deletions
diff --git a/net-p2p/phex/ChangeLog b/net-p2p/phex/ChangeLog
index 5841b8e88765..e24429c22a59 100644
--- a/net-p2p/phex/ChangeLog
+++ b/net-p2p/phex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/phex
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/ChangeLog,v 1.14 2008/01/22 22:09:48 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/ChangeLog,v 1.15 2010/06/18 21:10:52 sochotnicky Exp $
+
+*phex-3.2.0.102-r1 (18 Jun 2010)
+
+ 18 Jun 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +files/0001-Remove-MacOS-GUI-references.patch, +phex-3.2.0.102-r1.ebuild:
+ Remove MacOS GUI related calls (#298698)
22 Jan 2008; Petteri Räty <betelgeuse@gentoo.org> phex-3.2.0.102.ebuild:
Migrate to EAPI=1 slot deps.
diff --git a/net-p2p/phex/files/0001-Remove-MacOS-GUI-references.patch b/net-p2p/phex/files/0001-Remove-MacOS-GUI-references.patch
new file mode 100644
index 000000000000..06791af09e18
--- /dev/null
+++ b/net-p2p/phex/files/0001-Remove-MacOS-GUI-references.patch
@@ -0,0 +1,261 @@
+From 49f223f74e5557321afdefebd48cdec4f625b97d Mon Sep 17 00:00:00 2001
+From: Stanislav Ochotnicky <sochotnicky@gmail.com>
+Date: Fri, 18 Jun 2010 23:01:32 +0200
+Subject: [PATCH] Remove MacOS GUI references
+
+---
+ src/phex/gui/common/FileDialogHandler.java | 45 +---------
+ src/phex/gui/common/GUIRegistry.java | 5 -
+ src/phex/gui/macosx/MacOsxGUIUtils.java | 140 ----------------------------
+ 3 files changed, 2 insertions(+), 188 deletions(-)
+ delete mode 100644 src/phex/gui/macosx/MacOsxGUIUtils.java
+
+diff --git a/src/phex/gui/common/FileDialogHandler.java b/src/phex/gui/common/FileDialogHandler.java
+index a5ee4f7..530f374 100644
+--- a/src/phex/gui/common/FileDialogHandler.java
++++ b/src/phex/gui/common/FileDialogHandler.java
+@@ -34,7 +34,6 @@ import javax.swing.filechooser.FileFilter;
+
+ import org.apache.commons.lang.SystemUtils;
+
+-import phex.gui.macosx.MacOsxGUIUtils;
+ import phex.utils.DirectoryOnlyFileFilter;
+
+ public class FileDialogHandler
+@@ -45,7 +44,7 @@ public class FileDialogHandler
+ {
+ if ( SystemUtils.IS_OS_MAC_OSX )
+ {
+- return openMacDirectoryChooser( title, null, null );
++ return null;
+ }
+ else
+ {
+@@ -71,10 +70,7 @@ public class FileDialogHandler
+ {
+ if ( SystemUtils.IS_OS_MAC_OSX )
+ {
+- return new File[]
+- {
+- openMacDirectoryChooser( title, notifyPopupTitle, notifyPopupShortMessage )
+- };
++ return null;
+ }
+ else
+ {
+@@ -85,43 +81,6 @@ public class FileDialogHandler
+ }
+ }
+
+- private static File openMacDirectoryChooser( String title,
+- String notifyPopupTitle, String notifyPopupShortMessage )
+- {
+- // create folder dialog through other class this prevents
+- // NoClassDefFoundError on Windows systems since the import of the
+- // required OS X classes is elsewhere.
+- FileDialog dia = MacOsxGUIUtils.createFolderDialog();
+- dia.setTitle(title);
+-
+- // unfortunatly its not possible to display notification popup
+- // besides heavy weight dialog.
+- //if ( notifyPopupTitle != null || notifyPopupShortMessage != null )
+- //{
+- //displayMacNotificationPopup( dia, notifyPopupTitle,
+- // notifyPopupShortMessage );
+- //}
+-
+- DirectoryOnlyFileFilter filter = new DirectoryOnlyFileFilter();
+- dia.setFilenameFilter( new FileFilterWrapper(
+- filter) );
+- dia.setVisible( true );
+- String dirStr = dia.getDirectory();
+- String fileStr = dia.getFile();
+-
+- if( dirStr == null || fileStr == null )
+- {
+- return null;
+- }
+- File file = new File(dirStr, fileStr);
+- // validate filter
+- if( !filter.accept(file) )
+- {
+- return null;
+- }
+- return file;
+- }
+-
+ private static JFileChooser initDefaultChooser( String title,
+ String approveBtnText, char approveBtnMnemonic, FileFilter filter,
+ int mode, File currentDirectory, String notifyPopupTitle,
+diff --git a/src/phex/gui/common/GUIRegistry.java b/src/phex/gui/common/GUIRegistry.java
+index 852722e..3c28f2e 100644
+--- a/src/phex/gui/common/GUIRegistry.java
++++ b/src/phex/gui/common/GUIRegistry.java
+@@ -47,7 +47,6 @@ import phex.gui.actions.FWAction;
+ import phex.gui.actions.NewDownloadAction;
+ import phex.gui.actions.SwitchNetworkAction;
+ import phex.gui.chat.ChatFrameManager;
+-import phex.gui.macosx.MacOsxGUIUtils;
+ import phex.gui.prefs.InterfacePrefs;
+ import phex.update.UpdateCheckRunner;
+ import phex.utils.Localizer;
+@@ -119,10 +118,6 @@ public final class GUIRegistry implements GUIRegistryConstants
+ }
+ }
+
+- if ( SystemUtils.IS_OS_MAC_OSX )
+- {
+- MacOsxGUIUtils.installEventHandlers();
+- }
+ initializeGlobalActions();
+ chatFrameManager = new ChatFrameManager();
+ try
+diff --git a/src/phex/gui/macosx/MacOsxGUIUtils.java b/src/phex/gui/macosx/MacOsxGUIUtils.java
+deleted file mode 100644
+index bc6f1d9..0000000
+--- a/src/phex/gui/macosx/MacOsxGUIUtils.java
++++ /dev/null
+@@ -1,140 +0,0 @@
+-/*
+- * PHEX - The pure-java Gnutella-servent.
+- * Copyright (C) 2001 - 2006 Phex Development Group
+- *
+- * This program is free software; you can redistribute it and/or modify
+- * it under the terms of the GNU General Public License as published by
+- * the Free Software Foundation; either version 2 of the License, or
+- * (at your option) any later version.
+- *
+- * This program is distributed in the hope that it will be useful,
+- * but WITHOUT ANY WARRANTY; without even the implied warranty of
+- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+- * GNU General Public License for more details.
+- *
+- * You should have received a copy of the GNU General Public License
+- * along with this program; if not, write to the Free Software
+- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+- *
+- * Created on 28.08.2005
+- * --- CVS Information ---
+- * $Id: 0001-Remove-MacOS-GUI-references.patch,v 1.1 2010/06/18 21:10:52 sochotnicky Exp $
+- */
+-package phex.gui.macosx;
+-
+-import java.awt.FileDialog;
+-import java.awt.event.ActionEvent;
+-import java.awt.event.ActionListener;
+-import java.io.File;
+-
+-import net.roydesign.event.ApplicationEvent;
+-import net.roydesign.mac.MRJAdapter;
+-import net.roydesign.ui.FolderDialog;
+-import phex.gui.actions.ExitPhexAction;
+-import phex.gui.actions.NewDownloadAction;
+-import phex.gui.common.GUIRegistry;
+-import phex.gui.dialogs.AboutDialog;
+-import phex.gui.dialogs.options.OptionsDialog;
+-import phex.utils.NLogger;
+-import phex.utils.NLoggerNames;
+-
+-public class MacOsxGUIUtils
+-{
+- public static final void installEventHandlers()
+- {
+- MRJAdapter.addQuitApplicationListener( new ActionListener()
+- {
+- public void actionPerformed( ActionEvent evt )
+- {
+- try
+- {
+- NLogger.debug( NLoggerNames.NATIV_MACOSX,
+- "Called MacOsX quit handler." );
+- ExitPhexAction.performCloseGUIAction();
+- }
+- catch (Throwable th)
+- {
+- NLogger.error( NLoggerNames.USER_INTERFACE, th, th );
+- }
+- }
+- } );
+-
+- MRJAdapter.setPreferencesEnabled( true );
+- MRJAdapter.addPreferencesListener( new ActionListener()
+- {
+- public void actionPerformed( ActionEvent evt )
+- {
+- try
+- {
+- NLogger.debug( NLoggerNames.NATIV_MACOSX,
+- "Called MacOsX preferences handler." );
+- OptionsDialog dialog = new OptionsDialog();
+- dialog.show();
+- }
+- catch (Throwable th)
+- {
+- NLogger.error( NLoggerNames.USER_INTERFACE, th, th );
+- }
+- }
+- } );
+-
+- MRJAdapter.addAboutListener( new ActionListener()
+- {
+- public void actionPerformed( ActionEvent evt )
+- {
+- try
+- {
+- AboutDialog dialog = new AboutDialog();
+- dialog.setVisible( true );
+- }
+- catch (Throwable th)
+- {
+- NLogger.error( NLoggerNames.USER_INTERFACE, th, th );
+- }
+- }
+- } );
+-
+- MRJAdapter.addOpenDocumentListener( new ActionListener()
+- {
+- public void actionPerformed( ActionEvent evt )
+- {
+- try
+- {
+- File file = ((ApplicationEvent) evt).getFile();
+- NLogger.debug( NLoggerNames.NATIV_MACOSX,
+- "Called MacOsX open file handler: " + file );
+-
+- String absFileName = file.getAbsolutePath();
+- if ( absFileName.endsWith( ".magma" ) )
+- {
+- NewDownloadAction action = (NewDownloadAction) GUIRegistry
+- .getInstance().getGlobalAction(
+- GUIRegistry.NEW_DOWNLOAD_ACTION );
+- action.incommingMagmaDownload( absFileName );
+- }
+- if ( absFileName.endsWith( ".xml" ) )
+- {
+- NewDownloadAction action = (NewDownloadAction) GUIRegistry
+- .getInstance().getGlobalAction(
+- GUIRegistry.NEW_DOWNLOAD_ACTION );
+- action.incommingRSSDownload( absFileName );
+- }
+- }
+- catch (Throwable th)
+- {
+- NLogger.error( NLoggerNames.USER_INTERFACE, th, th );
+- }
+- }
+- } );
+- }
+-
+- /**
+- * Create folder dialog here. This prevents
+- * NoClassDefFoundError on Windows systems since the import of the
+- * required OS X classes is elsewhere.
+- */
+- public static final FileDialog createFolderDialog()
+- {
+- return new FolderDialog( GUIRegistry.getInstance().getMainFrame() );
+- }
+-}
+--
+1.7.1
+
diff --git a/net-p2p/phex/phex-3.2.0.102-r1.ebuild b/net-p2p/phex/phex-3.2.0.102-r1.ebuild
new file mode 100644
index 000000000000..fcda329c8db0
--- /dev/null
+++ b/net-p2p/phex/phex-3.2.0.102-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/phex-3.2.0.102-r1.ebuild,v 1.1 2010/06/18 21:10:52 sochotnicky Exp $
+
+EAPI=2
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="java gnutella file-sharing application"
+HOMEPAGE="http://phex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+COMMON_DEPEND="dev-java/commons-httpclient:3
+ dev-java/commons-logging:0
+ dev-java/jgoodies-forms:0
+ dev-java/jgoodies-looks:2.0
+ dev-java/log4j:0
+ dev-java/l2fprod-common:0
+ dev-java/commons-beanutils:1.7
+ dev-java/commons-codec:0
+ dev-java/commons-collections:0
+ dev-java/commons-lang:2.1"
+
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}_src"
+
+JAVA_PKG_BSFIX="off"
+
+src_prepare() {
+ # remove parts related to MacOS gui classes
+ epatch "${FILESDIR}/0001-Remove-MacOS-GUI-references.patch"
+
+ rm -vf lib/*.jar || die
+ # avoid patches like plague
+ sed -i "s/createJar, copyThirdpartyJars/createJar/" build/buildJava.xml || die
+ JAVA_ANT_REWRITE_CLASSPATH="true" java-ant_bsfix_files build/*.xml
+ # remove bundled packages that we have - bug #176739
+ rm -rf src/com/l2fprod src/org/apache || die
+}
+
+src_compile() {
+ local gcp="$(java-pkg_getjars commons-httpclient-3,commons-logging,jgoodies-forms,jgoodies-looks-2.0,log4j,l2fprod-common,commons-beanutils-1.7,commons-codec,commons-collections,commons-lang-2.1)"
+ cd build
+ eant -Dgentoo.classpath="${gcp}:MRJAdapter.jar" -Dproject.buildtarget=build buildJava
+}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ java-pkg_dolauncher ${PN} --main phex.Main
+
+ dohtml docs/readme/* || die
+}