summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-26 23:58:39 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-26 23:58:39 +0000
commitb6e1abb0293a355275b07ed6249f68a74181d19a (patch)
tree9e645f3e855ed9ef7eac74d577107db1ab217bff /net-p2p/nicotine+
parentVersion bump. (diff)
downloadgentoo-2-b6e1abb0293a355275b07ed6249f68a74181d19a.tar.gz
gentoo-2-b6e1abb0293a355275b07ed6249f68a74181d19a.tar.bz2
gentoo-2-b6e1abb0293a355275b07ed6249f68a74181d19a.zip
revbump; conversion -> distutils-r1, endorsed by maintainer in bug #543002
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog8
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.16-r1.ebuild51
2 files changed, 57 insertions, 2 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 413d2af45b6e..35b20284433e 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.57 2015/02/18 19:08:02 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.58 2015/03/26 23:58:39 idella4 Exp $
+
+*nicotine+-1.2.16-r1 (26 Mar 2015)
+
+ 26 Mar 2015; Ian Delaney <idella4@gentoo.org> +nicotine+-1.2.16-r1.ebuild:
+ revbump; conversion -> distutils-r1, endorsed by maintainer in bug #543002
18 Feb 2015; Ryan Hill <rhill@gentoo.org> nicotine+-1.2.16.ebuild:
Add dependency on librsvg (bug #523292).
@@ -229,4 +234,3 @@
+files/nicotine-n.png, +metadata.xml, +nicotine+-1.2.3.ebuild:
Initial import, fork of nicotine project, bug #139377. Ebuild by Josu Lopez
Fernandez <zamorate@zamorate.net>.
-
diff --git a/net-p2p/nicotine+/nicotine+-1.2.16-r1.ebuild b/net-p2p/nicotine+/nicotine+-1.2.16-r1.ebuild
new file mode 100644
index 000000000000..b5ed6cffe579
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.16-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.16-r1.ebuild,v 1.1 2015/03/26 23:58:39 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
+ gnome-base/librsvg"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:\(Icon=\).*:\1nicotine-plus-32px:' \
+ "${S}"/files/nicotine.desktop
+}
+
+src_install() {
+ distutils-r1_src_install
+ python_fix_shebang "${D}"
+ dosym nicotine.py /usr/bin/nicotine
+}
+
+pkg_postinst() {
+ echo
+ elog "You may want to install these packages to add additional features"
+ elog "to Nicotine+:"
+ elog
+ elog "dev-python/geoip-python Country lookup and flag display"
+ elog "media-libs/mutagen Media metadata extraction"
+ elog "net-libs/miniupnpc UPnP portmapping"
+ echo
+}