summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-23 21:32:34 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-23 21:32:34 +0000
commitaae911a9dbc18b1a2ebf1f79e677b52592ed2dd4 (patch)
tree192564295d294f9c3744ef7971427d13d1e3d3b8 /net-p2p/ncdc
parentVersion bump (bug 472552), respect LINGUAS (bug 438270). (diff)
downloadgentoo-2-aae911a9dbc18b1a2ebf1f79e677b52592ed2dd4.tar.gz
gentoo-2-aae911a9dbc18b1a2ebf1f79e677b52592ed2dd4.tar.bz2
gentoo-2-aae911a9dbc18b1a2ebf1f79e677b52592ed2dd4.zip
Respect AR (bug 470624)
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-p2p/ncdc')
-rw-r--r--net-p2p/ncdc/ChangeLog6
-rw-r--r--net-p2p/ncdc/ncdc-1.16.1.ebuild11
-rw-r--r--net-p2p/ncdc/ncdc-1.17.ebuild8
-rw-r--r--net-p2p/ncdc/ncdc-9999.ebuild8
4 files changed, 26 insertions, 7 deletions
diff --git a/net-p2p/ncdc/ChangeLog b/net-p2p/ncdc/ChangeLog
index d254dd092d9e..9e001d7e43f8 100644
--- a/net-p2p/ncdc/ChangeLog
+++ b/net-p2p/ncdc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/ncdc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ChangeLog,v 1.39 2013/06/20 20:10:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ChangeLog,v 1.40 2013/06/23 21:32:34 xmw Exp $
+
+ 23 Jun 2013; Michael Weber <xmw@gentoo.org> ncdc-1.16.1.ebuild,
+ ncdc-1.17.ebuild, ncdc-9999.ebuild:
+ Respect AR (bug 470624)
20 Jun 2013; Michael Weber <xmw@gentoo.org> ncdc-1.16.1.ebuild,
ncdc-1.17.ebuild, ncdc-9999.ebuild:
diff --git a/net-p2p/ncdc/ncdc-1.16.1.ebuild b/net-p2p/ncdc/ncdc-1.16.1.ebuild
index ae24e0eca6aa..8d7b55b2162f 100644
--- a/net-p2p/ncdc/ncdc-1.16.1.ebuild
+++ b/net-p2p/ncdc/ncdc-1.16.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.16.1.ebuild,v 1.6 2013/06/20 20:10:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.16.1.ebuild,v 1.7 2013/06/23 21:32:33 xmw Exp $
EAPI=4
+inherit toolchain-funcs
+
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="http://dev.yorhel.nl/ncdc"
SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
@@ -24,6 +26,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
- econf \
- --disable-silent-rules
+ econf --disable-silent-rules
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
}
diff --git a/net-p2p/ncdc/ncdc-1.17.ebuild b/net-p2p/ncdc/ncdc-1.17.ebuild
index cab70670f4eb..778d3f24a7c7 100644
--- a/net-p2p/ncdc/ncdc-1.17.ebuild
+++ b/net-p2p/ncdc/ncdc-1.17.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.17.ebuild,v 1.3 2013/06/20 20:10:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.17.ebuild,v 1.4 2013/06/23 21:32:33 xmw Exp $
EAPI=5
+inherit toolchain-funcs
+
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="http://dev.yorhel.nl/ncdc"
SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
@@ -23,3 +25,7 @@ DEPEND="${RDEPEND}
dev-lang/perl
dev-util/makeheaders
virtual/pkgconfig"
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
diff --git a/net-p2p/ncdc/ncdc-9999.ebuild b/net-p2p/ncdc/ncdc-9999.ebuild
index 8b64a22a4ae1..aa75e7691f83 100644
--- a/net-p2p/ncdc/ncdc-9999.ebuild
+++ b/net-p2p/ncdc/ncdc-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-9999.ebuild,v 1.10 2013/06/20 20:10:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-9999.ebuild,v 1.11 2013/06/23 21:32:33 xmw Exp $
EAPI=5
-inherit autotools base git-2
+inherit autotools git-2 toolchain-funcs
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="http://dev.yorhel.nl/ncdc"
@@ -33,3 +33,7 @@ src_prepare() {
src_configure() {
econf --enable-git-version
}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}