summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2004-09-03 00:29:22 +0000
committerMalcolm Lashley <malc@gentoo.org>2004-09-03 00:29:22 +0000
commit12bd13dc9fa0f9288897da8fddb6bf0f48de9b2c (patch)
tree0ca73001115e90dd7f7961a671a106713af601af /net-p2p/ed2k_hash
parentHelp text, bug #62559 (Manifest recommit) (diff)
downloadgentoo-2-12bd13dc9fa0f9288897da8fddb6bf0f48de9b2c.tar.gz
gentoo-2-12bd13dc9fa0f9288897da8fddb6bf0f48de9b2c.tar.bz2
gentoo-2-12bd13dc9fa0f9288897da8fddb6bf0f48de9b2c.zip
Fix md4.h for 64bit-ness
Diffstat (limited to 'net-p2p/ed2k_hash')
-rw-r--r--net-p2p/ed2k_hash/ChangeLog5
-rw-r--r--net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild11
-rw-r--r--net-p2p/ed2k_hash/files/ed2k_64bit.patch12
3 files changed, 25 insertions, 3 deletions
diff --git a/net-p2p/ed2k_hash/ChangeLog b/net-p2p/ed2k_hash/ChangeLog
index abdfccef309a..bae38d07033d 100644
--- a/net-p2p/ed2k_hash/ChangeLog
+++ b/net-p2p/ed2k_hash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/ed2k_hash
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ed2k_hash/ChangeLog,v 1.7 2004/07/01 09:15:46 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ed2k_hash/ChangeLog,v 1.8 2004/09/03 00:29:22 malc Exp $
+
+ 02 Sep 2004; Malcolm Lashley <malc@gentoo.org> ed2k_hash-0.4.0.ebuild:
+ Fixed hashing on 64bit (amd64) and keyworded - closes bug #62587
01 Jul 2004; Jon Hood <squinky86@gentoo.org> ed2k_hash-0.4.0.ebuild:
virtual/glibc needs changed to virtual/libc; stable on ppc
diff --git a/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild b/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild
index 8116799df62f..ded635d2edb0 100644
--- a/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild
+++ b/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild,v 1.5 2004/07/01 09:15:46 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild,v 1.6 2004/09/03 00:29:22 malc Exp $
DESCRIPTION="Tool for generating eDonkey2000 links"
HOMEPAGE="http://ed2k-tools.sourceforge.net/${PN}.shtml"
@@ -8,10 +8,17 @@ RESTRICT="nomirror"
SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="x86 ppc ~amd64"
IUSE=""
DEPEND="virtual/libc"
+inherit eutils
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${FILESDIR}/ed2k_64bit.patch
+}
+
src_install() {
make install DESTDIR=${D} || die
diff --git a/net-p2p/ed2k_hash/files/ed2k_64bit.patch b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
new file mode 100644
index 000000000000..7425bb0c03fc
--- /dev/null
+++ b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
@@ -0,0 +1,12 @@
+--- ed2k_hash-0.4.0/work/ed2k_hash-0.4.0/ed2k_hash/md4.h 2002-09-04 18:24:37.000000000 +0100
++++ ed2k_hash-0.4.0_orig/work/ed2k_hash-0.4.0/ed2k_hash/md4.h 2004-09-02 21:13:49.900613616 +0100
+@@ -66,7 +66,8 @@
+ typedef unsigned short int UINT2;
+
+ /* UINT4 defines a four byte word */
+-typedef unsigned long int UINT4;
++/* unsigned long int on 64bit is 8 bits */
++typedef unsigned int UINT4;
+
+ /* PROTO_LIST is defined depending on how PROTOTYPES is defined above.
+ If using PROTOTYPES, then PROTO_LIST returns the list, otherwise it