summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-07-12 16:32:51 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-07-12 16:32:51 +0000
commit36d68d09ec695ebcc94cdca20207ef83cc7198f3 (patch)
treef9992ff4d81cfb91f40b028fa6acd9634835f7e3 /net-p2p/bitflu
parentadded GPL-2 to LICENSE per bug 426088 (diff)
downloadgentoo-2-36d68d09ec695ebcc94cdca20207ef83cc7198f3.tar.gz
gentoo-2-36d68d09ec695ebcc94cdca20207ef83cc7198f3.tar.bz2
gentoo-2-36d68d09ec695ebcc94cdca20207ef83cc7198f3.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/bitflu')
-rw-r--r--net-p2p/bitflu/ChangeLog5
-rw-r--r--net-p2p/bitflu/bitflu-1.50.ebuild79
2 files changed, 84 insertions, 0 deletions
diff --git a/net-p2p/bitflu/ChangeLog b/net-p2p/bitflu/ChangeLog
index 96945e3fcd5b..8c68c2a1215f 100644
--- a/net-p2p/bitflu/ChangeLog
+++ b/net-p2p/bitflu/ChangeLog
@@ -1,5 +1,10 @@
+*bitflu-1.50 (12 Jul 2012)
+
+ 12 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +bitflu-1.50.ebuild:
+ Version bump
+
12 Jul 2012; Anthony G. Basile <blueness@gentoo.org> bitflu-1.37.ebuild,
bitflu-1.41.ebuild, bitflu-1.42.ebuild, bitflu-1.43.ebuild:
Add GPL-2 for init scripts, bug #426112
diff --git a/net-p2p/bitflu/bitflu-1.50.ebuild b/net-p2p/bitflu/bitflu-1.50.ebuild
new file mode 100644
index 000000000000..d4e183244d0d
--- /dev/null
+++ b/net-p2p/bitflu/bitflu-1.50.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/bitflu-1.50.ebuild,v 1.1 2012/07/12 16:32:51 blueness Exp $
+
+EAPI=4
+
+inherit user
+
+DESCRIPTION="Bitflu is a BitTorrent client, written in Perl and is designed to run as a daemon"
+HOMEPAGE="http://bitflu.workaround.ch"
+SRC_URI="http://bitflu.workaround.ch/bitflu/${P}.tgz"
+
+LICENSE="Artistic-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-perl/Danga-Socket
+ dev-perl/Sys-Syscall"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup bitflu
+ enewuser bitflu -1 -1 /var/lib/bitflu bitflu
+}
+
+src_compile() {
+:
+}
+
+PLUGINS="/usr/lib/bitflu"
+HOMEDIR="/var/lib/bitflu"
+CONFDIR="/etc/bitflu"
+LOGDIR="/var/log/bitflu"
+
+src_install() {
+ # executable daemon
+ exeinto /usr/sbin
+ doexe bitflu.pl
+
+ # plugins
+ dodir "${PLUGINS}"
+ insinto "${PLUGINS}"
+ doins -r plugins
+
+ # working dir
+ dodir "${HOMEDIR}"
+ fowners bitflu:bitflu "${HOMEDIR}"
+ fperms 775 "${HOMEDIR}"
+
+ # config file
+ dodir "${CONFDIR}"
+ fowners bitflu:bitflu "${CONFDIR}"
+ fperms 775 "${CONFDIR}"
+ insinto "${CONFDIR}"
+ doins "${FILESDIR}"/bitflu.config
+ fowners bitflu:bitflu "${CONFDIR}"/bitflu.config
+ fperms 664 "${CONFDIR}"/bitflu.config
+
+ # log file
+ dodir "${LOGDIR}"
+ fowners bitflu:bitflu "${LOGDIR}"
+ fperms 775 "${LOGDIR}"
+
+ # docs
+ dodoc bitflu.config.example ChangeLog.txt CONTRIBUTING README_IPv6.txt \
+ README.txt Documentation/bitflu-internals.txt
+
+ newinitd "${FILESDIR}"/bitflu.initd bitflu
+}
+
+pkg_postinst() {
+ ewarn "Note: At startup, or at the user's request, ${PN} (re)reads its"
+ ewarn "configuration file and overwrites it with its own sanitized"
+ ewarn "version. A backup is created in the configuration directory,"
+ ewarn "/etc/${PN}, but that file will subseqently be overwritten if"
+ ewarn "a further backup is made. You may want to keep your own backup."
+ ewarn "A prestine example with comments may be found in /usr/share/doc/${P}."
+}