summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-04-27 09:27:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-04-27 09:27:12 +0000
commit9d5ebc5b0279625638d5815a598a46245f459d83 (patch)
treed3807c70d73850ee32768802abc68b7c5d075446 /net-p2p/bitcoind
parentVersion bump rc3's and add log rotation (diff)
downloadgentoo-2-9d5ebc5b0279625638d5815a598a46245f459d83.tar.gz
gentoo-2-9d5ebc5b0279625638d5815a598a46245f459d83.tar.bz2
gentoo-2-9d5ebc5b0279625638d5815a598a46245f459d83.zip
Add logrotation to 0.6.0 as well
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/bitcoind')
-rw-r--r--net-p2p/bitcoind/ChangeLog5
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.0.ebuild13
2 files changed, 15 insertions, 3 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 081d60b7d7da..9607c5f1604d 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.25 2012/04/27 09:21:32 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.26 2012/04/27 09:27:12 blueness Exp $
+
+ 27 Apr 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.6.0.ebuild:
+ Add logrotation to 0.6.0 as well
27 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
+files/0.4.5-reopen_log_file.patch, -bitcoind-0.4.5_rc3.ebuild,
diff --git a/net-p2p/bitcoind/bitcoind-0.6.0.ebuild b/net-p2p/bitcoind/bitcoind-0.6.0.ebuild
index 9615e6e2edcf..a460e0dbe920 100644
--- a/net-p2p/bitcoind/bitcoind-0.6.0.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.0.ebuild,v 1.1 2012/04/04 13:31:12 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.0.ebuild,v 1.2 2012/04/27 09:27:12 blueness Exp $
EAPI="4"
@@ -17,11 +17,14 @@ SRC_URI="https://nodeload.github.com/bitcoin/bitcoin/tarball/v${PV/_/} -> bitcoi
LICENSE="MIT ISC"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+eligius examples ssl upnp"
+IUSE="+eligius examples logrotate ssl upnp"
RDEPEND="
>=dev-libs/boost-1.41.0
dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
upnp? (
net-libs/miniupnpc
)
@@ -42,6 +45,7 @@ pkg_setup() {
src_prepare() {
cd src || die
use eligius && epatch "${WORKDIR}/${PV}-eligius_sendfee.patch"
+ use logrotate && epatch "${FILESDIR}/${PV}-reopen_log_file.patch"
}
src_compile() {
@@ -102,4 +106,9 @@ src_install() {
docinto examples
dodoc -r contrib/{bitrpc,pyminer,wallettools}
fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
}