summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-10-10 00:15:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-10-10 00:15:12 +0000
commit6ffbf0b2bcb0a565c4a835a9bfeaafeb3e2bc211 (patch)
tree601f239aefb1733ee60c49fa819d11c42abf3185 /net-p2p/bitcoind
parentRemove libvpx.so.1* and libavutil.so.51* (diff)
downloadgentoo-2-6ffbf0b2bcb0a565c4a835a9bfeaafeb3e2bc211.tar.gz
gentoo-2-6ffbf0b2bcb0a565c4a835a9bfeaafeb3e2bc211.tar.bz2
gentoo-2-6ffbf0b2bcb0a565c4a835a9bfeaafeb3e2bc211.zip
Remove vulnerable versions, bug #484546
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p/bitcoind')
-rw-r--r--net-p2p/bitcoind/ChangeLog9
-rw-r--r--net-p2p/bitcoind/bitcoind-0.4.9_rc2.ebuild94
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.8_rc2.ebuild108
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.3.ebuild109
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.5_rc2.ebuild107
-rw-r--r--net-p2p/bitcoind/bitcoind-0.7.3_rc2.ebuild102
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.1.ebuild111
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.2.ebuild116
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild122
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.3.ebuild121
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.4.ebuild122
11 files changed, 8 insertions, 1113 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 6177db040e89..06c4a5e9cace 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.78 2013/09/26 17:30:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.79 2013/10/10 00:15:12 blueness Exp $
+
+ 10 Oct 2013; Anthony G. Basile <blueness@gentoo.org>
+ -bitcoind-0.4.9_rc2.ebuild, -bitcoind-0.5.8_rc2.ebuild,
+ -bitcoind-0.6.3.ebuild, -bitcoind-0.6.5_rc2.ebuild,
+ -bitcoind-0.7.3_rc2.ebuild, -bitcoind-0.8.1.ebuild, -bitcoind-0.8.2.ebuild,
+ -bitcoind-0.8.3-r1.ebuild, -bitcoind-0.8.3.ebuild, -bitcoind-0.8.4.ebuild:
+ Remove vulnerable versions, bug #484546
26 Sep 2013; Agostino Sarubbo <ago@gentoo.org> bitcoind-0.8.5.ebuild:
Stable for arm, wrt bug #480096
diff --git a/net-p2p/bitcoind/bitcoind-0.4.9_rc2.ebuild b/net-p2p/bitcoind/bitcoind-0.4.9_rc2.ebuild
deleted file mode 100644
index 9fd81569fc86..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.4.9_rc2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.4.9_rc2.ebuild,v 1.2 2013/04/14 18:49:43 blueness Exp $
-
-EAPI=4
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.4.7-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bip16 logrotate ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/crypto++
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-${PN}-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- cp "${FILESDIR}/0.4.2-Makefile.gentoo" "Makefile" || die
- if use bip16; then
- epatch "${WORKDIR}/0.4.7-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
- fi
- use logrotate && epatch "${FILESDIR}/0.4.7-reopen_log_file.patch"
-}
-
-src_compile() {
- local OPTS=()
-
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=( "LDFLAGS=${LDFLAGS}")
-
- OPTS+=("DB_CXXFLAGS=-I$(db_includedir "${DB_VER}")")
- OPTS+=("DB_LDFLAGS=-ldb_cxx-${DB_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- use upnp && OPTS+=(USE_UPNP=1)
-
- cd src || die
- emake "${OPTS[@]}" ${PN}
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.8_rc2.ebuild b/net-p2p/bitcoind/bitcoind-0.5.8_rc2.ebuild
deleted file mode 100644
index 7a52f062e951..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.5.8_rc2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.8_rc2.ebuild,v 1.2 2013/04/14 18:49:43 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator toolchain-funcs
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.6-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+bip16 examples logrotate ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-bitcoind-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- if use bip16; then
- epatch "${WORKDIR}/0.5.6-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
- fi
- use logrotate && epatch "${FILESDIR}/0.4.7-reopen_log_file.patch"
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.3.ebuild b/net-p2p/bitcoind/bitcoind-0.6.3.ebuild
deleted file mode 100644
index f57b77cd0def..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.6.3.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.3.ebuild,v 1.8 2013/04/14 18:49:43 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator toolchain-funcs
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="https://nodeload.github.com/bitcoin/bitcoin/tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/bitcoind/eligius/sendfee/0.6.1-eligius_sendfee.patch.xz )
- logrotate? ( https://github.com/bitcoin/bitcoin/commit/9af080c351c40a4f56d37174253d33a9f4ffdb69.diff -> 0.6.3-reopen_log_file.patch )
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="+eligius examples logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-bitcoin-bbe1084"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- use eligius && epatch "${WORKDIR}/0.6.1-eligius_sendfee.patch"
- use logrotate && epatch "${DISTDIR}/0.6.3-reopen_log_file.patch"
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- # Workaround for bug #440034
- share/genbuild.sh src/obj/build.h
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.5_rc2.ebuild b/net-p2p/bitcoind/bitcoind-0.6.5_rc2.ebuild
deleted file mode 100644
index df4fddf1fead..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.6.5_rc2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.5_rc2.ebuild,v 1.2 2013/04/14 18:49:43 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator toolchain-funcs
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}-r1.tgz
- logrotate? ( https://github.com/bitcoin/bitcoin/commit/9af080c351c40a4f56d37174253d33a9f4ffdb69.diff -> 0.6.3-reopen_log_file.patch )
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="examples logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-bitcoind-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- use logrotate && epatch "${DISTDIR}/0.6.3-reopen_log_file.patch"
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- # Workaround for bug #440034
- share/genbuild.sh src/obj/build.h
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.7.3_rc2.ebuild b/net-p2p/bitcoind/bitcoind-0.7.3_rc2.ebuild
deleted file mode 100644
index 314cf9cb4762..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.7.3_rc2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.7.3_rc2.ebuild,v 1.2 2013/04/14 18:49:43 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator toolchain-funcs
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="examples ipv6 logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-bitcoind-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- # Workaround for bug #440034
- share/genbuild.sh src/obj/build.h
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.8.1.ebuild b/net-p2p/bitcoind/bitcoind-0.8.1.ebuild
deleted file mode 100644
index d8f4d40a5e05..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.8.1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.1.ebuild,v 1.7 2013/09/19 17:42:28 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator toolchain-funcs
-
-MyPV="${PV/_/}"
-MyPN="bitcoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="examples ipv6 logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/0.8.0-sys_leveldb.patch"
- rm -r src/leveldb
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.8.2.ebuild b/net-p2p/bitcoind/bitcoind-0.8.2.ebuild
deleted file mode 100644
index 7b4e8263127f..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.8.2.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.2.ebuild,v 1.2 2013/09/19 17:42:28 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator toolchain-funcs
-
-MyPV="${PV/_/}"
-MyPN="bitcoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="examples ipv6 logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-sys_leveldb.patch"
- rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README.md doc/release-notes.md
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild b/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild
deleted file mode 100644
index 8ee5a79b9acf..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild,v 1.3 2013/09/19 17:42:28 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit bash-completion-r1 db-use eutils versionator systemd toolchain-funcs
-
-MyPV="${PV/_/}"
-MyPN="bitcoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bash-completion examples ipv6 logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/0.8.2-sys_leveldb.patch"
- rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
- systemd_dounit "${FILESDIR}/bitcoind.service"
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README.md doc/release-notes.md
- doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
-
- if use bash-completion; then
- newbashcomp contrib/${PN}.bash-completion ${PN}
- fi
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.8.3.ebuild b/net-p2p/bitcoind/bitcoind-0.8.3.ebuild
deleted file mode 100644
index 23b5cf6adbe3..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.8.3.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.3.ebuild,v 1.3 2013/09/19 17:42:28 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit bash-completion-r1 db-use eutils versionator toolchain-funcs
-
-MyPV="${PV/_/}"
-MyPN="bitcoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bash-completion examples ipv6 logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/0.8.2-sys_leveldb.patch"
- rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README.md doc/release-notes.md
- doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
-
- if use bash-completion; then
- newbashcomp contrib/${PN}.bash-completion ${PN}
- fi
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.8.4.ebuild b/net-p2p/bitcoind/bitcoind-0.8.4.ebuild
deleted file mode 100644
index 5ef7165c357c..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.8.4.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 2010-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.4.ebuild,v 1.2 2013/09/19 17:42:28 blueness Exp $
-
-EAPI="4"
-
-DB_VER="4.8"
-
-inherit bash-completion-r1 db-use eutils versionator systemd toolchain-funcs
-
-MyPV="${PV/_/}"
-MyPN="bitcoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
-"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bash-completion examples ipv6 logrotate upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/0.8.2-sys_leveldb.patch"
- rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
-}
-
-src_compile() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_test() {
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
- ./test_bitcoin || die 'Tests failed'
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
- systemd_dounit "${FILESDIR}/bitcoind.service"
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README.md doc/release-notes.md
- doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
-
- if use bash-completion; then
- newbashcomp contrib/${PN}.bash-completion ${PN}
- fi
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}