summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-15 16:37:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-15 16:37:13 +0000
commit26f1b5b0fe2e090c8c02d549382f069a238bdcda (patch)
treee4312808f09ebc94a11c5d589866359b789b5055 /net-p2p/bitcoind
parentRestore stable 2.6.2 version for x86, intented removal was for 2.6.1, thanks ... (diff)
downloadgentoo-2-26f1b5b0fe2e090c8c02d549382f069a238bdcda.tar.gz
gentoo-2-26f1b5b0fe2e090c8c02d549382f069a238bdcda.tar.bz2
gentoo-2-26f1b5b0fe2e090c8c02d549382f069a238bdcda.zip
Remove unstable vulnerable versions, bug #407793
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/bitcoind')
-rw-r--r--net-p2p/bitcoind/ChangeLog8
-rw-r--r--net-p2p/bitcoind/bitcoind-0.4.3-r2.ebuild93
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.0.3-r2.ebuild100
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.0.4_rc3.ebuild100
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.2-r2.ebuild100
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.3_rc3.ebuild100
6 files changed, 7 insertions, 494 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 979cabeaf058..8b259cdf2483 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.10 2012/03/09 08:51:24 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.11 2012/03/15 16:37:13 blueness Exp $
+
+ 15 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
+ -bitcoind-0.4.3-r2.ebuild, -bitcoind-0.5.0.3-r2.ebuild,
+ -bitcoind-0.5.0.4_rc3.ebuild, -bitcoind-0.5.2-r2.ebuild,
+ -bitcoind-0.5.3_rc3.ebuild:
+ Remove unstable vulnerable versions, bug #407793
09 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> bitcoind-0.5.1.ebuild:
x86 stable wrt bug #405211
diff --git a/net-p2p/bitcoind/bitcoind-0.4.3-r2.ebuild b/net-p2p/bitcoind/bitcoind-0.4.3-r2.ebuild
deleted file mode 100644
index 7cfd02156d7f..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.4.3-r2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.4.3-r2.ebuild,v 1.1 2012/02/21 17:54:21 blueness Exp $
-
-EAPI=4
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip17? ( http://luke.dashjr.org/programs/bitcoin/files/bip17/bip17_v0.4.0.patch -> bip17_v0.4.0_r2.patch )
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
-"
-
-LICENSE="MIT ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bip17 +eligius ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0
- dev-libs/crypto++
- dev-libs/openssl[-bindist]
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-${PN}-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- cp "${FILESDIR}/0.4.2-Makefile.gentoo" "Makefile" || die
- use bip17 && epatch "${DISTDIR}/bip17_v0.4.0_r2.patch"
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
-}
-
-src_compile() {
- local OPTS=()
- local BOOST_PKG BOOST_VER BOOST_INC
-
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=( "LDFLAGS=${LDFLAGS}")
-
- OPTS+=("DB_CXXFLAGS=-I$(db_includedir "${DB_VER}")")
- OPTS+=("DB_LDFLAGS=-ldb_cxx-${DB_VER}")
-
- BOOST_PKG="$(best_version 'dev-libs/boost')"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- OPTS+=("BOOST_CXXFLAGS=-I${BOOST_INC}")
- OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- use upnp && OPTS+=(USE_UPNP=1)
-
- cd src || die
- emake "${OPTS[@]}" ${PN}
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.0.3-r2.ebuild b/net-p2p/bitcoind/bitcoind-0.5.0.3-r2.ebuild
deleted file mode 100644
index 2d4fba5e4614..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.5.0.3-r2.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.0.3-r2.ebuild,v 1.1 2012/02/21 17:54:21 blueness Exp $
-
-EAPI=4
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip17? ( http://luke.dashjr.org/programs/bitcoin/files/bip17/bip17_v${PV}.patch -> bip17_v${PV}_r2.patch )
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
-"
-
-LICENSE="MIT ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+bip17 +eligius examples ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0
- dev-libs/openssl[-bindist]
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-${PN}-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- use bip17 && epatch "${DISTDIR}/bip17_v${PV}_r2.patch"
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
-}
-
-src_compile() {
- local OPTS=()
- local BOOST_PKG BOOST_VER BOOST_INC
-
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- BOOST_PKG="$(best_version 'dev-libs/boost')"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
- OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- cd src || die
- emake -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.0.4_rc3.ebuild b/net-p2p/bitcoind/bitcoind-0.5.0.4_rc3.ebuild
deleted file mode 100644
index 934b038b93e3..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.5.0.4_rc3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.0.4_rc3.ebuild,v 1.1 2012/03/05 21:37:24 blueness Exp $
-
-EAPI=4
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip17? ( http://luke.dashjr.org/programs/bitcoin/files/bip17/bip17_v0.5.0.3.patch -> bip17_v0.5.0.3_r2.patch )
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
-"
-
-LICENSE="MIT ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+bip17 +eligius examples ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0
- dev-libs/openssl[-bindist]
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-${PN}-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- use bip17 && epatch "${DISTDIR}/bip17_v0.5.0.3_r2.patch"
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
-}
-
-src_compile() {
- local OPTS=()
- local BOOST_PKG BOOST_VER BOOST_INC
-
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- BOOST_PKG="$(best_version 'dev-libs/boost')"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
- OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- cd src || die
- emake -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.2-r2.ebuild b/net-p2p/bitcoind/bitcoind-0.5.2-r2.ebuild
deleted file mode 100644
index d98236e267a0..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.5.2-r2.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.2-r2.ebuild,v 1.1 2012/02/21 17:54:21 blueness Exp $
-
-EAPI=4
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip17? ( http://luke.dashjr.org/programs/bitcoin/files/bip17/bip17_v${PV}.patch -> bip17_v${PV}_r2.patch )
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
-"
-
-LICENSE="MIT ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+bip17 +eligius examples ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0
- dev-libs/openssl[-bindist]
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-bitcoind-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- use bip17 && epatch "${DISTDIR}/bip17_v${PV}_r2.patch"
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
-}
-
-src_compile() {
- local OPTS=()
- local BOOST_PKG BOOST_VER BOOST_INC
-
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- BOOST_PKG="$(best_version 'dev-libs/boost')"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
- OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- cd src || die
- emake -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.3_rc3.ebuild b/net-p2p/bitcoind/bitcoind-0.5.3_rc3.ebuild
deleted file mode 100644
index 34aa9756960d..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.5.3_rc3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3_rc3.ebuild,v 1.1 2012/03/05 21:37:24 blueness Exp $
-
-EAPI=4
-
-DB_VER="4.8"
-
-inherit db-use eutils versionator
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-HOMEPAGE="http://bitcoin.org/"
-SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- bip17? ( http://luke.dashjr.org/programs/bitcoin/files/bip17/bip17_v0.5.2.patch -> bip17_v0.5.2_r2.patch )
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
-"
-
-LICENSE="MIT ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+bip17 +eligius examples ssl upnp"
-
-RDEPEND="
- >=dev-libs/boost-1.41.0
- dev-libs/openssl[-bindist]
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-S="${WORKDIR}/bitcoin-bitcoind-stable"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- cd src || die
- use bip17 && epatch "${DISTDIR}/bip17_v0.5.2_r2.patch"
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
-}
-
-src_compile() {
- local OPTS=()
- local BOOST_PKG BOOST_VER BOOST_INC
-
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- BOOST_PKG="$(best_version 'dev-libs/boost')"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
- OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- if use upnp; then
- OPTS+=(USE_UPNP=1)
- else
- OPTS+=(USE_UPNP=)
- fi
-
- cd src || die
- emake -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd" ${PN}
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/README
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,wallettools}
- fi
-}