summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-13 18:19:42 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-13 18:19:42 +0000
commit67551cbd0dfaeb55d359c3f15f02d0b308aa16e8 (patch)
tree228ae5e48a6c82471e45bc751e05a0e2392f4f33 /net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
parentReorder dependency order (diff)
downloadgentoo-2-67551cbd0dfaeb55d359c3f15f02d0b308aa16e8.tar.gz
gentoo-2-67551cbd0dfaeb55d359c3f15f02d0b308aa16e8.tar.bz2
gentoo-2-67551cbd0dfaeb55d359c3f15f02d0b308aa16e8.zip
Add -9999
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild')
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
new file mode 100644
index 000000000000..35fa39cc8b24
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2010-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild,v 1.1 2014/11/13 18:19:42 blueness Exp $
+
+EAPI=4
+
+inherit autotools eutils git-2
+
+MyPV="${PV/_/}"
+MyPN="bitcoin"
+MyP="${MyPN}-${MyPV}"
+
+DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="
+"
+EGIT_PROJECT='bitcoin'
+EGIT_REPO_URI="git://github.com/bitcoin/bitcoin.git https://github.com/bitcoin/bitcoin.git"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.52.0[threads(+)]
+ dev-libs/openssl:0[-bindist]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i 's/bitcoin-tx//' src/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-ccache \
+ --without-miniupnpc \
+ --disable-tests \
+ --disable-wallet \
+ --without-daemon \
+ --without-gui
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/README.md doc/release-notes.md
+ dodoc doc/assets-attribution.md doc/tor.md
+}