summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-08-01 13:40:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-08-01 13:40:40 +0000
commit6363c7e4cf09b3253edbdc15cc6ff51932c6c412 (patch)
tree27f17a21356c750a5a73471fcf711d726b8adfcd /net-news
parentMore old. (diff)
downloadgentoo-2-6363c7e4cf09b3253edbdc15cc6ff51932c6c412.tar.gz
gentoo-2-6363c7e4cf09b3253edbdc15cc6ff51932c6c412.tar.bz2
gentoo-2-6363c7e4cf09b3253edbdc15cc6ff51932c6c412.zip
Version bump (fixes #477052 upstream).
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'net-news')
-rw-r--r--net-news/liferea/ChangeLog7
-rw-r--r--net-news/liferea/liferea-1.10.1a.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-news/liferea/ChangeLog b/net-news/liferea/ChangeLog
index 203ce34ea35e..75be7bf97278 100644
--- a/net-news/liferea/ChangeLog
+++ b/net-news/liferea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/liferea
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.237 2013/07/13 07:45:21 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.238 2013/08/01 13:40:40 slyfox Exp $
+
+*liferea-1.10.1a (01 Aug 2013)
+
+ 01 Aug 2013; Sergei Trofimovich <slyfox@gentoo.org> +liferea-1.10.1a.ebuild:
+ Version bump (fixes #477052 upstream).
*liferea-1.10.0 (13 Jul 2013)
diff --git a/net-news/liferea/liferea-1.10.1a.ebuild b/net-news/liferea/liferea-1.10.1a.ebuild
new file mode 100644
index 000000000000..0f78fa11a9aa
--- /dev/null
+++ b/net-news/liferea/liferea-1.10.1a.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.10.1a.ebuild,v 1.1 2013/08/01 13:40:40 slyfox Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 pax-utils
+
+MY_P=${P/_rc/-RC}
+MY_P=${MY_P/_/-}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="http://liferea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ayatana libnotify"
+
+RDEPEND="x11-libs/gtk+:3
+ >=dev-libs/glib-2.26.0:2
+ dev-libs/json-glib
+ >=dev-libs/libpeas-1.0.0[gtk]
+ >=net-libs/libsoup-2.28.2:2.4
+ dev-libs/libunique:3
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.19
+ >=dev-db/sqlite-3.7.0:3
+ >=gnome-base/gconf-1.1.9:2
+ gnome-base/gsettings-desktop-schemas
+ >=net-libs/webkit-gtk-1.6.1:3
+ >=x11-libs/pango-1.4.0
+ ayatana? ( dev-libs/libindicate )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog README"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ $(use_enable ayatana libindicate)
+ $(use_enable libnotify)"
+}
+
+src_prepare() {
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ # bug #338213
+ # Uses webkit's JIT. Needs mmap('rwx') to generate code in runtime.
+ # MPROTECT policy violation. Will sit here until webkit will
+ # get optional JIT.
+ pax-mark m "${D}"/usr/bin/liferea
+
+ einfo "If you want to enhance the functionality of this package,"
+ einfo "you should consider installing:"
+ einfo " dev-libs/dbus-glib"
+ einfo " net-misc/networkmanager"
+}