summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-02-17 11:46:02 +0000
committerCédric Krier <cedk@gentoo.org>2008-02-17 11:46:02 +0000
commit3788e61cc2cee42b0efa38addbc5462910d0ae53 (patch)
tree3d9bf975233ac25c23d020985a6beb9ee22610a4 /net-news/snownews
parentStable on ppc wrt bug 208916 (diff)
downloadgentoo-2-3788e61cc2cee42b0efa38addbc5462910d0ae53.tar.gz
gentoo-2-3788e61cc2cee42b0efa38addbc5462910d0ae53.tar.bz2
gentoo-2-3788e61cc2cee42b0efa38addbc5462910d0ae53.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-news/snownews')
-rw-r--r--net-news/snownews/ChangeLog8
-rw-r--r--net-news/snownews/files/snownews-1.5.9-install.patch11
-rw-r--r--net-news/snownews/snownews-1.5.9.ebuild57
3 files changed, 75 insertions, 1 deletions
diff --git a/net-news/snownews/ChangeLog b/net-news/snownews/ChangeLog
index 316a8ea84a0c..4d83c0ec6253 100644
--- a/net-news/snownews/ChangeLog
+++ b/net-news/snownews/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-news/snownews
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/ChangeLog,v 1.19 2008/01/10 23:10:46 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/ChangeLog,v 1.20 2008/02/17 11:46:01 cedk Exp $
+
+*snownews-1.5.9 (17 Feb 2008)
+
+ 17 Feb 2008; Cédric Krier <cedk@gentoo.org>
+ +files/snownews-1.5.9-install.patch, +snownews-1.5.9.ebuild:
+ Version bump
*snownews-1.5.8 (10 Jan 2008)
diff --git a/net-news/snownews/files/snownews-1.5.9-install.patch b/net-news/snownews/files/snownews-1.5.9-install.patch
new file mode 100644
index 000000000000..f02483ded567
--- /dev/null
+++ b/net-news/snownews/files/snownews-1.5.9-install.patch
@@ -0,0 +1,11 @@
+diff -ru snownews-1.5.9~/Makefile snownews-1.5.9/Makefile
+--- snownews-1.5.9~/Makefile 2008-02-17 12:31:35.000000000 +0100
++++ snownews-1.5.9/Makefile 2008-02-17 12:31:52.000000000 +0100
+@@ -66,7 +66,6 @@
+ (cd $(DESTDIR)$(PREFIX)/bin && \
+ ln -sf opml2snow snow2opml ); \
+ fi;
+- $(INSTALL) snowsync $(DESTDIR)$(PREFIX)/bin
+
+ install-locales: locales
+ for L in $(LOCALES); do \
diff --git a/net-news/snownews/snownews-1.5.9.ebuild b/net-news/snownews/snownews-1.5.9.ebuild
new file mode 100644
index 000000000000..5ba14eae6ba2
--- /dev/null
+++ b/net-news/snownews/snownews-1.5.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/snownews-1.5.9.ebuild,v 1.1 2008/02/17 11:46:01 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Snownews, a text-mode RSS/RDF newsreader"
+HOMEPAGE="http://snownews.kcore.de/"
+SRC_URI="http://home.kcore.de/~kiza/software/snownews/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-libs/libxml2-2.5.6
+ >=sys-libs/ncurses-5.3"
+
+RDEPEND="dev-perl/XML-LibXML
+ dev-perl/XML-LibXSLT
+ dev-perl/libwww-perl"
+
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ eerror "sys-libs/ncurses must be build with unicode"
+ die "${PN} requires sys-libs/ncurses with USE=unicode"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/-O2//" \
+ configure
+
+ epatch "${FILESDIR}"/${P}-install.patch
+
+ sed -i -e 's/$(INSTALL) -s/$(INSTALL)/' \
+ Makefile
+
+ #Bug #121805
+ epatch "${FILESDIR}"/${PN}-1.5.7-stdint.patch
+}
+
+src_compile() {
+ local conf="--prefix=/usr"
+ use unicode && conf="${conf} --charset=UTF-8"
+ ./configure ${conf} || die "configure failed"
+ emake CC="$(tc-getCC)" EXTRA_CFLAGS="${CFLAGS}" EXTRA_LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "make install failed"
+
+ dodoc AUTHOR CREDITS README README.colors README.de README.patching
+}