summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-03-25 11:23:01 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-03-25 11:23:01 +0000
commit578cd77948736582ad5e2154fee0da804d561947 (patch)
treeacf5341cf1d9284d58a21a9428f9255c7341d878 /net-nds
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-578cd77948736582ad5e2154fee0da804d561947.tar.gz
gentoo-2-578cd77948736582ad5e2154fee0da804d561947.tar.bz2
gentoo-2-578cd77948736582ad5e2154fee0da804d561947.zip
Version bump, as requested by Reuben Farrelly in bug #540116.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/tac_plus/ChangeLog11
-rw-r--r--net-nds/tac_plus/files/tac_plus-4.0.4.27a-deansification.patch11
-rw-r--r--net-nds/tac_plus/files/tac_plus-4.0.4.27a-parallelmake.patch12
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.27a.ebuild60
4 files changed, 92 insertions, 2 deletions
diff --git a/net-nds/tac_plus/ChangeLog b/net-nds/tac_plus/ChangeLog
index 640ae713922e..113eff5935bd 100644
--- a/net-nds/tac_plus/ChangeLog
+++ b/net-nds/tac_plus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nds/tac_plus
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/ChangeLog,v 1.19 2013/04/05 17:11:05 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/ChangeLog,v 1.20 2015/03/25 11:23:01 chainsaw Exp $
+
+*tac_plus-4.0.4.27a (25 Mar 2015)
+
+ 25 Mar 2015; Tony Vroon <chainsaw@gentoo.org> +tac_plus-4.0.4.27a.ebuild,
+ +files/tac_plus-4.0.4.27a-deansification.patch,
+ +files/tac_plus-4.0.4.27a-parallelmake.patch:
+ Version bump, as requested by Reuben Farrelly in bug #540116.
05 Apr 2013; Agostino Sarubbo <ago@gentoo.org> tac_plus-4.0.4.19-r4.ebuild:
Stable for ppc, wrt bug #464472
diff --git a/net-nds/tac_plus/files/tac_plus-4.0.4.27a-deansification.patch b/net-nds/tac_plus/files/tac_plus-4.0.4.27a-deansification.patch
new file mode 100644
index 000000000000..ee1bcb231838
--- /dev/null
+++ b/net-nds/tac_plus/files/tac_plus-4.0.4.27a-deansification.patch
@@ -0,0 +1,11 @@
+diff -uNr tacacs+-F4.0.4.27a.ORIG/configure.in tacacs+-F4.0.4.27a/configure.in
+--- tacacs+-F4.0.4.27a.ORIG/configure.in 2015-03-25 11:13:06.976024203 +0000
++++ tacacs+-F4.0.4.27a/configure.in 2015-03-25 11:13:36.816025689 +0000
+@@ -126,7 +126,6 @@
+
+ # compiler specifics
+ AC_PROG_CC
+-AM_C_PROTOTYPES
+ AC_PROG_CPP
+ AC_C_CONST
+ AC_C_INLINE
diff --git a/net-nds/tac_plus/files/tac_plus-4.0.4.27a-parallelmake.patch b/net-nds/tac_plus/files/tac_plus-4.0.4.27a-parallelmake.patch
new file mode 100644
index 000000000000..c75a05b0cd12
--- /dev/null
+++ b/net-nds/tac_plus/files/tac_plus-4.0.4.27a-parallelmake.patch
@@ -0,0 +1,12 @@
+diff -uNr tacacs+-F4.0.4.27a.ORIG/Makefile.am tacacs+-F4.0.4.27a/Makefile.am
+--- tacacs+-F4.0.4.27a.ORIG/Makefile.am 2015-03-25 11:10:26.821016226 +0000
++++ tacacs+-F4.0.4.27a/Makefile.am 2015-03-25 11:11:04.954018126 +0000
+@@ -19,7 +19,7 @@
+ tac_plus_SOURCES += aceclnt_fn.c
+ endif
+ tac_plus_LDFLAGS = -L$(top_srcdir)
+-tac_plus_LDADD = $(WRAPLIBS) -ltacacs
++tac_plus_LDADD = $(WRAPLIBS) libtacacs.la
+
+ lib_LTLIBRARIES = libtacacs.la
+ libtacacs_la_SOURCES = fdes.c maxsess.c md4.c md5.c packet.c
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.27a.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.27a.ebuild
new file mode 100644
index 000000000000..73a99eabc29f
--- /dev/null
+++ b/net-nds/tac_plus/tac_plus-4.0.4.27a.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/tac_plus-4.0.4.27a.ebuild,v 1.1 2015/03/25 11:23:01 chainsaw Exp $
+
+EAPI=5
+
+inherit autotools base libtool
+
+MY_P="tacacs+-F${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="An updated version of Cisco's TACACS+ server"
+HOMEPAGE="http://www.shrubbery.net/tac_plus/"
+SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
+
+LICENSE="HPND RSA GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug finger maxsess tcpd skey static-libs"
+
+DEPEND="skey? ( >=sys-auth/skey-1.1.5-r1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-parallelmake.patch"
+ "${FILESDIR}/${P}-deansification.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ mv configure.in configure.ac || die "Unable to quiet autoconf deprecation warning"
+ AT_M4DIR="." eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_with skey) \
+ $(use_with tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable finger) \
+ $(use_enable maxsess) \
+ $(use_enable static-libs static) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ use static-libs || find "${D}" -name '*.la' -delete || die "Unable to remove spurious libtool archive"
+ dodoc CHANGES FAQ
+
+ newinitd "${FILESDIR}/tac_plus.init2" tac_plus
+ newconfd "${FILESDIR}/tac_plus.confd2" tac_plus
+
+ insinto /etc/tac_plus
+ newins "${FILESDIR}/tac_plus.conf2" tac_plus.conf
+}