summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-22 23:19:17 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-22 23:19:17 +0000
commit4b9a2a7f3fb8305203a306e4d1bbbdf22b83bb92 (patch)
tree1e0ac8b3a539c11667bbfc7410f40f90125c272b /net-nds
parentVersion bump. (diff)
downloadgentoo-2-4b9a2a7f3fb8305203a306e4d1bbbdf22b83bb92.tar.gz
gentoo-2-4b9a2a7f3fb8305203a306e4d1bbbdf22b83bb92.tar.bz2
gentoo-2-4b9a2a7f3fb8305203a306e4d1bbbdf22b83bb92.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog7
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.2.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index 01b3aa19ff65..fcf5d074905a 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/rpcbind
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.39 2014/11/02 09:27:00 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.40 2014/12/22 23:19:17 radhermit Exp $
+
+*rpcbind-0.2.2 (22 Dec 2014)
+
+ 22 Dec 2014; Tim Harder <radhermit@gentoo.org> +rpcbind-0.2.2.ebuild:
+ Version bump.
02 Nov 2014; Sven Vermeulen <swift@gentoo.org> rpcbind-0.2.0-r1.ebuild,
rpcbind-0.2.1-r1.ebuild, rpcbind-9999.ebuild:
diff --git a/net-nds/rpcbind/rpcbind-0.2.2.ebuild b/net-nds/rpcbind/rpcbind-0.2.2.ebuild
new file mode 100644
index 000000000000..3ae5a28f52d6
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.2.ebuild,v 1.1 2014/12/22 23:19:17 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug selinux tcpd warmstarts"
+
+CDEPEND=">=net-libs/libtirpc-0.2.3
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpcbind )
+"
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --with-statedir="${EPREFIX}"/run/${PN} \
+ --with-rpcuser=root \
+ $(use_enable tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable warmstarts)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}