summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-06-16 16:00:43 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-06-16 16:00:43 +0000
commitf84c7fc88c4ae7b0d5098743c8a87b78e6fcf90a (patch)
tree43f697ff483cae44a906ba4a6c24c1cc89aa1ca5 /net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild
parentFix MODULE_VERSION (diff)
downloadgentoo-2-f84c7fc88c4ae7b0d5098743c8a87b78e6fcf90a.tar.gz
gentoo-2-f84c7fc88c4ae7b0d5098743c8a87b78e6fcf90a.tar.bz2
gentoo-2-f84c7fc88c4ae7b0d5098743c8a87b78e6fcf90a.zip
Revision bump now that we have a flawless version, and remove the previous two incarnations.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild')
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild
new file mode 100644
index 000000000000..33b2e860d82d
--- /dev/null
+++ b/net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/tac_plus-4.0.4.19-r2.ebuild,v 1.1 2011/06/16 16:00:43 chainsaw Exp $
+
+EAPI=4
+
+inherit libtool autotools
+
+MY_P="tacacs+-F${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="An updated version of Cisco's TACACS+ server"
+HOMEPAGE="http://www.shrubbery.net/tac_plus/"
+SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="debug finger maxsess tcpd skey static-libs"
+
+DEPEND="skey? ( >=sys-auth/skey-1.1.5-r1 )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallelmake.patch
+
+ AT_M4DIR="." eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_with skey) \
+ $(use_with tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable finger) \
+ $(use_enable maxsess) \
+ $(use_enable static-libs static) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc CHANGES FAQ
+
+ newinitd "${FILESDIR}/tac_plus.init" tac_plus
+ newconfd "${FILESDIR}/tac_plus.confd2" tac_plus
+
+ insinto /etc/tac_plus
+ newins "${FILESDIR}/tac_plus.conf2" tac_plus.conf
+}