summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-03-30 10:09:14 +0000
committerPacho Ramos <pacho@gentoo.org>2014-03-30 10:09:14 +0000
commitd8e5b41e31925f5d7f343cf1e038a93a54f8362e (patch)
treece48a510e90c7dede16f09951130b9ec11b5ee48 /net-misc
parentAdd systemd support (#506008 by Anthoine Bourgeois) (diff)
downloadgentoo-2-d8e5b41e31925f5d7f343cf1e038a93a54f8362e.tar.gz
gentoo-2-d8e5b41e31925f5d7f343cf1e038a93a54f8362e.tar.bz2
gentoo-2-d8e5b41e31925f5d7f343cf1e038a93a54f8362e.zip
Fix systemd support (#482690 by Yichao Zhou)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/isatapd/ChangeLog10
-rw-r--r--net-misc/isatapd/files/isatapd.service-r115
-rw-r--r--net-misc/isatapd/files/isatapd.service.conf30
-rw-r--r--net-misc/isatapd/isatapd-0.9.7-r1.ebuild35
4 files changed, 88 insertions, 2 deletions
diff --git a/net-misc/isatapd/ChangeLog b/net-misc/isatapd/ChangeLog
index def8fd688768..4b2c5eecbb75 100644
--- a/net-misc/isatapd/ChangeLog
+++ b/net-misc/isatapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/isatapd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/isatapd/ChangeLog,v 1.2 2013/09/28 11:18:07 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/isatapd/ChangeLog,v 1.3 2014/03/30 10:09:14 pacho Exp $
+
+*isatapd-0.9.7-r1 (30 Mar 2014)
+
+ 30 Mar 2014; Pacho Ramos <pacho@gentoo.org> +files/isatapd.service-r1,
+ +files/isatapd.service.conf, +isatapd-0.9.7-r1.ebuild:
+ Fix systemd support (#482690 by Yichao Zhou)
*isatapd-0.9.7 (28 Sep 2013)
diff --git a/net-misc/isatapd/files/isatapd.service-r1 b/net-misc/isatapd/files/isatapd.service-r1
new file mode 100644
index 000000000000..d1caf3bc1f90
--- /dev/null
+++ b/net-misc/isatapd/files/isatapd.service-r1
@@ -0,0 +1,15 @@
+[Unht]
+Description=ISATAP Client for Linux
+After=network.target nss-lookup.target
+
+[Service]
+ExecStart=/usr/sbin/isatapd ${DAEMON_OPTS} \
+ --interval ${ISATAP_INTERVAL} \
+ --name ${ISATAP_NAME} \
+ --link ${ISATAP_LINK} \
+ --mtu ${ISATAP_MTU} \
+ --check-dns ${ISATAP_CHECK_DNS} \
+ ${ISATAP_ROUTERS}
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/isatapd/files/isatapd.service.conf b/net-misc/isatapd/files/isatapd.service.conf
new file mode 100644
index 000000000000..87fe0be4a23d
--- /dev/null
+++ b/net-misc/isatapd/files/isatapd.service.conf
@@ -0,0 +1,30 @@
+[Service]
+# A space separated list of one or more hostnames/IPv4 addresses to use as
+# potential routers.
+# The default is the unqualified hostname 'isatap'
+Environment="ISATAP_ROUTERS=isatap"
+
+# Interval in seconds to send router solicitations.
+# Default (unset): 'auto'
+Environment="ISATAP_INTERVAL=auto"
+
+# Interval in seconds to check for DNS changes. Set to 0 to disable.
+# Default: 3600
+Environment="ISATAP_CHECK_DNS=3600"
+
+# Link tunnel to device
+# Default (unset): automatically find outgoing device
+Environment="ISATAP_LINK=auto"
+
+# The name of the ISATAP tunnel device
+# Default is 'is0' if ISATAP_LINK is unset and 'is_${ISATAP_LINK}' otherwise.
+Environment="ISATAP_NAME=auto"
+
+# IPv6 MTU of the created ISATAP tunnel interface. The IPv4 path to
+# the ISATAP router and all other ISATAP clients should be able to
+# handle at least MTU+20 bytes.
+# The minimum IPv6 MTU (1280 Bytes) is the safest choice here
+Environment="ISATAP_MTU=1280"
+
+# Additional options, see isatapd(8) for details
+Environment="DAEMON_OPTS="
diff --git a/net-misc/isatapd/isatapd-0.9.7-r1.ebuild b/net-misc/isatapd/isatapd-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..605ad3fb7995
--- /dev/null
+++ b/net-misc/isatapd/isatapd-0.9.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/isatapd/isatapd-0.9.7-r1.ebuild,v 1.1 2014/03/30 10:09:14 pacho Exp $
+
+EAPI=5
+inherit linux-info systemd
+
+DESCRIPTION="creates and maintains an ISATAP tunnel (rfc5214)"
+HOMEPAGE="http://www.saschahlusiak.de/linux/isatap.htm"
+SRC_URI="http://www.saschahlusiak.de/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~TUN"
+ERROR_TUN="CONFIG_TUN is needed for isatapd to work"
+
+src_prepare() {
+ sed -e '/^opts/s:opts:extra_started_commands:' \
+ -i openrc/isatapd.init.d || die
+}
+
+src_install() {
+ default
+
+ newinitd openrc/isatapd.init.d isatapd
+ newconfd openrc/isatapd.conf.d isatapd
+ systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf
+}