summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-11-25 19:41:04 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-11-25 19:41:04 +0000
commitc9d07f4ccc7f02aff42076c7eed653dd26f02862 (patch)
tree58e5951f354bf4a852b3488a3a01fcecf3bbbb9f /net-misc
parentMake dbus a PDEP + test dep since upstream no longer links to the library. Ad... (diff)
downloadgentoo-2-c9d07f4ccc7f02aff42076c7eed653dd26f02862.tar.gz
gentoo-2-c9d07f4ccc7f02aff42076c7eed653dd26f02862.tar.bz2
gentoo-2-c9d07f4ccc7f02aff42076c7eed653dd26f02862.zip
move kernel check under the modules use flag for bug 491844
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvswitch/ChangeLog6
-rw-r--r--net-misc/openvswitch/openvswitch-1.11.0.ebuild6
-rw-r--r--net-misc/openvswitch/openvswitch-2.0.0.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/net-misc/openvswitch/ChangeLog b/net-misc/openvswitch/ChangeLog
index 2748379c16be..08686a23567d 100644
--- a/net-misc/openvswitch/ChangeLog
+++ b/net-misc/openvswitch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openvswitch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.16 2013/11/25 16:43:10 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.17 2013/11/25 19:41:04 prometheanfire Exp $
+
+ 25 Nov 2013; Matthew Thode <prometheanfire@gentoo.org>
+ openvswitch-1.11.0.ebuild, openvswitch-2.0.0.ebuild:
+ move kernel check under the modules use flag for bug 491844
25 Nov 2013; Matthew Thode <prometheanfire@gentoo.org>
files/ovsdb-server_conf2, openvswitch-2.0.0.ebuild:
diff --git a/net-misc/openvswitch/openvswitch-1.11.0.ebuild b/net-misc/openvswitch/openvswitch-1.11.0.ebuild
index e72ee77b740b..adc65d7db1e8 100644
--- a/net-misc/openvswitch/openvswitch-1.11.0.ebuild
+++ b/net-misc/openvswitch/openvswitch-1.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-1.11.0.ebuild,v 1.2 2013/09/14 09:30:50 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-1.11.0.ebuild,v 1.3 2013/11/25 19:41:04 prometheanfire Exp $
EAPI=5
@@ -39,12 +39,12 @@ pkg_setup() {
if use modules ; then
CONFIG_CHECK+=" ~!OPENVSWITCH"
linux-mod_pkg_setup
+ kernel_is ge 2 6 18 || die "Linux >=2.6.18 and <3.2.9 required"
+ kernel_is lt 3 9 || die "Linux >=2.6.18 and <3.9 required"
else
CONFIG_CHECK+=" ~OPENVSWITCH"
linux-info_pkg_setup
fi
- kernel_is ge 2 6 18 || die "Linux >=2.6.18 and <3.2.9 required"
- kernel_is lt 3 9 || die "Linux >=2.6.18 and <3.9 required"
use monitor && python-single-r1_pkg_setup
}
diff --git a/net-misc/openvswitch/openvswitch-2.0.0.ebuild b/net-misc/openvswitch/openvswitch-2.0.0.ebuild
index 89dfe532d42a..d33e32f1f67a 100644
--- a/net-misc/openvswitch/openvswitch-2.0.0.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.0.0.ebuild,v 1.3 2013/11/25 16:43:10 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.0.0.ebuild,v 1.4 2013/11/25 19:41:04 prometheanfire Exp $
EAPI=5
@@ -38,13 +38,13 @@ BUILD_TARGETS="all"
pkg_setup() {
if use modules ; then
CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 2 6 32 || die "Linux >=2.6.32 and <3.10 required"
+ kernel_is lt 3 11 || die "Linux >=2.6.18 and <3.11 required"
linux-mod_pkg_setup
else
CONFIG_CHECK+=" ~OPENVSWITCH"
linux-info_pkg_setup
fi
- kernel_is ge 2 6 32 || die "Linux >=2.6.32 and <3.10 required"
- kernel_is lt 3 11 || die "Linux >=2.6.18 and <3.11 required"
use monitor && python-single-r1_pkg_setup
}