summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 12:45:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 12:45:27 +0000
commit99b74aff96de977f2acfe748cbbc654087ec17e4 (patch)
tree4f871a8af0fb4270c658a610cf1f53a2478fb5da /net-misc
parentBump to libgksu-2.0.12-r1 (diff)
downloadgentoo-2-99b74aff96de977f2acfe748cbbc654087ec17e4.tar.gz
gentoo-2-99b74aff96de977f2acfe748cbbc654087ec17e4.tar.bz2
gentoo-2-99b74aff96de977f2acfe748cbbc654087ec17e4.zip
Version bump.
(Portage version: 15196-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/neon/ChangeLog8
-rw-r--r--net-misc/neon/neon-0.29.3.ebuild104
2 files changed, 111 insertions, 1 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index d72e4757c112..5c2153c78945 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.148 2010/01/07 15:56:39 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.149 2010/01/12 12:45:27 arfrever Exp $
+
+*neon-0.29.3 (12 Jan 2010)
+
+ 12 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +neon-0.29.3.ebuild:
+ Version bump.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org> neon-0.29.2.ebuild:
Transfer Prefix keywords
diff --git a/net-misc/neon/neon-0.29.3.ebuild b/net-misc/neon/neon-0.29.3.ebuild
new file mode 100644
index 000000000000..deed4395c769
--- /dev/null
+++ b/net-misc/neon/neon-0.29.3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.3.ebuild,v 1.1 2010/01/12 12:45:27 arfrever Exp $
+
+EAPI="2"
+
+inherit autotools libtool versionator
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc expat gnutls kerberos libproxy nls pkcs11 ssl zlib"
+IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
+for lingua in ${IUSE_LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+unset lingua
+RESTRICT="test"
+
+RDEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ gnutls? (
+ >=net-libs/gnutls-2.0
+ pkcs11? ( dev-libs/pakchois )
+ )
+ !gnutls? ( ssl? (
+ >=dev-libs/openssl-0.9.6f
+ pkcs11? ( dev-libs/pakchois )
+ ) )
+ kerberos? ( virtual/krb5 )
+ libproxy? ( net-libs/libproxy )
+ nls? ( virtual/libintl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local lingua linguas
+ for lingua in ${IUSE_LINGUAS}; do
+ use linguas_${lingua} && linguas+=" ${lingua}"
+ done
+ sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
+
+ AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ if has_version sys-libs/glibc; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=" --enable-threadsafe-ssl=posix"
+ fi
+
+ if use expat; then
+ myconf+=" --with-expat"
+ else
+ myconf+=" --with-libxml2"
+ fi
+
+ if use gnutls; then
+ myconf+=" --with-ssl=gnutls --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use ssl; then
+ myconf+=" --with-ssl=openssl"
+ fi
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with kerberos gssapi) \
+ $(use_with libproxy) \
+ $(use_enable nls) \
+ $(use_with pkcs11 pakchois) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-lib install-headers install-config install-nls || die "emake install failed"
+
+ if use doc; then
+ emake DESTDIR="${D}" install-docs || die "emake install-docs failed"
+ fi
+
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
+ doman doc/man/*.[1-8]
+}
+
+pkg_postinst() {
+ ewarn "Neon has a policy of breaking API across minor versions, this means"
+ ewarn "that any package that links against Neon may be broken after"
+ ewarn "updating. They will remain broken until they are ported to the"
+ ewarn "new API. You can downgrade Neon to the previous version by doing:"
+ ewarn
+ ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
+ ewarn
+ ewarn "You may also have to downgrade any package that has not been"
+ ewarn "ported to the new API yet."
+}