summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-24 12:23:25 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-24 12:23:25 +0000
commit6d56d2cfe981eb2e1c75ec31bca9d1cebe894bd7 (patch)
tree044243969f4f958225341de9380f83fca523181a /net-misc
parentAdd pygobject dependency (bug #514818, thanks to Patrick Lauer). (diff)
downloadgentoo-2-6d56d2cfe981eb2e1c75ec31bca9d1cebe894bd7.tar.gz
gentoo-2-6d56d2cfe981eb2e1c75ec31bca9d1cebe894bd7.tar.bz2
gentoo-2-6d56d2cfe981eb2e1c75ec31bca9d1cebe894bd7.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/ChangeLog7
-rw-r--r--net-misc/youtube-dl/youtube-dl-2014.06.24.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-misc/youtube-dl/ChangeLog b/net-misc/youtube-dl/ChangeLog
index e1f8f6f92484..095c501960c4 100644
--- a/net-misc/youtube-dl/ChangeLog
+++ b/net-misc/youtube-dl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/youtube-dl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.349 2014/06/23 13:06:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.350 2014/06/24 12:23:25 jer Exp $
+
+*youtube-dl-2014.06.24.1 (24 Jun 2014)
+
+ 24 Jun 2014; Jeroen Roovers <jer@gentoo.org> +youtube-dl-2014.06.24.1.ebuild:
+ Version bump.
23 Jun 2014; Jeroen Roovers <jer@gentoo.org> youtube-dl-2014.06.19.ebuild:
Stable for HPPA (bug #512600).
diff --git a/net-misc/youtube-dl/youtube-dl-2014.06.24.1.ebuild b/net-misc/youtube-dl/youtube-dl-2014.06.24.1.ebuild
new file mode 100644
index 000000000000..608854194d09
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2014.06.24.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.06.24.1.ebuild,v 1.1 2014/06/24 12:23:25 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_6,2_7,3_3,3_4})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
+HOMEPAGE="http://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ local xxx=(
+ extremetube fourtube hentaistigma mofosex pornhd pornhub pornotube
+ redtube slutload spankwire thisav trutube tube8 xbef xhamster xnxx
+ xtube xvideos youjizz youporn
+ )
+ sed -i -e $( printf '/%s/d;' ${xxx[@]} ) youtube_dl/extractor/__init__.py || die
+ rm $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ test/test_age_restriction.py || die
+ fi
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}