summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-07-12 14:06:27 +0000
committerRoy Marples <uberlord@gentoo.org>2006-07-12 14:06:27 +0000
commit6b5fc2d7851fca420a6fd5a5644432dfe438ee2b (patch)
treef15c6b5c4153acc026fdcd2c62e05f77143cbc99 /net-misc
parentQA: Added gtk to IUSE. (diff)
downloadgentoo-2-6b5fc2d7851fca420a6fd5a5644432dfe438ee2b.tar.gz
gentoo-2-6b5fc2d7851fca420a6fd5a5644432dfe438ee2b.tar.bz2
gentoo-2-6b5fc2d7851fca420a6fd5a5644432dfe438ee2b.zip
New version to fix ARP timeouts, #137800 and hopefully -O3 on PPC, #139179.
(Portage version: 2.1.1_pre2-r7)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.8.ebuild49
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-2.0.83
3 files changed, 58 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index cd27dde88a9a..3afa27f7f709 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.99 2006/06/23 10:39:24 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.100 2006/07/12 14:06:26 uberlord Exp $
+
+*dhcpcd-2.0.8 (12 Jul 2006)
+
+ 12 Jul 2006; Roy Marples <uberlord@gentoo.org> +dhcpcd-2.0.8.ebuild:
+ New version to fix ARP timeouts, #137800 and hopefully -O3 on PPC, #139179.
*dhcpcd-2.0.7 (23 Jun 2006)
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.8.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.8.ebuild
new file mode 100644
index 000000000000..e6f0d08517a7
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-2.0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.8.ebuild,v 1.1 2006/07/12 14:06:27 uberlord Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A DHCP client only"
+HOMEPAGE="http://developer.berlios.de/projects/dhcpcd/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build debug static"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+pkg_setup() {
+ if use debug ; then
+ ewarn "WARNING: dhcpcd will provide good debugging output with the"
+ ewarn "debug USE flag enabled but will not actually configure the"
+ ewarn "interface or setup /etc/resolv.conf"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Redefine the location of ntp.drift
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
+}
+
+src_compile() {
+ use static && append-flags -static
+ econf $(use_enable debug) || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dosbin src/dhcpcd || die
+
+ if ! use build ; then
+ dodoc AUTHORS ChangeLog NEWS README
+ doman src/dhcpcd.8
+ fi
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8 b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8
new file mode 100644
index 000000000000..2177e02191bf
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8
@@ -0,0 +1,3 @@
+MD5 ec91c33b6d9cb46a42f9564e573fd249 dhcpcd-2.0.8.tar.bz2 125090
+RMD160 719d65e257bea28db58a0ee6a4c200da88e616d2 dhcpcd-2.0.8.tar.bz2 125090
+SHA256 bf7b09f26be60485d888f88f63688d16feeb022cd7954cfc05a912e273757db1 dhcpcd-2.0.8.tar.bz2 125090