summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2007-01-16 03:29:50 +0000
committerGustavo Felisberto <humpback@gentoo.org>2007-01-16 03:29:50 +0000
commit3c90dc08b9316b88c70a387473fd71b39d4c05d8 (patch)
tree29c8880e6700128c364352c6cf3bda5f86c1c847 /net-misc
parentsh stable (diff)
downloadgentoo-2-3c90dc08b9316b88c70a387473fd71b39d4c05d8.tar.gz
gentoo-2-3c90dc08b9316b88c70a387473fd71b39d4c05d8.tar.bz2
gentoo-2-3c90dc08b9316b88c70a387473fd71b39d4c05d8.zip
bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vidalia/ChangeLog10
-rw-r--r--net-misc/vidalia/files/digest-vidalia-0.0.103
-rw-r--r--net-misc/vidalia/vidalia-0.0.10.ebuild42
-rw-r--r--net-misc/vidalia/vidalia-0.0.8.ebuild6
4 files changed, 56 insertions, 5 deletions
diff --git a/net-misc/vidalia/ChangeLog b/net-misc/vidalia/ChangeLog
index 33b8acc82f46..4519061d7a0d 100644
--- a/net-misc/vidalia/ChangeLog
+++ b/net-misc/vidalia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vidalia
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.4 2006/10/12 01:08:08 weeve Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.5 2007/01/16 03:29:50 humpback Exp $
+
+*vidalia-0.0.10 (16 Jan 2007)
+
+ 16 Jan 2007; Gustavo Felisberto <humpback@gentoo.org>;
+ vidalia-0.0.8.ebuild, +vidalia-0.0.10.ebuild:
+ Bump
12 Oct 2006; Jason Wever <weeve@gentoo.org> vidalia-0.0.8.ebuild:
Added ~sparc keyword.
diff --git a/net-misc/vidalia/files/digest-vidalia-0.0.10 b/net-misc/vidalia/files/digest-vidalia-0.0.10
new file mode 100644
index 000000000000..1f78fe20561d
--- /dev/null
+++ b/net-misc/vidalia/files/digest-vidalia-0.0.10
@@ -0,0 +1,3 @@
+MD5 e52e4d2b3a434d4fca09fa657855115a vidalia-0.0.10.tar.gz 1767174
+RMD160 08b88ec0b91776bee640842214dd5643a5f49aaa vidalia-0.0.10.tar.gz 1767174
+SHA256 5dc50c736e41772d11ce8064bb7820c8b1861c868dc349d4728b695ed155d1fa vidalia-0.0.10.tar.gz 1767174
diff --git a/net-misc/vidalia/vidalia-0.0.10.ebuild b/net-misc/vidalia/vidalia-0.0.10.ebuild
new file mode 100644
index 000000000000..af8027bb21ff
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.0.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.0.10.ebuild,v 1.1 2007/01/16 03:29:50 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="http://www.vidalia-project.net/"
+SRC_URI="http://www.vidalia-project.net/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=">=x11-libs/qt-4.1.1"
+RDEPEND="${DEPEND}
+ >=net-misc/tor-0.1.1.20"
+
+pkg_setup() {
+ if use debug && ! built_with_use ">=x11-libs/qt-4.1.1" debug; then
+ eerror "In order to have debug support for Vidalia"
+ eerror "you need to compile Qt 4 with debug support too."
+ die "Qt 4 built without debug support"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "To have vidalia starting tor you probably have to copy
+ /etc/tor/torrc.sample to the users \$HOME/.tor/torrc and comment the settings
+ there and change the socks. Also in vidalia change the default user under
+ wich tor will run"
+}
diff --git a/net-misc/vidalia/vidalia-0.0.8.ebuild b/net-misc/vidalia/vidalia-0.0.8.ebuild
index e0ed9f2dd1ca..0b3a387af978 100644
--- a/net-misc/vidalia/vidalia-0.0.8.ebuild
+++ b/net-misc/vidalia/vidalia-0.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.0.8.ebuild,v 1.2 2006/10/12 01:08:08 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.0.8.ebuild,v 1.3 2007/01/16 03:29:50 humpback Exp $
inherit eutils
@@ -36,7 +36,7 @@ src_install() {
pkg_postinst() {
ewarn "To have vidalia starting tor you probably have to copy
- /etc/tor/torrc.sample to the users $HOME/.tor/torrc and comment the settings
+ /etc/tor/torrc.sample to the users \$HOME/.tor/torrc and comment the settings
there and change the socks. Also in vidalia change the default user under
wich tor will run"
}